Windows 7 64bit and XBMC problem

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
xbs08 Offline
Posting Freak
Posts: 1,709
Joined: May 2008
Reputation: 7
Location: Portugal
Post: #31
Jezz_X Wrote:lol guess you didn't read what I wrote proper Smile


And yes I know the screenshot is window mode else you would not be able to tell its windows 7 it would just look like xbmc Smile

XBMC info will report the OS installed (atleast mine does)

  • Intel NUC Kit DN2820FYKH
  • Crucial DDR3L SO-DIMM 4GB
  • SanDisk ReadyCache 32GB SSD
  • Microsoft MCE model 1039 RC6 remote
find quote
KriLL3 Offline
Junior Member
Posts: 11
Joined: Jan 2009
Reputation: 0
Post: #32
Jezz_X Wrote:In window mode it tends to stutter alot and use more cpu but my guess is thats the Aero interface and those small little windows being rendered slowing it down.

I have the same result with multiple screens, windowed mode is slower than fullscreen, and with multiple screens aero is still rendered when running it fullscreen, it's some bug with xbmc.
find quote
Stencil Offline
Junior Member
Posts: 3
Joined: Oct 2008
Reputation: 0
Post: #33
Video stutters in fullscreen mode only, plays fine when XBMC is windowed.

Running on 64bit Windows 7 build 7000, Intel E8500, Radeon 4850 with catalyst 8.12 drivers, 4GB RAM

http://pastebin.com/m3bd75295

Any help would be appreciated
find quote
Stencil Offline
Junior Member
Posts: 3
Joined: Oct 2008
Reputation: 0
Post: #34
Video stutters in fullscreen mode only, plays fine when XBMC is windowed or when any other window is overlaying the fullscreen mode.

Running on 64bit Windows 7 build 7000, Intel E8500, Radeon 4850 with catalyst 8.12 drivers & CCC, 4GB RAM

http://pastebin.com/m3bd75295

Any help would be appreciated
find quote
Jester Offline
XBMC for iOS* forums Moderator
Posts: 980
Joined: Oct 2008
Reputation: 10
Post: #35
Stencil Wrote:Video stutters in fullscreen mode only, plays fine when XBMC is windowed or when any other window is overlaying the fullscreen mode.

Running on 64bit Windows 7 build 7000, Intel E8500, Radeon 4850 with catalyst 8.12 drivers & CCC, 4GB RAM

http://pastebin.com/m3bd75295

Any help would be appreciated

i've merged this with the correct thread, next time, search first !

Current XBMC Platform: ATV2
Extra XBMC Platform: Raspberry Pi
Read the iOS FAQ
find quote
Nuka1195 Offline
Skilled Python Coder
Posts: 3,910
Joined: Dec 2004
Reputation: 18
Post: #36
i have xbmc running fine in windows 7 64bit, but the python24.dll will not load.

has anyone got python working in windows 7 64 bit?

For python coding questions first see http://mirrors.xbmc.org/docs/python-docs/
find quote
Evil Elvis Offline
Junior Member
Posts: 36
Joined: Dec 2008
Reputation: 0
Post: #37
Nuka1195 Wrote:i have xbmc running fine in windows 7 64bit, but the python24.dll will not load.

has anyone got python working in windows 7 64 bit?

Try copying msvcr71.dll and msvcp71.dll from your \xbmc\setup directory to the windows\system32 directory?

I've had problems before with the win32dll loader that xbmc uses not correctly finding them in that directory.
find quote
Nuka1195 Offline
Skilled Python Coder
Posts: 3,910
Joined: Dec 2004
Reputation: 18
Post: #38
thanks, unfortunately, that didn't work.

does python load for you?

For python coding questions first see http://mirrors.xbmc.org/docs/python-docs/
find quote
Evil Elvis Offline
Junior Member
Posts: 36
Joined: Dec 2008
Reputation: 0
Post: #39
Try opening a cmd line, and tying this:
Code:
regsvr32 "c:\windows\System32\msvcr71.dll"
regsvr32 "c:\windows\System32\msvcp71.dll"

I just recently had the same problem under Vista x64 and XP x86 (I just reinstalled XP because of this problem and some sound issues). Python was working on XP, and then it just stopped working. Moving those dll's did the trick for me.

Check out this thread:
http://forum.xbmc.org/showthread.php?tid...t=imagelib

Use the Dependency Walker program to find out what dll's it can't find. It listed a few besides msvcp71.dll for me (an encryption dll and a java dll), which I'm assuming were located somewhere in xbmc.
find quote
Nuka1195 Offline
Skilled Python Coder
Posts: 3,910
Joined: Dec 2004
Reputation: 18
Post: #40
thank you,

i tried putting them in the xbmc/system folder, they needed to be in the python subfolder of xbmc/system.

python works good now Smile

For python coding questions first see http://mirrors.xbmc.org/docs/python-docs/
find quote
Evil Elvis Offline
Junior Member
Posts: 36
Joined: Dec 2008
Reputation: 0
Post: #41
About the various video problems on Win7 x64:

The beta/preview ATi drivers for x64 don't include OpenGL 2.0 drivers. You won't be able to launch XBMC with these drivers. The 8.12 vista x64 drivers - which do include the OpenGL 2.0 - evidently don't jive well with win7, which is causing problems.

Switching to win7 x86 and using the beta/preview drivers is probably the best option for now.
find quote
Stencil Offline
Junior Member
Posts: 3
Joined: Oct 2008
Reputation: 0
Post: #42
The new Catalyst 9.1 Drivers for Vista 64 seem to have fixed the problems I was having.
find quote
phistyle Offline
Junior Member
Posts: 30
Joined: Oct 2008
Reputation: 0
Post: #43
i installed the latest catalyst vista 64bit drivers on windows 7 64bit and I'm getting nothing but flickering in full screen mode..windowed mode works fine but full screen mode is unbearable...I'm on a DFI 790gx amd board with ati hd3300 integrated graphics. any help would be appreciated...
find quote
xbox1 Offline
Member
Posts: 50
Joined: Sep 2008
Reputation: 0
Post: #44
I used ATOM 330 + INTEL 945G +2G MEMORY
IN XP OR VISTA XBMC 8.1 IS OK

BUT IN WINDOWS 7 B7000

IT HAVE SOME ERROR INFO ON STARTING XBMC.EXE

ADDRESS 0X00000000 IS CAN;T BE READ 0X00000000......
find quote
spartacus Offline
Junior Member
Posts: 1
Joined: Feb 2009
Reputation: 0
Post: #45
Hi everyone. I found this xbmc forum thread from a google search as I have been having a terrible time with the fullscreen flickering on Windows 7.

I have a fix for it (taken from overclock.net--props to micam93 who found it):

http://www.overclock.net/windows/458892-...ost5634802
Grab RivaTuner and:

[Image: rivatuner1.png]
[Image: rivatuner3.png]

Reinstalled XBMC and fullscreen mode is now flicker free!
(This post was last modified: 2009-02-22 02:43 by spartacus.)
find quote