XBMC keeps minimizing when in fullscreen

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ADA2D Offline
Junior Member
Posts: 16
Joined: Aug 2009
Reputation: 0
Post: #1
Somewhere between Alpha1 and Alpha2, my copy of XBMC has started minimizing itself anytime I switch to another application.

Prior to this I have been running XBMC for about two months in a dual screen setup with no issues. XBMC would stay full screen on Monitor2 while I could run Windows XP applications on Monitor1.

Now, anytime I try to do anything on Monitor1, XBMC minimizes on Monitor2 and all I see is the desktop wallpaper.

Is there anyway to keep XBMC in fullscreen mode on monitor2 all the time??
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #2
It did it in alpha1 as well.

You can turn it off in alpha2, however.

Settings->Appearance->Screen->Use fullscreen window instead of true fullscreen.

Cheers
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
Scott R Offline
Fan
Posts: 315
Joined: Feb 2008
Reputation: 0
Post: #3
I'm glad I found this thread. This seems to fix my problem as well. I am launching MPC-HC as an external player. With Camelot, when closing MPC-HC XBMC stays minimized. This was not a problem with Babylon. Anyways, by setting XBMC to run in Windowed mode, this seems to fix the problem. And it also has the nice side effect of making the jump to MPC-HC more seamless (it doesn't show the Windows desktop at all in between).

Is there any downside to running in Windowed mode?
find quote
ADA2D Offline
Junior Member
Posts: 16
Joined: Aug 2009
Reputation: 0
Post: #4
jmarshall Wrote:It did it in alpha1 as well.

You can turn it off in alpha2, however.

Settings->Appearance->Screen->Use fullscreen window instead of true fullscreen.

Cheers
Jonathan

I don't see this option... Under the Screen Menu I can see Resolution, Display Blanking, Video Calibration..., Test Patterns..., and Vertical Blank Sync.

Under Resolution I have the following options: "1024x768 @ 60.00 - Full Screen", "800x600 @ 60.00 - Full Screen #2" and Windowed.

Is "Windowed" what you are referring to? If so is there any way to get rid of blue bar at the top of the screen?

I am currently running Camelot Alpha2 Rev24543 with Aeon Hitched skin...
(This post was last modified: 2009-11-15 09:37 by ADA2D.)
find quote
Scott R Offline
Fan
Posts: 315
Joined: Feb 2008
Reputation: 0
Post: #5
Yes, per my post above yours, I believe he was referring to "Windowed" mode. If by the "blue bar" you mean the title bar of the XBMC window, after you switch to Windowed mode, you probably need to then maximize the XBMC window. That should hide the menu bar and any window borders (or perhaps it just moves it into the overscan area - in which case maybe you need to adjust your video settings outside of XBMC to give yourself some overscan?). In my case, the Windows Start menu bar at the bottom of the screen was visible, so I then set that to "auto-hide".
(This post was last modified: 2009-11-16 16:59 by Scott R.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #6
There was a bug in alpha2 that prevented the option showing up. You need to add <videoscreen><fakefullscreen>true</fakefullscreen></videoscreen> to advancedsettings.xml

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
ADA2D Offline
Junior Member
Posts: 16
Joined: Aug 2009
Reputation: 0
Post: #7
Ok... I've added the string to advancedsettings.xml and XBMC is no longer minimizing when using other apps on Monitor1.

Under Appearance -> Screen I am using Full Screen #2 again and have no title bars!!

One more minor issue though is that every time I restart XBMC (which thankfully isn't too often) I have to reset video calibration... Is there anyway to make the settings stick permanently??
find quote