Audio Delay on Unpause

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
FriendlyG Offline
Junior Member
Posts: 27
Joined: Oct 2012
Reputation: 0
Post: #16
Same here, on Eden in OSX. 2011 i5 mac mini
find quote
Piers Offline
Donor
Posts: 936
Joined: Jan 2011
Reputation: 30
Post: #17
Same on XBMC 8 up to Frodo RC1. Also same on Windows XP, Vista, 7 and 8.

If you've found this post helpful please click on the +/-

HP N54L | 5450 | 2 GB RAM | 28TB HDD/NAS | STR-DH750 | Samsung UE46F5000
AMD GPU Guide & Best Practice | Metro Icon Generator
find quote
Trike Offline
Junior Member
Posts: 15
Joined: Dec 2012
Reputation: 0
Post: #18
Figure I report in as well. I'm also having the same issue. Has anybody figured out how to fix this or a workaround to keep the stream alive when resuming/fwd/rwd/ etc... ?
I'm on a ASRock A75M with a A6-3500 cpu.
find quote
bossanova808 Online
Donor
Posts: 2,182
Joined: Sep 2009
Reputation: 32
Location: Melbourne, Australia
Post: #19
I use the 'jump back on unpause' addon to get over this. Although it seems to break Live-TV pause, sigh.

http://wiki.xbmc.org/index.php?title=Add...e_Jumpback

My XBMC stuff:
find quote
Trike Offline
Junior Member
Posts: 15
Joined: Dec 2012
Reputation: 0
Post: #20
I was messing around with stuff last night and I fixed it on my A75M board. It makes XBMC feel so much more refined without that handshaking issue.
I never mentioned it, but I'm running the release version of Frodo.

What I did was:
Install the latest ATI drivers AND added this to my advancedsettings.xml
<advancedsettings>
<audio>
<streamsilence>1</streamsilence>
</audio>
</advancedsettings>

I found the setting here. http://wiki.xbmc.org/index.php?title=Aud...gure_audio

I don't think the driver update necessarily fixed it, but I'm pretty sure setting the streamsilence to 1 fixed it.
find quote
bilybob Offline
Junior Member
Posts: 11
Joined: Jun 2011
Reputation: 0
Post: #21
<streamsilence>1</streamsilence>

This fixed the issue for me as well.
find quote
bluenote Offline
Senior Member
Posts: 288
Joined: May 2010
Reputation: 0
Post: #22
I got a nice new receiver from just having soundcard driven speakers and I suffer from this problem. So far the streamsilence setting has not fixed it.

If anyone is monitoring this thread who it did work for, are you using WASAPI or directsound or what?

EDIT: Although I remember having to switch sound types previously to solve another prob lem, it seems that switching to WASAPI and using the streamsilence setting works for me. Hopefully the previous issue (I forget what it was) does not recur Smile

Anyways thanks for the solution!
(This post was last modified: 2013-08-17 08:27 by bluenote.)
find quote
Post Reply