How do i install a repository!?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
MrPresidento Offline
Junior Member
Posts: 7
Joined: Jun 2011
Reputation: 0
Post: #1
hi i just bought a mac, never had it before...
ive downloaded xbmc 10.1 for mac and trust me, ive googled everywere and searched on youtube, im getting really frustated so im begging... pls help me!
im trying to install a repository, the SVN Repo installer, to get the itunes trailers.
but how the hell do i do that, everywere i search it tells me that you have to install the "zip" file, but i dont have a zip file, its a folder!
i even made it to a zip and when i install nothing appears....
can someone pls give me a nooby tutorial pls....
2 days ive struggled Sad really need help.
thanks alot for all the little help i can get
/philippe antonio
find quote
pecinko Offline
Donor
Posts: 3,805
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #2
Welcome to forums:-)

Safari unzip it by default.

Safari-Preferences-General and uncheck "Open "safe" files..."

That will leave your zip alone. You can install the repo from addon settings ->install from zip

My skins:

Amber
Quartz

find quote
MrPresidento Offline
Junior Member
Posts: 7
Joined: Jun 2011
Reputation: 0
Post: #3
thanks for the answer, but i dont get it like a zip file, just as a folder with other folders inside....
thats the problem....
Sad
can you give me an adress from were i can download a zip file?
because everywere i download it from, even if it says zip file it download it as a folder.... so i cant find a zip file when im going to install it....
thanks guys!
find quote
MrPresidento Offline
Junior Member
Posts: 7
Joined: Jun 2011
Reputation: 0
Post: #4
ahaaaaaa, i think i get it now... will test that thing you said!
find quote
MrPresidento Offline
Junior Member
Posts: 7
Joined: Jun 2011
Reputation: 0
Post: #5
Ive come this far, as how to install the zip file.... I go to add ons install the zip file.... Then nothing happens... I go to video and dont se any other repo than the xbmc one... What am i doing wrong?
But i do have a zip file now that i did not had before thanks to the first reply, thanks!
Help pls.
find quote
eTip Offline
Senior Member
Posts: 139
Joined: Apr 2011
Reputation: 0
Post: #6
Sounds like you've installed the repo, now you need to install the Addon:

Settings > Add-ons > Get Add-ons >

Now select the Repo you installed previously, then the Type of Addon (Music, Video, etc.). Finally, select the Addon then "Install". NOW you should be able to go to Videos (or Music, etc) > Addons and find the Addon you installed.
(This post was last modified: 2011-06-27 01:07 by eTip.)
find quote
pecinko Offline
Donor
Posts: 3,805
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #7
What repo are you trying to install?

My skins:

Amber
Quartz

find quote
ccrg75 Offline
Junior Member
Posts: 3
Joined: Jun 2011
Reputation: 0
Post: #8
The same thing is happening to me. I downloaded Xbmc for mac a couple days ago, and everything works fine besides when I try to install new repositories. I download the links from the wiki page (for example) and go to addons, install from zip file, I find the file and select "ok"... Nothing happens... no window pops up down in the corner saying that it worked or didn't work and theres no new repository is added. No idea what to do now, and can't find anything online about it. Please help
find quote
Euphoria Offline
Junior Member
Posts: 1
Joined: Oct 2011
Reputation: 0
Post: #9
ccrg75 Wrote:The same thing is happening to me. I downloaded Xbmc for mac a couple days ago, and everything works fine besides when I try to install new repositories. I download the links from the wiki page (for example) and go to addons, install from zip file, I find the file and select "ok"... Nothing happens... no window pops up down in the corner saying that it worked or didn't work and theres no new repository is added. No idea what to do now, and can't find anything online about it. Please help

Did you ever find a solution to this. I know EXACTLY what you are experiencing. I'm having the same thing on my Mac. For a while I thought it was just installing from the .zip very quickly then I pulled up some how-to videos and supposedly it shows this little window saying it's installing. I don't get that and in turn, no add-ons.

Would appreciate any guidance!
Thanks
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,902
Joined: Jan 2011
Reputation: 274
Location: Arizona, USA
Post: #10
Without debug logs there's not much we can do for anyone in this thread.

http://forum.xbmc.org/showthread.php?tid=47124
find quote
sire Offline
Junior Member
Posts: 1
Joined: Dec 2011
Reputation: 0
Post: #11
I am a mac noob and I had the same problem. Downloaded the "ZIP" repo or add-on but would not install. Tried pecinko's tip and all seems to be working fine. Thankyou.
find quote
Chris! Offline
Donor
Posts: 1,012
Joined: Apr 2010
Reputation: 16
Location: England
Post: #12
Just to push the Wiki a bit:
http://wiki.xbmc.org/index.php?title=Add-on

including how to install repositories.


Flirc now has a forum: forum.flirc.tv
find quote