XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)

  Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
meikelmoeller Offline
Junior Member
Posts: 8
Joined: Feb 2011
Reputation: 0
Location: Ruhrpott, Germany
Post: #2281
(2013-05-07 10:24)mulb Wrote:  Hello,

I'm using constellation on iPad and iPhone for several years, and it's a magical tool!! thanks.

Since I upgraded to the latest version last week, I lost all my radio favorites, and there's no list of radios anymore.

It was very useful to start radio without turning on TV.

Is there a reason why this list disappeared?

Regards
Damien

Same problem, the latest update (yesterday) does not fix the issue. Please solve the problem. Listening to radio without switching on the TV is important for me.
find quote
dracula Offline
Junior Member
Posts: 38
Joined: Jul 2012
Reputation: 0
Location: NL
Post: #2282
Radio stations non-functional
Seek/progress bar visual glitch
Picture files not 'playing'

Issues still present after latest update.

OS: Windows 7 64-bit
XBMC: Frodo 12
Skin: Confluence
find quote
dak999 Offline
Junior Member
Posts: 1
Joined: May 2013
Reputation: 0
Post: #2283
I've been patient. I've paid for additional features that were removed and not refunded without complaining. I have waited for the promised replacement features to justify taking my cash without any evidence such promises will be kept and not kicked up a fuss. But the loss of quality frequently now being delivered is finally forcing me to stop using this app.

The continued loss of the playlist feature is the final straw. It failed to function 2 updates back on both my iPhone 5 and iPad 2. I can see on this forum that other users have also lost this feature, so it is not isolated to just my devices. Quite how such a significant feature for this app can fail to be tested within an update is appalling. That it has remained broken after the latest update now forces me to use alternatives.

I have followed the forum recently expecting to see news of work to restore the playlist, but instead all I read is that the developers are very busy with their other projects. So busy that when they do decide to update this product, they break one of its main functions and seem not to even notice. That being the case, then I see no reason why I should accept such poor service and quality, and will be requesting all my money back.

This used to be a great app. That makes the decline that has been in evidence now for many months frustrating, but with no indication that the trend is likely to change I do not see any point in trying to sweeten my message with useless platitudes.
find quote
xuanvu Offline
Junior Member
Posts: 10
Joined: Jan 2009
Reputation: 0
Post: #2284
It has been broken (empty playlist) for 2 months and no fix, no words?
find quote
wellspokenman Offline
Senior Member
Posts: 117
Joined: Jul 2012
Reputation: 1
Post: #2285
It would appear the users of this product have been abandoned. So long as nobody here bought the app that's not such a big deal I guess. It's pretty lame for those of us who bought it though.
find quote
formula Offline
Member
Posts: 78
Joined: Oct 2011
Reputation: 0
Post: #2286
can someone give me an example of how commands management are typed in for instance updating movie library as my movies are on a separate hard drive so it would be (E:\My Movies) so how would that look in the commands option !
find quote
flippertygibble Offline
Junior Member
Posts: 9
Joined: Jul 2012
Reputation: 0
Post: #2287
Ok, I've finally managed to get a GREEN LIGHT using Constellation 2.8.2 with Frodo 12.2 (dream combo). Thank you Archigos. The problem now is that XBMC Constellation crashes shortly after startup. I have tried using experimental sync but to no avail. So I was wondering...is there a log file for XBMC Constellation? If so, where is it?

Thanks...

Ps - if anyone is wondering how I got the green light, it was an XBMC setting :-

SYSTEM ---> Services ---> Remote Control ---> Allow program's on other systems to control XBMC = enabled

Edit >>> I tried upgrading to latest version of Constellation and it's now stable...except the Playlist isn't populating (see above). So close...
(This post was last modified: 2013-05-29 22:46 by flippertygibble.)
find quote
formula Offline
Member
Posts: 78
Joined: Oct 2011
Reputation: 0
Post: #2288
(2013-05-27 12:46)formula Wrote:  can someone give me an example of how commands management are typed in for instance updating movie library as my movies are on a separate hard drive so it would be (E:\My Movies) so how would that look in the commands option !

is there anyone here that could help me with this !
find quote
wellspokenman Offline
Senior Member
Posts: 117
Joined: Jul 2012
Reputation: 1
Post: #2289
(2013-05-04 11:30)wellspokenman Wrote:  
(2013-05-01 17:28)wellspokenman Wrote:  I have all my folder.jpg in banner format for TV shows but constellation only sees one of them. I've deleted and reinstalled the app, and set the xbmc host to force banner, but still get no tv show banners from the app. The folder.jpgs work in windows, linux and xbmc. ideas?

The folders that don't work have quite a few images in there:
Code:
fanart.jpg
season1-poster.jpg
season0-poster.jpg
logo.png
folder.jpg
season01.tbn
clearart.png
season5-poster.jpg
season03.tbn
season02.tbn
tvshow.nfo
season-specials.tbn
season05.tbn
season2-poster.jpg
landscape.jpg
poster.jpg
season4-poster.jpg
theme.mp3
season3-poster.jpg
season04.tbn
banner.jpg
season-all.tbn
The new one that works has only folder.jpg and fanart.jpg. I guess maybe Constellation could be getting confused by the presence of both banner.jpg and folder.jpg, but some tips would be greatly appreciated before I start deleting all my tv show art files. I thought that it only looked for folder.jpg?

The folder.jpg in the problem shows are in banner format and they display correctly upon entering the tv show in Constellation. Also works in XBMC, so the files are definitely good. It's just the Constellation TV show list that shows up with almost no images displayed.

This is still a problem. Been waiting for well over a month now, as has everyone else. Yes I paid for the app and yes I posted it on your completely dead support forums.
find quote
JamiePhonic Offline
Junior Member
Posts: 9
Joined: Jun 2013
Reputation: 0
Post: #2290
OK, so I've been coming close to tearing my hair out over this for the past week or so, so i thought i would stop here first.
I've been running XBMC on raspberry pi and thought I'd give constellation a go, i quite like it, although the playlist wont populate. other than that, its fine Smile

I then thought I'd give it a go with my windows desktop. for some reason, the JSON RPC wont connect. I tried changing the port to no avail, so i enabled debug logging and saw that it was giving an error about no Bluetooth socket, so i plugged in an old Bluetooth dongle i had and now that's gone, but it still wont connect.

Im running constellation 2.8.21 and XBMC (12.2 Git:20130502-32b1a5e), Built on May 2 2013 (compiler 1600), on Windows 7 SP1 64-bit, build 7601.
its not the firewall because i disabled it to check, and port 9090 isn't being used by any other program (nor is 8585, the alternative port i tried) (i used tcp view to check)

its a shame because i really like this app and was considering going pro, but until this is fixed, its not happening Sad
(This post was last modified: 2013-06-11 21:43 by JamiePhonic.)
find quote
JamiePhonic Offline
Junior Member
Posts: 9
Joined: Jun 2013
Reputation: 0
Post: #2291
(2013-06-11 20:25)formula Wrote:  
(2013-05-27 12:46)formula Wrote:  can someone give me an example of how commands management are typed in for instance updating movie library as my movies are on a separate hard drive so it would be (E:\My Movies) so how would that look in the commands option !

is there anyone here that could help me with this !

as far as i know, as long as the folder has been added to your videos sources and it's content has been set to movies, it should be updated when you run a library update.

as for custom commands, ive been playing with that myself and got nowhere.
from what i can tell, it's probably under the built in functions somewhere.
find quote
Archigos Offline
Donor
Posts: 581
Joined: Jan 2006
Reputation: 6
Location: Upstate New York
Post: #2292
(2013-05-22 00:38)dak999 Wrote:  I've been patient. I've paid for additional features that were removed and not refunded without complaining. I have waited for the promised replacement features to justify taking my cash without any evidence such promises will be kept and not kicked up a fuss. But the loss of quality frequently now being delivered is finally forcing me to stop using this app.

The continued loss of the playlist feature is the final straw. It failed to function 2 updates back on both my iPhone 5 and iPad 2. I can see on this forum that other users have also lost this feature, so it is not isolated to just my devices. Quite how such a significant feature for this app can fail to be tested within an update is appalling. That it has remained broken after the latest update now forces me to use alternatives.

I have followed the forum recently expecting to see news of work to restore the playlist, but instead all I read is that the developers are very busy with their other projects. So busy that when they do decide to update this product, they break one of its main functions and seem not to even notice. That being the case, then I see no reason why I should accept such poor service and quality, and will be requesting all my money back.

This used to be a great app. That makes the decline that has been in evidence now for many months frustrating, but with no indication that the trend is likely to change I do not see any point in trying to sweeten my message with useless platitudes.
Trust me, I know the disappointing feeling... I'll state again for those that didn't read far enough back, but I do NOT work for FSS (the app creators) but have been essentially their lead tech support because I like the app so much. Things regarding my health have kept me from being as active as I used to here (and the fact that I'm working on some of my own projects again) but you're right, the latest beta I have (that came after the last update in the AppStore) as far as I know still does not have a working playlist. I think the reality with that feature being overlooked isn't a 'screw you' to the users, but more of a 'we don't use that feature' so it's not as actively checked. I tried contacting Dawid again before making this point so I could at least relay some information (good or bad) but was unable to reach him.

(2013-05-25 18:00)xuanvu Wrote:  It has been broken (empty playlist) for 2 months and no fix, no words?
See above.

(2013-05-25 18:09)wellspokenman Wrote:  It would appear the users of this product have been abandoned. So long as nobody here bought the app that's not such a big deal I guess. It's pretty lame for those of us who bought it though.
I paid for the app (and all the extras) just like most of the users here... granted it sucks when an app 'dies' but as far as I know they still have intentions to continue adding too it, fixing things, etc. so even though I spent the money, I got great use of it (still do) and don't feel like I've been abandoned. I'm not making excuses for them, I'm not promising they even care anymore, but the beta testers do still see new versions come out on occasion which implies they didn't just 'give up'.

(2013-05-27 12:46)formula Wrote:  can someone give me an example of how commands management are typed in for instance updating movie library as my movies are on a separate hard drive so it would be (E:\My Movies) so how would that look in the commands option !
If your movies on your E drive are scanned into your library the same as the others, you don't need to call a special command to update that specifically since "Update Video Library" does all TV and Movie sources found in XBMC. If you check out XBMC's wiki there may be a way to update specific parts like your asking and if you can find that page and PM me a link to it, I'll create a little walk through on how to do it.

(2013-05-29 21:05)flippertygibble Wrote:  Ok, I've finally managed to get a GREEN LIGHT using Constellation 2.8.2 with Frodo 12.2 (dream combo). Thank you Archigos. The problem now is that XBMC Constellation crashes shortly after startup. I have tried using experimental sync but to no avail. So I was wondering...is there a log file for XBMC Constellation? If so, where is it?

Thanks...
You're welcome... as always, if I helped a user, it'd be great if they hit the little 'reputation' button to add to that.

(2013-06-11 21:04)wellspokenman Wrote:  
(2013-05-04 11:30)wellspokenman Wrote:  
(2013-05-01 17:28)wellspokenman Wrote:  I have all my folder.jpg in banner format for TV shows but constellation only sees one of them. I've deleted and reinstalled the app, and set the xbmc host to force banner, but still get no tv show banners from the app. The folder.jpgs work in windows, linux and xbmc. ideas?

The folders that don't work have quite a few images in there:
Code:
fanart.jpg
season1-poster.jpg
season0-poster.jpg
logo.png
folder.jpg
season01.tbn
clearart.png
season5-poster.jpg
season03.tbn
season02.tbn
tvshow.nfo
season-specials.tbn
season05.tbn
season2-poster.jpg
landscape.jpg
poster.jpg
season4-poster.jpg
theme.mp3
season3-poster.jpg
season04.tbn
banner.jpg
season-all.tbn
The new one that works has only folder.jpg and fanart.jpg. I guess maybe Constellation could be getting confused by the presence of both banner.jpg and folder.jpg, but some tips would be greatly appreciated before I start deleting all my tv show art files. I thought that it only looked for folder.jpg?

The folder.jpg in the problem shows are in banner format and they display correctly upon entering the tv show in Constellation. Also works in XBMC, so the files are definitely good. It's just the Constellation TV show list that shows up with almost no images displayed.

This is still a problem. Been waiting for well over a month now, as has everyone else. Yes I paid for the app and yes I posted it on your completely dead support forums.
I'll take a look at this when I get back home since I have essentially the same folder structure... I just never really used banners in Constellation except to initially test it when the added the feature (and it worked back then by grabbing banner.jpg). I haven't tried it since so it might take me a bit to fiddle around with it. I'll try to respond by tomorrow at the latest for you.

That also reminds me, the 'completely dead support forums' are hosted by me and the reason I haven't been in there to help is I had a little issue with one of the databases and it gets hammered with spam signups so much I truthfully got a little pissed and started to ignore it. I apologize for that and after I try to fix your image issue I'll get back into the forum and see if I can straighten some of that out as well.

(2013-06-11 21:13)JamiePhonic Wrote:  OK, so I've been coming close to tearing my hair out over this for the past week or so, so i thought i would stop here first.
I've been running XBMC on raspberry pi and thought I'd give constellation a go, i quite like it, although the playlist wont populate. other than that, its fine Smile

I then thought I'd give it a go with my windows desktop. for some reason, the JSON RPC wont connect. I tried changing the port to no avail, so i enabled debug logging and saw that it was giving an error about no Bluetooth socket, so i plugged in an old Bluetooth dongle i had and now that's gone, but it still wont connect.

Im running constellation 2.8.21 and XBMC (12.2 Git:20130502-32b1a5e), Built on May 2 2013 (compiler 1600), on Windows 7 SP1 64-bit, build 7601.
its not the firewall because i disabled it to check, and port 9090 isn't being used by any other program (nor is 8585, the alternative port i tried) (i used tcp view to check)

its a shame because i really like this app and was considering going pro, but until this is fixed, its not happening Sad
If I'm reading this correctly, Constellation connects to your RaspberryPi no problem, but not to the Windows desktop. If that's the case in XBMC* (on Windows) go into the "Settings => Services => Webserver" and make sure that the port listed is not the same as it is on Rasp. then in "Remote Control" make sure both items are checked. Also, a good tip (not sure if it matters) make sure the "Device Name" is unique also.

Now, for a simple test, make sure XBMC is NOT running on the RaspberryPi (this is just to check the port) and IS running on your Windows system. Remove and re-add the host in Constellation for your Windows machine and see if it connects. If it does, start XBMC on the Raspberry and see if you can change between the hosts. If you have issues with any of this, you can feel free to PM me with the details and we can try to get it working.

*Note: These directions may be slightly different based on what skin you are using.

(2013-06-11 22:01)JamiePhonic Wrote:  
(2013-06-11 20:25)formula Wrote:  
(2013-05-27 12:46)formula Wrote:  can someone give me an example of how commands management are typed in for instance updating movie library as my movies are on a separate hard drive so it would be (E:\My Movies) so how would that look in the commands option !

is there anyone here that could help me with this !

as far as i know, as long as the folder has been added to your videos sources and it's content has been set to movies, it should be updated when you run a library update.

as for custom commands, ive been playing with that myself and got nowhere.
from what i can tell, it's probably under the built in functions somewhere.
You're correct that it's a built in function. The custom commands are for advanced things that most people wont need/use and most of the 'common' tasks should be found under built in. Sorry I didn't see this message before when I answered Jamie specifically above. Credit goes to you. Smile

------
As always, users can feel free to PM me in regards to Constellation if they need help. But just remember, I don't work for FSS and don't have access to the source code, so for example, the playlist feature, there's really nothing I can do about that, but I can help you troubleshoot your connection and things of that nature.

HTPC 1: Quad Core 3.06GHz, 16GB DDR3, (6) 2TB + (3) 1TB, 42" Vizio, Windows 8 Pro (x64), IIS 8 <- Died Jan. 10, 2013
HTPC 2: Dual Core 2.6GHz, 4GB DDR3, 640GB, Windows 8 Pro (x64)
My Personal Blog - Constellation Forums - NewsDemon
find quote
JamiePhonic Offline
Junior Member
Posts: 9
Joined: Jun 2013
Reputation: 0
Post: #2293
(2013-06-12 02:14)Archigos Wrote:  
(2013-06-11 21:13)JamiePhonic Wrote:  OK, so I've been coming close to tearing my hair out over this for the past week or so, so i thought i would stop here first.
I've been running XBMC on raspberry pi and thought I'd give constellation a go, i quite like it, although the playlist wont populate. other than that, its fine Smile

I then thought I'd give it a go with my windows desktop. for some reason, the JSON RPC wont connect. I tried changing the port to no avail, so i enabled debug logging and saw that it was giving an error about no Bluetooth socket, so i plugged in an old Bluetooth dongle i had and now that's gone, but it still wont connect.

Im running constellation 2.8.21 and XBMC (12.2 Git:20130502-32b1a5e), Built on May 2 2013 (compiler 1600), on Windows 7 SP1 64-bit, build 7601.
its not the firewall because i disabled it to check, and port 9090 isn't being used by any other program (nor is 8585, the alternative port i tried) (i used tcp view to check)

its a shame because i really like this app and was considering going pro, but until this is fixed, its not happening Sad
If I'm reading this correctly, Constellation connects to your RaspberryPi no problem, but not to the Windows desktop. If that's the case in XBMC* (on Windows) go into the "Settings => Services => Webserver" and make sure that the port listed is not the same as it is on Rasp. then in "Remote Control" make sure both items are checked. Also, a good tip (not sure if it matters) make sure the "Device Name" is unique also.

Now, for a simple test, make sure XBMC is NOT running on the RaspberryPi (this is just to check the port) and IS running on your Windows system. Remove and re-add the host in Constellation for your Windows machine and see if it connects. If it does, start XBMC on the Raspberry and see if you can change between the hosts. If you have issues with any of this, you can feel free to PM me with the details and we can try to get it working.

*Note: These directions may be slightly different based on what skin you are using.

wierd... that worked. thank you so much :-)
find quote
Archigos Offline
Donor
Posts: 581
Joined: Jan 2006
Reputation: 6
Location: Upstate New York
Post: #2294
Most people forget that for 'external' apps like Constellation you have to manually tell XBMC to allow other things to control it. Smile

HTPC 1: Quad Core 3.06GHz, 16GB DDR3, (6) 2TB + (3) 1TB, 42" Vizio, Windows 8 Pro (x64), IIS 8 <- Died Jan. 10, 2013
HTPC 2: Dual Core 2.6GHz, 4GB DDR3, 640GB, Windows 8 Pro (x64)
My Personal Blog - Constellation Forums - NewsDemon
find quote
JamiePhonic Offline
Junior Member
Posts: 9
Joined: Jun 2013
Reputation: 0
Post: #2295
(2013-06-12 02:26)Archigos Wrote:  Most people forget that for 'external' apps like Constellation you have to manually tell XBMC to allow other things to control it. Smile

everything else was already set, the only thing i did was change the http port from 8080 to 8081 (and the json port to 9091 just in case)
is that not on the documentation? if you have more than one XBMC box, assign them different http ports?
find quote
Post Reply