Sandybridge H264 dxva

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #1
People with Intel Sandybridge, can you try if these dll's solve your H264 dxva2 problem:
http://www.speedyshare.com/files/29293622/.libs.rar
(edited with new link, I spotted a small error I made).
Use with official Dharma 10.1 (not nightly builds).
(This post was last modified: 2011-07-05 07:36 by thespecialist.)
find quote
NicoP Offline
Junior Member
Posts: 3
Joined: Jul 2011
Reputation: 0
Post: #2
I'll give it a try today after work on my i7-2600k sandybridge setup and write the results here.
find quote
phusebox Offline
Junior Member
Posts: 13
Joined: Jul 2011
Reputation: 0
Post: #3
Still hoping for someone to test it in the next couple of hours, that would be just in time for me to cancel my i3 order...
find quote
NicoP Offline
Junior Member
Posts: 3
Joined: Jul 2011
Reputation: 0
Post: #4
Tested your dll today, still the same issue.
Did the testing on my i7-2600k running Windows 7 64bit.

Placed the avcodec-52.dll file in C:\Program Files (x86)\XBMC\system\players\dvdplayer\ where it seems to be the only file with avcodec-52.dll as filename.
Is the avcodec.dll to be used anywhere?
find quote
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #5
Yeah, I heard from others the same thing. It was the most obvious thing that could have caused the problem, too bad it's not that. I'll try to fix up a new dll, today or tomorrow, with another idea. If that doesn't work either, I'm going to give up, since it's too inconvenient to fix it without having an Intel chipset myself.
find quote
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #6
Ok, please see if this solves it: http://www.speedyshare.com/files/2930759...dec-52.rar

It might be possible that when you skip in the video, you'll see the issue for a few seconds and then it (hopefully) disappears. Or is that also the case anyway with the original version ?
find quote
NicoP Offline
Junior Member
Posts: 3
Joined: Jul 2011
Reputation: 0
Post: #7
just tried your new modified files - still the same issue im afraid.

Did some testing with the same movie and original vs your modified avcodec-52.dll and it seems to be precise same issues.

macroblocking all over, and if the camera clips to a completely new area the picture will be okay for 1 sec, and then start with all the macroblocking again.

When trying to skip in the video it gives me same issue as when a new scene/clip starts.

and this was same issue for both original + your dll.
find quote
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #8
NicoP Wrote:just tried your new modified files - still the same issue im afraid.

Did some testing with the same movie and original vs your modified avcodec-52.dll and it seems to be precise same issues.

macroblocking all over, and if the camera clips to a completely new area the picture will be okay for 1 sec, and then start with all the macroblocking again.

When trying to skip in the video it gives me same issue as when a new scene/clip starts.

and this was same issue for both original + your dll.

Ok, thanks for testing. Somebody told me that MPC-HC/FFMPEG worked ok for H264 on Sandybridge. So, then I checked the MPC-HC/FFMPEG code out and saw that they patched their FFMPEG H264 implementation a bit. So my last 2 dll's were based on that, but I just heard today from that guy that he had it wrong and that MPC-HC/FFMPEG didn't work either (which I had expected in the first place).

So in short, it seems there's no easy solution here and it's going to be hardcore debugging again. Since I have no Sandybridge myself, I'll leave it this time up to somebody else Smile
find quote
XBMCRocksMyBoat Offline
Junior Member
Posts: 26
Joined: Apr 2011
Reputation: 0
Post: #9
@theSpecialist

MPC-HC does work, if you try the nightly builds. I've tried it myself.
(This post was last modified: 2011-07-07 08:30 by XBMCRocksMyBoat.)
find quote
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #10
XBMCRocksMyBoat Wrote:@theSpecialist

MPC-HC does work, if you try the nightly builds. I've tried it myself.

I heard so, but then the guy said that it just shut downs DXVA.

You could verify with dxvachecker, with the 'trace' option, it logs DXVA calls.

Or, there's probably an option in MPC-HC to show all info on screen (like the O-key in xbmc).

And remember, we're talking about the FFMPEG (dxva) filter in MPC-HC (in MPC-HC you can also select another filter, which DOES work with dxva2 H264).
(This post was last modified: 2011-07-07 17:18 by thespecialist.)
find quote
XBMCRocksMyBoat Offline
Junior Member
Posts: 26
Joined: Apr 2011
Reputation: 0
Post: #11
thespecialist Wrote:I heard so, but then the guy said that it just shut downs DXVA.

You could verify with dxvachecker, with the 'trace' option, it logs DXVA calls.

Or, there's probably an option in MPC-HC to show all info on screen (like the O-key in xbmc).

And remember, we're talking about the FFMPEG (dxva) filter in MPC-HC (in MPC-HC you can also select another filter, which DOES work with dxva2 H264).

I've made this screenshot with only internal filters of MPC-HC and I've even blocked all external filters to be absolutely sure.

Here's the screenshot:
[Image: 25jlb2q.jpg]

As you can see, it works perfectly..
find quote
thespecialist Offline
Senior Member
Posts: 126
Joined: Mar 2007
Reputation: 0
Post: #12
Hmmm that looks good indeed. That's very interesting. There are more differences between the MPC-HC H264 ffmpeg code and the XBMC code than I have patched. I'd need a SB though to mess around ...

Hopefully someone *with* Sandybridge can use MPC-HC as a basis for the solution ...
find quote
alanwww1 Offline
Team-XBMC Member
Posts: 1,352
Joined: Nov 2008
Reputation: 33
Location: Hungary
Post: #13
Guys, I found one interesting changset in MPC-HC which might help us.

https://sourceforge.net/apps/trac/mpc-hc/changeset/2822

This is the release log:

http://www.xvidvideo.ru/media-player-cla...-2825.html

I was not able to get the files that actually changed, but you might have a better luck. Also maybe we could contact the developer who commited these changes.

Cheers, Alan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Valkyrie743 Offline
Junior Member
Posts: 43
Joined: May 2011
Reputation: 0
Location: Western Ny
Post: #14
Any updates to this ?

Main PC: Intel Core I7 2600K @ 4.5ghz, 8GB XMS3 @1600mhz, EVGA GTX 680 SC, Asus P8P67 Pro Rev 3.1, Corsair F120, WD 500GB, WD 1TB

HTPC: Intel Core I3 2100 @ 3.1ghz, 4GB XMS3 @1333mhz, ASUS, P6H61-I mini ITX, Seagate 20gb 5400rpm HDD, Antec ISK 300-150 (built in 150W psu)
find quote
PelleBert Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #15
I will (hopefully) soon get my new i3-2105 htpc and planned to try and fix this issue (since it works in mpc-hc it should be solvable).

thespecialist Would it be possible to get patches, or revisions from mpc-hc, of the things you've already tried so I don't need to test the same things again?
find quote
Post Reply