[solved] Current build from trunk - crash with smb

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #1
Hi Davilla, Memphiz, other developers

the current build from trunk (#e0ba636) doesnt work with mysql-db settings in advancedsettings.xml. It crashes right from the start. If I remove the mysql-settings everything works fine.

Debug Log: http://pastebin.com/MPQ5G58u

CrashReport: http://pastebin.com/s0dDqr6Z

The last known working build for me was #1c250ec.

Thanks for your help,
EmKay
(This post was last modified: 2011-07-21 17:22 by emkay.)
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #2
Did you build release or debug? Need this for symbolicating the crashlog ...

BTW it crash ins libsmbclient. Are you sure it has something to do with sql and not with your pass substitution?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2011-07-21 18:07 by Memphiz.)
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #3
I am building release. I did uncommenting on each of those sections. With the mysql-settings and without pathsubstitution it crashes, with pathsubstitution but without mysql-settings it works.

But you are right - it's always the thread with libsmbclient - in all crashreports. I will double check that now...

Thank you!

EmKay

EDIT: No, I was wrong. It crashes only when mysql AND pathsubstitution are active. When I disable either of those two it works. Which is logical: When I "remove" the library it will not try to load thumbs from smb...

So, yes, thumbs on SMB is the problem here...
(This post was last modified: 2011-07-21 18:23 by emkay.)
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #4
I tried to play a video via smb after disabling pathsubstitution and got another crash: http://pastebin.com/90MckwCW

So, there seems to be a general problem with smb - not only pathsubstitution.

EmKay
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #5
I think there is something with your build wrong tbh. The current trunk runs smooth for me. And there where no changes to libsmb. Did you do a clean build after the thread commits? Because it needed atleast a clean bootstrap...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #6
yes, did clean everything - in fact I deleted everything, just to be safe: the whole xbmc-folder and the xbmc-depends folder in Shared.

But I will try from scratch - again Wink

Thanks so far...
(This post was last modified: 2011-07-21 19:04 by emkay.)
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #7
stop!!!!!! ... can reproduce it now ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #8
Hey!

That's good - or is it Wink

I'm curious what the problem is...
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #9
builld the debug version if you are in hurry - otherwise jcarrol will fix this ... i trust him Big Grin

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #10
okay Smile

thank you very much, mate! Did you already inform him?

EmKay
(This post was last modified: 2011-07-21 20:18 by emkay.)
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #11
its fixed

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
emkay Offline
Donor
Posts: 107
Joined: Feb 2011
Reputation: 0
Location: Germany
Post: #12
Thanks again!
find quote
cf125 Offline
Member
Posts: 78
Joined: May 2011
Reputation: 0
Post: #13
is this the reason mine isnt working this is the thread about it:

http://forum.xbmc.org/showthread.php?tid=105994
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,159
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #14
nope...

ps: renamed the thread title because it was missleading

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2011-07-21 23:01 by Memphiz.)
find quote