blu-ray in 1080p with dts-hd and truehd

  Thread Rating:
  • 7 Votes - 4.43 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #46
bluray Wrote:when you select hdmi audio output in "control panel", it shouldn't greyed out as 7.0. you should be able to manually configure speaker configuration to "stereo". do not select 2.0, 5.1, 7.1, etc. don't confuse between xbmc audio output with audio output in control panel!

I'm really close, but now it's greyed out as 2.0. I didn't realize that was different than stereo.

[Image: watched-fanart.jpg]
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #47
Ok, I see what you're saying about the control panel. I have it configured exactly like you show in both the control panel and XBMC. I'm getting every playback except stereo and mono. Even in tv shows, like Andy Griffith, no audio.

[Image: watched-fanart.jpg]
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #48
Well, I just reinstalled the latest nightly and I'm pretty committed to only running this version on the rare occasion that I want DTS HD or TrueHD audio because it's not supporting anything below Dolby Digital for me.

[Image: watched-fanart.jpg]
find quote
bluray Offline
Posting Freak
Posts: 8,252
Joined: May 2011
Reputation: 144
Post: #49
clubwerks Wrote:Ok, I see what you're saying about the control panel. I have it configured exactly like you show in both the control panel and XBMC. I'm getting every playback except stereo and mono. Even in tv shows, like Andy Griffith, no audio.
did you select the proper hdmi audio output and configure speaker to stereo in control panel. in xbmc, after you selected hdmi with dts-hd/truehd, you shouldn't have any option to select 2.1/5.1/7.1.

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
bluray Offline
Posting Freak
Posts: 8,252
Joined: May 2011
Reputation: 144
Post: #50
meridius Wrote:Why would u disable smooth video playback in the ati setting a I have this enabled.

Does is make Amy difference and if so what

Cheers
i'm not sure why either. if it work out better for them when it is disabled, why not?

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #51
bluray Wrote:did you select the proper hdmi audio output and configure speaker to stereo in control panel. in xbmc, after you selected hdmi with dts-hd/truehd, you shouldn't have any option to select 2.1/5.1/7.1.

Yes, I configured the HDMI output to stereo in the control panel. All the options are showing like in the picture you show. In XBMC, the speaker is set to 2.0 and greyed out. I actually only have one HDMI output to select from, the same one you do, Realtek HDMI Audio (ATI HDMI Audio). Like I said, it works perfectly from DTSHDMA on down to Dolby Digital, but it won't pass stereo or mono from audio only or video files.

[Image: watched-fanart.jpg]
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #52
Also, the Realtek audio drivers link is just a continuous loop, but I'm sure I have the latest drivers.

Gigabyte 990FX MB
16G RAM
XFX 6670 Video Card

All the latest drivers installed yesterday for everything.

[Image: watched-fanart.jpg]
find quote
bluray Offline
Posting Freak
Posts: 8,252
Joined: May 2011
Reputation: 144
Post: #53
clubwerks Wrote:Also, the Realtek audio drivers link is just a continuous loop, but I'm sure I have the latest drivers.

Gigabyte 990FX MB
16G RAM
XFX 6670 Video Card

All the latest drivers installed yesterday for everything.
yes, you might need realtek codecs because it has the most codecs in it. the link work fine for me, and i just tried it. your htpc must have some kind of antivirus protection in it. the easiest way might be to goole it with these "download realtek had audio". or you can go directly to realtek.com to download it.

the 2.0 that is greyed out in xbmc meant that you're passthrough everything through hdmi to avr. it greyed out so that you don't try to select anything in that option!

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #54
OK, I was able to use IE9 and hack my way through that convoluted site to get the drivers. I'm assuming I wanted the first listing of 7 x64 exe R2.65?

[Image: watched-fanart.jpg]
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #55
No change. No output for stereo.

[Image: watched-fanart.jpg]
find quote
bluray Offline
Posting Freak
Posts: 8,252
Joined: May 2011
Reputation: 144
Post: #56
clubwerks Wrote:No change. No output for stereo.
let me ask you this- are you able to stereo sound window media player? just to verify that your htpc can output stereo without xbmc!

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #57
bluray Wrote:let me ask you this- are you able to stereo sound window media player? just to verify that your htpc can output stereo without xbmc!


I didn't try it in WMP, but I can play all those files from VLC or from a regular build of XBMC. Before two hours ago, I could play any of those files from the regular build of XBMC.

Yep, just tried it with WMP. Plays fine.

[Image: watched-fanart.jpg]
find quote
mkohman Offline
Member
Posts: 58
Joined: May 2010
Reputation: 0
Post: #58
bluray Wrote:did you select the proper hdmi audio output and configure speaker to stereo in control panel. in xbmc, after you selected hdmi with dts-hd/truehd, you shouldn't have any option to select 2.1/5.1/7.1.

yes all done correctly and your right you don't have the option in XBMC to select unless.. you check use exclusive mode Smile shall I not have that checked then?
find quote
bluray Offline
Posting Freak
Posts: 8,252
Joined: May 2011
Reputation: 144
Post: #59
mkohman Wrote:yes all done correctly and your right you don't have the option in XBMC to select unless.. you check use exclusive mode Smile shall I not have that checked then?
if it is passing through everything to your avr via hdmi, you shouldn't have to select the amount of channel output. your avr should be able to process whatever codecs that passthrough to it.

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
clubwerks Offline
Posting Freak
Posts: 841
Joined: Dec 2010
Reputation: 0
Post: #60
You're not going to believe this. In the audio menu watching a video, there's a volume control. My volume was set to 0.0 DB. It goes up to 0.4 DB which doesn't seem like enough adjustment. Plus, it only goes about halfway up the slider. But, hey, it's working.

[Image: watched-fanart.jpg]
find quote
Post Reply