ATV2 Dolby Digital not working!

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
vskatusa Offline
Fan
Posts: 353
Joined: Dec 2008
Reputation: 2
Post: #1
Hi,

I did not make any changes and I do not hear any sound thru my receiver for dolby digital movies anymore! it was working perfectly before and I have no idea why it stopped working! Movies with mp3 etc seem to work. Any clues how I can troubleshoot this?

My settings in ATV2 is 16 bit - Dolby Digital ON - HDMI Auto

Setup: ATV2 Via HDMI to Denon receiver - This setup worked perfectly before!
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,158
Joined: Feb 2011
Reputation: 109
Location: germany
Post: #2
before what?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Neerav Offline
Junior Member
Posts: 23
Joined: Dec 2010
Reputation: 0
Post: #3
vskatusa Wrote:Hi,

I did not make any changes and I do not hear any sound thru my receiver for dolby digital movies anymore! it was working perfectly before and I have no idea why it stopped working! Movies with mp3 etc seem to work. Any clues how I can troubleshoot this?

My settings in ATV2 is 16 bit - Dolby Digital ON - HDMI Auto

Setup: ATV2 Via HDMI to Denon receiver - This setup worked perfectly before!

try go into sound in xbmc and change from analog to HDMI and the sound should work on DTS and DD movies again.
find quote
vskatusa Offline
Fan
Posts: 353
Joined: Dec 2008
Reputation: 2
Post: #4
I had jailbrokern my ATV2 Long time back and have locked if from further updates and it worked perfectly with dolby digital. But now the dolby digital does not work (absolutely no sound). However AAC works.

My detailed environment.

ATV2 - Software jailbroken and updates blocked
ATV Software: 4.2.2 (2203)
OS Build Version: 4.3 (8F305)

ATV2 Audio Video Settings
Dolby Digital: on
Audio Output: 16 bit
HDMI: Auto

ATV2 -> HDMI -> DENON AVR Receiver 2807 -> hdmi to tv

guisettings.xml
<audiooutput>
<ac3passthrough>true</ac3passthrough>
<audiodevice>Default Output Device</audiodevice>
<channellayout>7</channellayout>
<dontnormalizelevels>true</dontnormalizelevels>
<dtspassthrough>true</dtspassthrough>
<mode>2</mode>
<passthroughaac>false</passthroughaac>
<passthroughmp1>false</passthroughmp1>
<passthroughmp2>false</passthroughmp2>
<passthroughmp3>false</passthroughmp3>
</audiooutput>

When I say "before" it was working...I did not make any changes to ATV2 software build.

When I change as follows
<ac3passthrough>false</ac3passthrough>
<dtspassthrough>false</dtspassthrough>

I can hear sound but not "dolby digital"!

If the above is true (this was the setup that always worked for me) I do not hear ANY sound. Normally the receiver will display "dolby digital" and I do not see it either if this true or false.

Any help to restore my Dolby Digital would be much appreciated.
(This post was last modified: 2011-09-17 17:14 by vskatusa.)
find quote
vskatusa Offline
Fan
Posts: 353
Joined: Dec 2008
Reputation: 2
Post: #5
I updated to the latest nightly build xbmc Pre-11.0 Git: 20110916-0c3e6a3 (compiled Sep 16, 2011) and the results are the same - no dolby digital!
find quote
vskatusa Offline
Fan
Posts: 353
Joined: Dec 2008
Reputation: 2
Post: #6
I am suspecting my DENON AVR 2807 now --- I tried a laptop (instead of atv2) and the dolby digital is not working either! Maybe the dolby digital stuff in my amp is broken! I dont know. totally confused now
find quote
vskatusa Offline
Fan
Posts: 353
Joined: Dec 2008
Reputation: 2
Post: #7
It was my mistake! Somehow the "auto" functionality in my AV receiver was off! Now I get dolby digital like a charm! Sorry for all the confusion Big Grin
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,387
Joined: Feb 2008
Reputation: 64
Post: #8
np, I have a Denon too, nice receiver but one of the most confusing to get setup that I've seen.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
S80_UK Offline
Donor
Posts: 102
Joined: Jan 2009
Reputation: 0
Location: Cambridgeshire, UK
Post: #9
Marantz can be just as bad Stare - they are a sister company of Denon so I presume they maybe share development resources.
find quote