[RELEASE] DFAtmo the driver for Atmolight controllers

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #31
@werwer

ok here are the steps for ubuntu:

Code:
# 1. Install prerequisites:
sudo apt-get install git build-essential fakeroot debhelper zip libusb-1.0-0-dev python-dev

# 1a. If you want to build the DFAtmo xinelib plugin do the following step
# Note: You need libxine 1.2 packages here!
sudo apt-get install libxine-dev

# 2. Change into your home dir
cd $HOME

# 3. Download DFAtmo files from git into sub dir dfatmo
# This has only to be done for the first time
git clone git@github.com:durchflieger/DFAtmo.git dfatmo

# 4. Change into project dir
cd dfatmo

# 5. If you want to update the project from git do the following step
git reset --hard
git pull

# 6. If you only want xbmc support without xinelib plugin do the following step
cp debian/control-dfatmo-only debian/control

# 7. Build debian packages
dpkg-buildpackage -b -D -tc -sd -us -uc

# 8. Install DFAtmo package
sudo dpkg -i ../dfatmo_0.1-0_i386.deb

# 8a. If you build the xinelib plugin install it with
sudo dpkg -i ../libxine-dfatmo-plugin_0.1-0_amd64.deb

# 9. Add permissions to access the serial port for the user who executes xbmc by adding him to group "dialout"
#    If you are logged in as this user log out/in again before executing xbmc.
sudo adduser <username> dialout

# 10. Next launch xbmc and install DFAtmo xbmc addon with the zip installation function of XBMC
# The zip is located at "/usr/lib/dfatmo/dfatmo-xbmc-addon.zip"

Go into the addon settings for DFAtmo and set:
driver -> serial
driver param -> /dev/ttyS0;proto=classic
areas -> top=1 left=1 right=1

Of course set driver param to your used serial port device.

Start the DFAtmo addon in xbmc.
Start watching a video -> light should go on

If you need you can configure the mapping from areas to controller channels
individually with the "proto:" option within driver_param.
Have a look into DFAtmo README how this works.
(This post was last modified: 2011-10-12 14:18 by durchflieger.)
find quote
werwer Offline
Junior Member
Posts: 34
Joined: Jun 2011
Reputation: 0
Post: #32
Thanks!!
unfortunately, in the step

# Build debian DFAtmo package:
dpkg-buildpackage -b -D -tc -sd -us -uc

it says that

dpkg-buildpackage: exportar «CFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «CPPFLAGS» de dpkg-buildflags (origen: «vendor»): «»
dpkg-buildpackage: exportar «CXXFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «FFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «LDFLAGS» de dpkg-buildflags (origen: «vendor»): «-Wl,-Bsymbolic-functions»
dpkg-buildpackage: paquete fuente dfatmo
dpkg-buildpackage: versión de las fuentes 0.1-0
dpkg-buildpackage: fuentes modificadas por Andreas Auras <yak54@inkennet.de>
dpkg-buildpackage: arquitectura del sistema i386
dpkg-source --before-build dfatmo
dpkg-checkbuilddeps: Dependencias de construcción no satisfechas: debhelper (>= 7)
dpkg-buildpackage: aviso: Las dependencias y conflictos de construcción no están satisfechas, cancelando.
dpkg-buildpackage: aviso: (Use la opción «-d» para anularlo.)

In english is something like
"
dpkg-checkbuilddeps: Dependencies of building not satisfied: debhelper (>= 7)
dpkg-buildpackage: warning: dependencies and building conflicts are not satisfied, cancelling"

what can i do?

i really appreciate your effort here.

Thanks again!!
(This post was last modified: 2011-10-11 22:55 by werwer.)
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #33
werwer Wrote:Thanks!!
unfortunately, in the step

# Build debian DFAtmo package:
dpkg-buildpackage -b -D -tc -sd -us -uc

it says that

dpkg-buildpackage: exportar «CFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «CPPFLAGS» de dpkg-buildflags (origen: «vendor»): «»
dpkg-buildpackage: exportar «CXXFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «FFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «LDFLAGS» de dpkg-buildflags (origen: «vendor»): «-Wl,-Bsymbolic-functions»
dpkg-buildpackage: paquete fuente dfatmo
dpkg-buildpackage: versión de las fuentes 0.1-0
dpkg-buildpackage: fuentes modificadas por Andreas Auras <yak54@inkennet.de>
dpkg-buildpackage: arquitectura del sistema i386
dpkg-source --before-build dfatmo
dpkg-checkbuilddeps: Dependencias de construcción no satisfechas: debhelper (>= 7)
dpkg-buildpackage: aviso: Las dependencias y conflictos de construcción no están satisfechas, cancelando.
dpkg-buildpackage: aviso: (Use la opción «-d» para anularlo.)

In english is something like
"
dpkg-checkbuilddeps: Dependencies of building not satisfied: debhelper (>= 7)
dpkg-buildpackage: warning: dependencies and building conflicts are not satisfied, cancelling"

what can i do?

i really appreciate your effort here.

Thanks again!!

Maybe package "debhelper" is missing. Install it with:
sudo apt-get install debhelper

There is another step you should do:
The user under which xbmc is executed should have permissions to access the serial port by adding him to the "dialout" group:
sudo adduser <username> dialout

If you are logged in as this user log out/in again before executing xbmc.
find quote
werwer Offline
Junior Member
Posts: 34
Joined: Jun 2011
Reputation: 0
Post: #34
OK, it seems that installing debhelper solved that issue. however, now i have another problem:

# Build debian DFAtmo package:
dpkg-buildpackage -b -D -tc -sd -us -uc

it says that

dpkg-buildpackage: exportar «CFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «CPPFLAGS» de dpkg-buildflags (origen: «vendor»): «»
dpkg-buildpackage: exportar «CXXFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «FFLAGS» de dpkg-buildflags (origen: «vendor»): «-g -O2»
dpkg-buildpackage: exportar «LDFLAGS» de dpkg-buildflags (origen: «vendor»): «-Wl,-Bsymbolic-functions»
dpkg-buildpackage: paquete fuente dfatmo
dpkg-buildpackage: versión de las fuentes 0.1-0
dpkg-buildpackage: fuentes modificadas por Andreas Auras <yak54@inkennet.de>
dpkg-buildpackage: arquitectura del sistema i386
dpkg-source --before-build dfatmo
fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
/usr/bin/make clean
make[1]: se ingresa al directorio «/home/htpc/dfatmo»
rm -f *.so* *.o dfatmo-xbmc-addon.zip
rm -rf ./build
make[1]: se sale del directorio «/home/htpc/dfatmo»
dh_clean
debian/rules build
dh_testdir
# Add here commands to configure the package.
touch configure-stamp
dh_testdir
# Add here commands to compile the package.
/usr/bin/make XINEPLUGINDIR=INEPLUGINDIR DFATMOINSTDIR="/usr"
make[1]: python-config: No se encontró el programa
make[1]: se ingresa al directorio «/home/htpc/dfatmo»
cc -g -O2 -O3 -fPIC -DOUTPUT_DRIVER_PATH='"/usr/lib/dfatmo/drivers"' -c -o atmodriver.o atmodriver.c
atmodriver.c:23:20: fatal error: Python.h: No existe el fichero o el directorio
compilation terminated.
make[1]: *** [atmodriver.o] Error 1
make[1]: se sale del directorio «/home/htpc/dfatmo»
make: *** [build-stamp] Error 2
dpkg-buildpackage: fallo: debian/rules build devolvió un estado de salida de error 2

something went wrong. what can i do?

i'm sorry to bother you againSad

Thanks again!!
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #35
@werwer

Could you please issue this command:

apt-cache showpkg xbmc


and post the output here.
find quote
werwer Offline
Junior Member
Posts: 34
Joined: Jun 2011
Reputation: 0
Post: #36
durchflieger Wrote:@werwer

Could you please issue this command:

apt-cache showpkg xbmc


and post the output here.

Of course:

Package: xbmc
Versions:
2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty (/var/lib/apt/lists/ppa.launchpad.net_team-xbmc_unstable_ubuntu_dists_natty_main_binary-i386_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_unstable_ubuntu_dists_natty_main_binary-i386_Packages
MD5: fe8a5d04c10ac9c610a143988630b0e5


Reverse Depends:
xbmc-live,xbmc 2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty
Dependencies:
2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty - xbmc-bin (2 2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty) xbmc-bin (3 2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty.1~) mesa-utils (0 (null)) x11-utils (0 (null)) ttf-liberation (0 (null)) ttf-dejavu-core (0 (null)) python-bluez (16 (null)) python-lightblue (0 (null)) python-imaging (0 (null)) python (0 (null)) python-support (2 0.90.0) xbmc-test-helper (0 (null)) python-qt3 (0 (null)) xbmc-data (0 (null)) xbmc-eventclients-common (0 (null)) xbmc-eventclients-dev (0 (null)) xbmc-eventclients-j2me (0 (null)) xbmc-eventclients-ps3 (0 (null)) xbmc-eventclients-xbmc-send (0 (null)) xbmc-skin-confluence (0 (null)) xbmc-standalone (0 (null)) xbmc-data (0 (null)) xbmc-eventclients-common (0 (null)) xbmc-eventclients-dev (0 (null)) xbmc-eventclients-j2me (0 (null)) xbmc-eventclients-ps3 (0 (null)) xbmc-eventclients-xbmc-send (0 (null)) xbmc-skin-confluence (0 (null)) xbmc-standalone (0 (null))
Provides:
2:11.0~git20111010.34f799e-0ubuntu1~ppa1~natty - xbmc-standalone xbmc-skin-confluence xbmc-eventclients-xbmc-send xbmc-eventclients-ps3 xbmc-eventclients-j2me xbmc-eventclients-dev xbmc-eventclients-common xbmc-data
Reverse Provides:


What can be happening?

Thanks for everything!!
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #37
@werwer

well i need this information to see which python version xbmc uses on natty.

I have updated some files in the git repo for the build process and updated the step by step description in the previous posting.

Please repeat the steps 1. 2. 4. 5. 6. ... 10. with the updated description.

I hope that it now should work for you.
find quote
werwer Offline
Junior Member
Posts: 34
Joined: Jun 2011
Reputation: 0
Post: #38
OK, now it compiles and I can install it!!

However, it does not work. The "proto=classic" in driver param send an error.
If i leave it as "/dev/ttyUSB0" it does some kind of flickering, but it does not change accordint the image, just flickers in blue and purple.

Changing some values in the config has no effect.

I don't know, maybe it just does not work with my hardware, maybe i have not configure the addon properly.
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #39
werwer Wrote:OK, now it compiles and I can install it!!

However, it does not work. The "proto=classic" in driver param send an error.
If i leave it as "/dev/ttyUSB0" it does some kind of flickering, but it does not change accordint the image, just flickers in blue and purple.

Changing some values in the config has no effect.

I don't know, maybe it just does not work with my hardware, maybe i have not configure the addon properly.

The "proto=classic" must be "proto:classic". But this is not the problem because if you leave it "proto:classic" is the default.
Is seams that momolight uses a different baudrate and a different protocol.
Please post your working boblight conf file. It should provide us with the necessary information.
find quote
tocinillo Offline
Fan
Posts: 304
Joined: Dec 2010
Reputation: 2
Post: #40
One question:

I tried to use "speed" option with DFAtmo Add-on, but seems that doesn't work correctly. Under driver_param I wrote:

"speed=19200"

Doesnt work...

With boblight I use this config:

boblight-X11 -f -x -o saturation=5 -o value=10 -o threshold=10 -o use=1 -o interpolation=1 -o autospeed=0.2 -o speed=30

How I use speed=30 in DFAtmo?

Thanks four your awesome work!
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #41
tocinillo Wrote:One question:

I tried to use "speed" option with DFAtmo Add-on, but seems that doesn't work correctly. Under driver_param I wrote:

"speed=19200"

Doesnt work...

With boblight I use this config:

boblight-X11 -f -x -o saturation=5 -o value=10 -o threshold=10 -o use=1 -o interpolation=1 -o autospeed=0.2 -o speed=30

How I use speed=30 in DFAtmo?

Thanks four your awesome work!

The correct syntax is: speed:19200

Please post your working boblight.conf
(This post was last modified: 2011-10-13 13:43 by durchflieger.)
find quote
tocinillo Offline
Fan
Posts: 304
Joined: Dec 2010
Reputation: 2
Post: #42
With syntaxis = speed:19200 it seems that work (no error message) but Atmolight doesn't work (doesn't power on).

My boblight.conf is:

Quote:[global]
interface 127.0.0.1
port 19333

[device]
name ambilight
type atmo
output /dev/ttyUSB0
rate 38400
channels 15
interval 16000
prefix FF

[color]
name red
rgb FF0000
gamma 1.0
adjust 1.0
blacklevel 0.0

[color]
name green
rgb 00FF00
gamma 1.0
adjust 1.0
blacklevel 0.0

[color]
name blue
rgb 0000FF
gamma 1.0
adjust 1.0
blacklevel 0.0

[light]
name left
color red ambilight 4
color green ambilight 5
color blue ambilight 6
hscan 0 50
vscan 0 100

[light]
name right
color red ambilight 7
color green ambilight 8
color blue ambilight 9
hscan 50 100
vscan 0 100

[light]
name top
color red ambilight 10
color green ambilight 11
color blue ambilight 12
hscan 0 100
vscan 0 50

[light]
name bottom
color red ambilight 13
color green ambilight 14
color blue ambilight 15
hscan 0 100
vscan 50 100

And for turn ON Atmolight I use my own script with Executor:

Quote:#!/bin/sh
boblightd -f > /dev/null 2>&1
export DISPLAY=:0.0
boblight-X11 -f -x -o saturation=5 -o value=10 -o threshold=10 -o use=1 -o interpolation=1 -o autospeed=0.2 -o speed=30> /dev/null 2>&1

Regards and thanks!
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #43
@tocinillo

what kind of atmolight controller do you use?

xbmc on Windows or Linux?
(This post was last modified: 2011-10-13 23:01 by durchflieger.)
find quote
tocinillo Offline
Fan
Posts: 304
Joined: Dec 2010
Reputation: 2
Post: #44
Atmolight from Carsten Presser, Win7 32 bits.

Thanks!
find quote
durchflieger Offline
Member
Posts: 63
Joined: Sep 2011
Reputation: 3
Post: #45
tocinillo Wrote:Atmolight from Carsten Presser, Win7 32 bits.

Thanks!

The baudrate for this controller should be 38400 (the default speed of DFAtmo).
Your boblight.conf seems to be a Linux version (/dev/ttyUSB0) Confused?
Area to channel mapping in your boblight.conf is not default. You
need to specify a corresponding proto: configuration (see below).
I assume you do not configure the correct COM port in driver param?

Code:
driver -> serial
driver param -> COM1;proto:255|0|0|15|Rl|Gl|Bl|Rr|Gr|Br|Rt|Gt|Bt|Rb|Gb|Bb|0|0|0
areas -> top 1, bottom 1, left 1, right 1
(This post was last modified: 2011-10-14 08:18 by durchflieger.)
find quote
Post Reply