Problem with directional controls and skipping

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Hitcher Online
Skilled Skinner
Posts: 10,872
Joined: Aug 2007
Reputation: 101
Location: Eastleigh, UK
Post: #1
I've got a problem with the TV Next layout I'm making for XeeBo when there's no info available for one of the days in the group and it's the one that has an ActivateWindow() control associated with it.

In the setup below list 202 has the <onleft>ActivateWindow(51)</onleft> control which works fine.
205 has <onright>206</onright> but because 206 isn't focusable XBMC then uses it's onright control which is <onright>200</onright> - again this works fine.

[Image: screenshot001wh.jpg]

The problem occurs when the non-focusable list is the one with <onleft>ActivateWindow(51)</onleft> control. In this case clicking left from list 200 which has <onleft>206</onleft> XBMC wont then use 206's onleft control and open window 51. Instead it just doesn't move.

[Image: screenshot000f.jpg]

Thanks.
find quote
`Black Offline
Team-Kodi Member
Posts: 2,436
Joined: Apr 2009
Reputation: 72
Location: Germany
Post: #2
The id's are not correct, monday is always 200, tuesday 201 etc... maybe that's the problem?

[Image: xp1080-21.png]
find quote
Hitcher Online
Skilled Skinner
Posts: 10,872
Joined: Aug 2007
Reputation: 101
Location: Eastleigh, UK
Post: #3
Sorry, should have mentioned that the labels aren't yet coded to behave the same way as the lists so ignore what they say.

The problem is XBMC doesn't or wont use the skipped item's controls if they're anything other than another controls ID.
(This post was last modified: 2011-10-19 19:40 by Hitcher.)
find quote
`Black Offline
Team-Kodi Member
Posts: 2,436
Joined: Apr 2009
Reputation: 72
Location: Germany
Post: #4
Ok that could indeed be a bug. Smile

[Image: xp1080-21.png]
find quote
pieh Offline
Team-Kodi Member
Posts: 672
Joined: Aug 2010
Reputation: 13
Location: Poland
Post: #5
Hitcher, do You have sample code to reproduce this problem?

---edit
oh, just realised what this is about - don't need samples - I can prepare them myslef now that I understand issue

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
(This post was last modified: 2011-10-20 12:09 by pieh.)
find quote
Hitcher Online
Skilled Skinner
Posts: 10,872
Joined: Aug 2007
Reputation: 101
Location: Eastleigh, UK
Post: #6
In case you still some sample code use the following for the last button in Confluence's VideoOSD.xml.

PHP Code:
            <control type="button" id="705">
                <
posx>180</posx>
                <
posy>0</posy>
                <
width>45</width>
                <
height>45</height>
                <
label>31355</label>
                <
font>-</font>
                <
texturefocus>OSDDvdFO.png</texturefocus>
                <
texturenofocus>OSDDvdNF.png</texturenofocus>
                <
onleft>704</onleft>
                <
onright>ActivateWindow(videos)</onright>
                <
onup>1000</onup>
                <
ondown>1000</ondown>
                <
onclick>PlayerControl(ShowVideoMenu)</onclick>
                <
animation effect="fade" start="100" end="50" time="100" condition="!VideoPlayer.HasMenu">Conditional</animation>
            </
control

You'll see that when you press right on the DVD menu button it will open up the Videos window but if you add back in the <enable> control (code code below) you'll get to the Bookmarks button and it wont let you skip and open Videos.

PHP Code:
            <control type="button" id="705">
                <
posx>180</posx>
                <
posy>0</posy>
                <
width>45</width>
                <
height>45</height>
                <
label>31355</label>
                <
font>-</font>
                <
texturefocus>OSDDvdFO.png</texturefocus>
                <
texturenofocus>OSDDvdNF.png</texturenofocus>
                <
onleft>704</onleft>
                <
onright>ActivateWindow(videos)</onright>
                <
onup>1000</onup>
                <
ondown>1000</ondown>
                <
onclick>PlayerControl(ShowVideoMenu)</onclick>
                <
enable>VideoPlayer.HasMenu</enable>
                <
animation effect="fade" start="100" end="50" time="100" condition="!VideoPlayer.HasMenu">Conditional</animation>
            </
control

Thanks.

EDIT: I also tried using a grouplist and adding <onleft>ActivateWindow(51)</onleft> control to that but that wont open the window at all.
(This post was last modified: 2011-10-20 17:41 by Hitcher.)
find quote
Hitcher Online
Skilled Skinner
Posts: 10,872
Joined: Aug 2007
Reputation: 101
Location: Eastleigh, UK
Post: #7
@pieh

Did you have a chance to see if this is fixable or not?

Thanks.
find quote
pieh Offline
Team-Kodi Member
Posts: 672
Joined: Aug 2010
Reputation: 13
Location: Poland
Post: #8
this is fixable, sure - I checked where the problem is but I don't think I will have time to come with acceptable solution earlier than next weekend

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
find quote
Hitcher Online
Skilled Skinner
Posts: 10,872
Joined: Aug 2007
Reputation: 101
Location: Eastleigh, UK
Post: #9
That's cool, no rush. I just wanted to know so I can carry on with my intended layout and not scrap it all together.

Thanks.
find quote
pieh Offline
Team-Kodi Member
Posts: 672
Joined: Aug 2010
Reputation: 13
Location: Poland
Post: #10
Hitcher Wrote:That's cool, no rush. I just wanted to know so I can carry on with my intended layout and not scrap it all together.

Thanks.
Few days late ... but still https://github.com/xbmc/xbmc/pull/518.

Also while I was messing with code - there seems to be workaround for this (in case our current behaviour will be considered as desired):
Instead of having <onleft>ActivateWindow(51)</onleft> in first column - make it go to button that will focus first focusable column from left and activate that window:
Code:
<onfocus condition="Control.IsVisible(200)">SetFocus(200)</onfocus>
up to
<onfocus condition="Control.IsVisible(206)">SetFocus(206)</onfocus>

and of course

<onfocus>ActivateWindow(51)</onfocus>

(I bet You had it figured out already, but thought I'll write it down just in case)

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
find quote