XBMC Nightlies Crashing on 1080p Playback

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #16
Sarlic Wrote:Memphiz:

I ran a completely new jailbreak/restore of ATV2 to AppleTV2,1_4.3_8F455. I then ran through the installation instructions in the FAQ and installed the latest nightly - xbmc-20111024-c5758bf-master-atv2.deb. I also installed the update killer via ssh - apt-get install com.nito.updatebegone. I did not install any other software beyond XBMC. I re-uploaded my advancedsettings file to continue using the centralized MySql DB and thumbs db. I also turned off the "extract thumbnails" setting you mentioned previously in this thread.

I'm pleased to report that my files are no longer crashing to FrontRow immediately upon playing; however, they are crashing maybe 1-3 minutes in.

I tried 2 files - The Terminator and Tombstone:

Terminator (MediaInfo): http://pastebin.com/bvVrLNWV
Tombstone (MediaInfo): http://pastebin.com/9XrvDg9s

XBMC Log: http://pastebin.com/fLxzFikq
Syslog: http://pastebin.com/ZTd9gH6V

My CrashReporter stuff is *still* not showing up in private/var/mobile/library/logs/crashreporter; however, stuff is showing up in private/var/logs/CrashReporter, pasted below --- and I note that the filename, once again, says "LowMemory" -- I'm at a loss!

CrashReporter (LowMemory-2011-10-25-200851.plist, in above location): http://pastebin.com/YdGZNwbt

Thoughts on what I can try next? Am I ripping this files to be too large? (10 GB and 14 GB do not seem like a large 1080p MKV rip to me, but am I way out in left field with that assumption?)

Many thanks for your continued assistance!

SM

EDIT: Something finally showed up in the mobile/library/logs/crashreporter, but this does not correspond to the logs above --however, it corresponds with the same issue -- mkv playback crashing to front row:
http://pastebin.com/nYPVKV4m

Thx for your logs. Not much that i can tell you. Something is eating up the memory. If the crash is reproducable with that videos maybe it would help to cut a sample which triggers that crash definitly and upload it somewhere.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #17
Turb007 Wrote:too late ..on IOS5 (4.4.1 ) and running xbmc perfectly

Thanks for the help Smile

Apple has already released 4.4.2 ... so when your atv2 crashs next don't put a new thread please ... but kill that update notification like mentioned in our FAQ.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Turb007 Offline
Junior Member
Posts: 19
Joined: Jun 2011
Reputation: 0
Post: #18
yes sorry I forgot to put in my post I also blocked updates by editing the hosts as per the FAQ so all should be good

Thanks again for pointing it out I knew it had tried the update but did'nt get that that would be causing the issues after as I killed it from happening

good stuff Smile
find quote
zidewinder Offline
Junior Member
Posts: 25
Joined: Aug 2011
Reputation: 0
Post: #19
I had the same problem that movies started buffering after some minutes and thereafter Xbmc crashed. Then i installed updatebegone and no problems anymore.
find quote
Sarlic Offline
Donor
Posts: 125
Joined: Mar 2011
Reputation: 0
Post: #20
Memphiz Wrote:Thx for your logs. Not much that i can tell you. Something is eating up the memory. If the crash is reproducable with that videos maybe it would help to cut a sample which triggers that crash definitly and upload it somewhere.

I'll try to cut a clip of both MKVs for upload.

*Could* this have something to do with the size of the files? If so, a much smaller clip of the MKV likely wouldn't cause the crash.

The out of memory -- are we talking RAM here or are we talking drive space? If the latter, how much free space should I have on the ATV after the XBMC install?

Man, I don't know what could be causing this, and I'm really worried that I've stumped you -- there's nothing but XBMC running, if this is a RAM issue, so I have no idea what could be causing the issue!

Edit: Also -- what is the effect of having the "extract thumbnails and movie information" activated? Since I have thumbnails and movie info stored on my server/in sql, does this somehow extract it all from the database and store it locally as well, or is this something else? The only reason I asked is that I had re-setup the MySql access before unchecking this option, so if anything was done to the ATV as a result of that, I'd want to try and undo it.

Thanks!
(This post was last modified: 2011-10-26 14:23 by Sarlic.)
find quote
g-off Offline
Fan
Posts: 631
Joined: Aug 2011
Reputation: 3
Post: #21
You can use whatever ipsw you want. Download from iclarified and shift click on create ipsw. Apple are still signing 4.3.

Sarlic Wrote:G-off, when running the Seas0npass jailbreak, will that automatically download the latest 4.3 build for me, or do I need to locate the ISPW separately? Been a while since I did a jailbreak, and I can't remember if Seas0npass will automatically download only the latest firmware for me.
find quote
Sarlic Offline
Donor
Posts: 125
Joined: Mar 2011
Reputation: 0
Post: #22
Thanks, Seas0npass makes it so easy, it's unbelievable. As I mentioned in my post above, I got it done... but still having issues. Ugh!
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #23
Sarlic Wrote:I'll try to cut a clip of both MKVs for upload.

*Could* this have something to do with the size of the files? If so, a much smaller clip of the MKV likely wouldn't cause the crash.

Nope ... i played up to 12gig 1080p mkvs without a problem

Sarlic Wrote:The out of memory -- are we talking RAM here or are we talking drive space?

We are talking about RAM here.

Sarlic Wrote:Also -- what is the effect of having the "extract thumbnails and movie information" activated?

It basically extracts some metainfo from the video itself. This is known to cause issues/crashes on ios. So nothing to worry about - its only active, when active.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Sarlic Offline
Donor
Posts: 125
Joined: Mar 2011
Reputation: 0
Post: #24
Hi Memphiz:

So I got a really good one for you now --

I have 2 AppleTVs in the house. The one I was testing is wired into my network, connected to a 7.1 dolby/dts receiver. It's been crashing for the memory issues.

For fun, I went to my second appletv -- newly jailbroken, same nightly installed. Wireless, connected via HDMI right into my bedroom TV.

Both MKV files played flawlessly. No crash. No problem.

So I came back out to my wired AppleTV and started messing with the settings. Switching the audio didn't make any difference, but as soon as I unplugged the Ethernet cable and hooked into my Wireless Network -- viola. The files didn't crash at all. Played without a hitch.

My Router is a Linksys E3000; Gigabit capable, with 2 wireless networks. My "streaming" network is the more powerful of the two radios, and that's what I had the ATV connected to.

Any idea what the hell the fact that the ATV was wired into the network could have to do with RAM/memory issues on my previously-wired ATV?

The logs I posted might as well be in Greek for all I can generally get from them, but is there anything in there you see that explains this? If anything, I'd expect the ATV to struggle more on the Wireless than the Wired.

Thanks!

Steve
(This post was last modified: 2011-10-27 02:29 by Sarlic.)
find quote
draws6741 Offline
Junior Member
Posts: 2
Joined: Oct 2011
Reputation: 0
Location: Central time zone
Post: #25
i do not see an advantage in updating my atv2 but everyone i have talked to recommended it but i think i would stick with my current version
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,377
Joined: Jan 2011
Reputation: 258
Location: Arizona, USA
Post: #26
draws6741 Wrote:i do not see an advantage in updating my atv2 but everyone i have talked to recommended it but i think i would stick with my current version

Just to be clear:

iOS, no need to update.

XBMC itself, keep updated.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #27
Sarlic Wrote:Hi Memphiz:

So I got a really good one for you now --

I have 2 AppleTVs in the house. The one I was testing is wired into my network, connected to a 7.1 dolby/dts receiver. It's been crashing for the memory issues.

For fun, I went to my second appletv -- newly jailbroken, same nightly installed. Wireless, connected via HDMI right into my bedroom TV.

Both MKV files played flawlessly. No crash. No problem.

So I came back out to my wired AppleTV and started messing with the settings. Switching the audio didn't make any difference, but as soon as I unplugged the Ethernet cable and hooked into my Wireless Network -- viola. The files didn't crash at all. Played without a hitch.

My Router is a Linksys E3000; Gigabit capable, with 2 wireless networks. My "streaming" network is the more powerful of the two radios, and that's what I had the ATV connected to.

Any idea what the hell the fact that the ATV was wired into the network could have to do with RAM/memory issues on my previously-wired ATV?

The logs I posted might as well be in Greek for all I can generally get from them, but is there anything in there you see that explains this? If anything, I'd expect the ATV to struggle more on the Wireless than the Wired.

Thanks!

Steve

Come on ... go home! Big Grin ... thats so unlogical to me that i quit thinking about it. Switching between wlan and ethernet makes that crash reproducable? Do you have DHCP on both or something? Try with static IPs then.

Else - no clue. I'm out ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Sarlic Offline
Donor
Posts: 125
Joined: Mar 2011
Reputation: 0
Post: #28
I know, right? I had the ATVs IP addresses set on the DHCP reservation table of my router. Right now the newly-wireless one has a dynamic IP, but tonight I will try to set a static IP via the ATV instead of using the router and plug back in to Ethernet to see what that does.

Makes no sense at all, to me. I'll let you know what happens.

Now that it's working, is it worth me posting any logs for comparison?
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #29
Sarlic Wrote:I know, right? I had the ATVs IP addresses set on the DHCP reservation table of my router. Right now the newly-wireless one has a dynamic IP, but tonight I will try to set a static IP via the ATV instead of using the router and plug back in to Ethernet to see what that does.

Makes no sense at all, to me. I'll let you know what happens.

Now that it's working, is it worth me posting any logs for comparison?

Nope ... out of memory handling is up to iOS. Nothing in the logfile which would give a clue ... at least not to me.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Sarlic Offline
Donor
Posts: 125
Joined: Mar 2011
Reputation: 0
Post: #30
Hi Memphiz..... I'm back. :-) With the same issue.

I'd been running my XBMC over wi-fi and was getting sick of buffering, so I ran a fresh jailbreak (deleted all of my old files, redownloaded Seas0nPass, re-installed, etc).

Before upgrading to the latest nightly, I decided to check out my 1080 MKV playback on the current "official" release.

While there's a bit of stuttering/frame skipping going on (I may not be using the correct terms here, but the video gets a bit jerky - less smooth - every so often) I was able to play all of the 1080p files that crash consistently on the current nightly WITHOUT issue -- without crashing, over the wired ethernet, etc. Score. However -- don't like that jerky video, so.... in the hopes that a fresh jailbreak had corrected the issue i was experiencing on previous nightlies, I upgraded to xbmc-20111124-da3fabb-master-atv2.deb.

And, of course..... crash to front row

I'm not a programmer, but this seems to say to me that *something* in the software that was changed since the current official release is causing this crash -- which as you determined above is related to memory. And no, the same file does not crash over Wi-Fi. Could something be fritzing the ATV out on the on-the-fly conversion from 1080 to 720? Maybe it can't handle the influx of data over the hard-wire, and since wireless is slower, it doesn't get overwhelmed (no idea....)?

Anyway, here are my logs from the most recent crash --

xbmc log - http://pastebin.com/EQ6P7aQr
syslog - http://pastebin.com/Jvc9CaAc
CrashReporter - http://pastebin.com/UFe4uX5e
MediaInfo - http://pastebin.com/VdHPYuAi

Please, PLEASE let me know what other info I can provide that will give you any clue as to what could be causing this issue. Short of buying one of you guys a ticket and flying you here to Baltimore, I'll do whatever I can to facilitate a solution to this annoying problem - access to my server, whatever. I love this software and it has revolutionized my movie/television viewing, and it's a heartache (as sad as that is) that I can't get beyond this crashing issue.) I don't know how far back the nightlies archive goes, but I will try each and every one until I find the culprit.

Many thanks,

Steve
(This post was last modified: 2011-11-25 22:02 by Sarlic.)
find quote
Post Reply