Artwork Downloader

  Thread Rating:
  • 12 Votes - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sialivi Offline
Posting Freak
Posts: 1,156
Joined: Dec 2008
Reputation: 9
Location: Sweden
Post: #871
Here's a logfile from AD 12.0.3 re-downloading already downloaded season-posters and season-banners. The original logfile was massive so I've trimmed out all but one show from this one: http://xbmclogs.com/show.php?id=14259

On every run it re-downloads several hundred images that already exists, putting unneccessary stress on the website(s). The problem seems to be limited to just season-posters and season-banners. I have since re-tested using 12.0.5 and it still has the same problem.
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #872
(2012-11-13 23:48)sialivi Wrote:  Here's a logfile from AD 12.0.3 re-downloading already downloaded season-posters and season-banners. The original logfile was massive so I've trimmed out all but one show from this one: http://xbmclogs.com/show.php?id=14259

On every run it re-downloads several hundred images that already exists, putting unneccessary stress on the website(s). The problem seems to be limited to just season-posters and season-banners. I have since re-tested using 12.0.5 and it still has the same problem.

So don't use them for now.

I have got other things to do atm. I know the issue but won't fix it now

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
(This post was last modified: 2012-11-14 00:34 by Martijn.)
find quote
johnmerrick Offline
Senior Member
Posts: 205
Joined: Oct 2010
Reputation: 0
Post: #873
(2012-11-08 19:32)Reginald Wrote:  
(2012-11-07 23:29)Martijn Wrote:  not true. silent mode still works.


I only removed the auto daily run.

I thought about the term used in his requested and realized I was wrong. I have mine run this way and it is working fine in Eden, I am not sure about the Back button issue as I usually kick it off let it run for a bit. Sorry to mis-speak.

Silent mode no longer works for me on 4 different pc's. I just run it manually now before i exit XBMC.
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #874
(2012-11-14 00:32)johnmerrick Wrote:  
(2012-11-08 19:32)Reginald Wrote:  
(2012-11-07 23:29)Martijn Wrote:  not true. silent mode still works.


I only removed the auto daily run.

I thought about the term used in his requested and realized I was wrong. I have mine run this way and it is working fine in Eden, I am not sure about the Back button issue as I usually kick it off let it run for a bit. Sorry to mis-speak.

Silent mode no longer works for me on 4 different pc's. I just run it manually now before i exit XBMC.

You are completely wrong

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
johnmerrick Offline
Senior Member
Posts: 205
Joined: Oct 2010
Reputation: 0
Post: #875
Just tried it again on my pc at work and it didn't work.

What happens is i go to (Aeon Mq3 skin) - addons - program addons - artwork downloader - it starts running the the banner goes (normal) then i go back to my homescreen to watch something etc ( as I always did ).

I then check the log about an hour later or the next day and it shows a run from either my last non silent run or from one I did a fortnight ago. I do a Windows search for new artwork and there is nothing new from a silent run.

By the way Martijn, you seem to be gaining satisfaction from people being 'completely wrong' but I assure you I'm not really that bothered If I am wrong. I'm asking for advice on an internet forum and seeing if anyone has a similar problem or a fix for it. That's all. Quite innocent, very normal and also polite.

I have read through this whole thread and this seems to be a common theme in your replies. I'm sure the people on here are posting in good faith. Otherwise, what's the point in posting at all?
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #876
You are still completely WRONG

Silent mode is NOT the same as automatic run each day. Read the thread carefully since i already explained it!

Silent run:
This show you are message that it has started and it will ONLY notify you after it finished. If you turn off silent you get the progress dialog that show you current progress. This STILL works like it should

Auto run:
This will start the script every 24 hours THIS HAS BEEN DISABLED like stated before

Quote:By the way Martijn, you seem to be gaining satisfaction from people being 'completely wrong' but I assure you I'm not really that bothered If I am wrong. I'm asking for advice on an internet forum and seeing if anyone has a similar problem or a fix for it. That's all. Quite innocent, very normal and also polite.

I have read through this whole thread and this seems to be a common theme in your replies. I'm sure the people on here are posting in good faith. Otherwise, what's the point in posting at all?

Since i hate saying things over and over and over again without you guys even reading anything.
There is a wiki explaining everything with the link in the first post including what you should do if you have a problem.
If i respond like this it means they didn't read.

I do help a lot of people with problems throughout the forum and they are hopefully great full for the time i put into it. But if they are asking things that are so obvious and they didn't even take the time to even read anything or at least the first posts on a thread or at least the last couple of pages i will respond with some sarcasm.

I don't expect you to read a whole thread but you should at least take the effort or do some google search first.
Enough said. If you don't agree that's up to you

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
(This post was last modified: 2012-11-14 11:50 by Martijn.)
find quote
johnmerrick Offline
Senior Member
Posts: 205
Joined: Oct 2010
Reputation: 0
Post: #877
"johnmerrick Wrote:
I can no longer run this addon in silent mode (run in background). Not sure why.

Also, if i back to the previous screen or main menu it cancels! It never used to.

Latest version.

This has been answered a few times now in the thread, a change was made due to the load that was put on Fanart.TV's servers, Martijn has said if Fanart.TV gets enough money for a year, he may add it back."



As you can see above in red I didn't say silent mode was the same as the Automatic run. Somebody else confused my first question with that and if you look above you will see that users reply to me.

Silent mode runs in the background when you start it yourself and notifies you at the beginning and end like you have stated. I know that.

What I'm saying is my silent mode doesn't work and my non silent mode does. If i start my silent mode then go back to my main screen to watch something, then check back nothing has downloaded. If I do 'non silent' the addon scans through and everything downloads fine. This is fine with me as I just run it before i exit xbmc and it doesn't make any difference to me that much because i'm still pressing the same buttons.

The automatic feature stopped weeks ago and I read the posts on this and just accepted it. But that's irrelevant because I never mentioned that at all in my question. Because that wasn't my question.

I actually read about 80-90% of the threads because I find answers quicker by reading rather than posting.

I'm still not bothered about being wrong even though I'm 100% certain my 'silent mode' downloads absolutely nothing. Even if I leave it overnight or sit and wait for it to finish. If it still works for you and other people then fine, there is a glitch at my end on all 4 of my pc's in different locations. That' a fact.

What is also a fact is that you are clearly irritated by nearly everyone that posts! We are only asking questions on a forum!
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #878
K in that case sorry, seems some one else got me thinking you meant something else.

So how do you know it hasn't downloaded anything?
Through the report? the Debug Log?
This should tell you a lot of what happens if you turn it on in addons settings and xbmc

Script hasn't been updated in a long time so it shouldn't have changed anything.
There is no difference between normal or silent run besides the fact the progress isn't shown. It just turns the dialog off so there cannot be any difference.

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Skank Online
Posting Freak
Posts: 1,608
Joined: Jul 2012
Reputation: 7
Post: #879
Martijn, will there be an update for frodo once its released or beta is out?
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #880
(2012-11-14 15:18)Skank Wrote:  Martijn, will there be an update for frodo once its released or beta is out?

yes will be added to repo when there is one
already downloadable here:
https://github.com/XBMC-Addons/script.ar.../downloads

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Skank Online
Posting Freak
Posts: 1,608
Joined: Jul 2012
Reputation: 7
Post: #881
(2012-11-14 15:23)Martijn Wrote:  
(2012-11-14 15:18)Skank Wrote:  Martijn, will there be an update for frodo once its released or beta is out?

yes will be added to repo when there is one
already downloadable here:
https://github.com/XBMC-Addons/script.ar.../downloads

Cool thx!
find quote
johnmerrick Offline
Senior Member
Posts: 205
Joined: Oct 2010
Reputation: 0
Post: #882
Will try it tonight with a debug log.

I leave it overnight and nothing has downloaded (i check the last run report) I will try it again later and see if it works.

i knew there was a problem because one of the movies was one with lot's of fanart and it just wasn't changing (it immediately downloaded them all in non silent mode).
find quote
SpaceMonkey Offline
Posting Freak
Posts: 1,162
Joined: Aug 2008
Reputation: 24
Location: Finland
Post: #883
I've downloaded logos for movies and tvshows and clearart for tv shows, so far so good. Now i enabled music videos and logos but i get an error about wrong setting combination, bug or a feature? Big Grin

Debug log: http://pastebin.com/cTjbxaQ0
Addon settings: http://pastebin.com/N2jXEAUj

Edit: modified the if statement for music videos to check for logos also, seemed to run after that. So this option really is only meant for music videos like the name says and not music library? Only way to add artist logos to music library views is to use these "skinhacks"?
(This post was last modified: 2012-11-14 20:11 by SpaceMonkey.)
find quote
KroZpOz Offline
Junior Member
Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #884
Martijn,

I can confirm johnmerrick's issue as, since the latest update, the silent mode no longer downloads any artwork. It does show the dialog "searching for artwork" but seems to crash later in the process.
(This post was last modified: 2012-11-15 00:05 by KroZpOz.)
find quote
Martijn Offline
Team Kodi
Posts: 11,590
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #885
(2012-11-15 00:04)KroZpOz Wrote:  Martijn,

I can confirm johnmerrick's issue as, since the latest update, the silent mode no longer downloads any artwork. It does show the dialog "searching for artwork" but seems to crash later in the process.

It seems to work on openelec (which i always use) but not on win32. Will see what is going on here....

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
Post Reply