Artwork Downloader

  Thread Rating:
  • 12 Votes - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jafichan Offline
Junior Member
Posts: 25
Joined: Sep 2014
Reputation: 0
Post: #2086
Thank you for your reply. I use aeon nox 4.1.9.9 and in the video info window, i can see the choose art menu, and yes the poster is updated in it, but not in the info window or in the main movie menu (all views)...

[Image: 1410457052-screenshot001.png]

Thank you and sorry for my bad english..
(This post was last modified: 2014-09-11 19:49 by jafichan.)
find quote
wgstarks Offline
Posting Freak
Posts: 1,009
Joined: Jun 2013
Reputation: 6
Location: North Carolina, USA
Post: #2087
(2014-09-11 19:38)jafichan Wrote:  Thank you for your reply. I use aeon nox 4.1.9.9 and in the video info window, i can see the choose art menu, and yes the poster is updated in it, but not in the info window or in the main movie menu (all views)...

[Image: 1410457052-screenshot001.png]

Thank you and sorry for my bad english..

http://forum.xbmc.org/showthread.php?tid...pid1792186

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.4/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
find quote
jafichan Offline
Junior Member
Posts: 25
Joined: Sep 2014
Reputation: 0
Post: #2088
Ok, so there is no way to get the artwork auto-update when i change something? I have to quit xbmc, delete the texture file, and relaunch each time?
Thx
find quote
Milhouse Offline
Team-Kodi Member
Posts: 3,990
Joined: Jan 2011
Reputation: 91
Post: #2089
(2014-09-11 21:04)jafichan Wrote:  Ok, so there is no way to get the artwork auto-update when i change something? I have to quit xbmc, delete the texture file, and relaunch each time?
Thx

Or use the script in my sig to recache artwork for specific movies. You certainly don't want to delete your Textures13.db if you can help it.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
wgstarks Offline
Posting Freak
Posts: 1,009
Joined: Jun 2013
Reputation: 6
Location: North Carolina, USA
Post: #2090
(2014-09-11 21:04)jafichan Wrote:  Ok, so there is no way to get the artwork auto-update when i change something? I have to quit xbmc, delete the texture file, and relaunch each time?
Thx

Actually I was suggesting you do it once and it may correct your problem. As Milhouse has suggested, you could also use his command line script.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.4/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
find quote
jafichan Offline
Junior Member
Posts: 25
Joined: Sep 2014
Reputation: 0
Post: #2091
Ok thank you very much!
find quote
cw-kid Offline
Posting Freak
Posts: 1,066
Joined: Jun 2012
Reputation: 3
Post: #2092
SOLVED

Hi

Artwork Downloader doesn't appear to always download Movie disc art images even though there is some present on Fanart.tv site. Has this been reported before?

Example: A Nightmare on Elm Street: The Dream Child. There are two disc art images for it on Fanart.tv here.

In this movies folder on my file server I currently do not have a disc art image present, so if I right click this movie title in XBMC and run AD in solo mode on it then I'd expect for it to find a disc image. But when I run solo mode it says Finished 0 Download.

Disc art is selected in the AD options etc.

Yet if I run AD again in GUI mode and select disc art it shows me those two disc art images fine and I can download one OK to my movies folder on the server.

Debug Log file attached:

http://xbmclogs.com/show.php?id=297637


Thank you very much for your time.

EDIT:

It appears Artwork Downloader is smarter than I am, in my example above the two disc art images on Fanart.tv one is Blu-ray and the other is German DVD. The title in my library is (English) SD XVID which is presumably why the Solo mode didn't download any of those disc arts. So it appears to be format SD vs HD specific as well as language specific which now makes sense.

Cheers

EDIT 2: OK I think I have found a better example, Stargate in my library is (English) SD XVID format. Looking on Fanart.tv there is one disc art image uploaded by a user called: Canyonhoppers, that is English and DVD so AD in Solo mode should download that disc right? The disc art image says on it, its Ultimate Edition Extended Cut. Does the Edition make any difference anyhow? I doubt it.

Here is the Stargate title from my library:

[Image: ArtworkDownloader-Stargate1_zps66684e1b.jpg]

When I run Solo mode this particular disc art image is not downloaded and I would expect it should be?

Here is a new debug log file for Startgate and running solo mode against it and it completes with Zero downloads.

Looking in the log file I can see this:

Code:
17:44:57 T:2088   DEBUG: CThumbExtractor::DoWork - trying to extract filestream details from video file smb://WHS/Movies/XVID/Stargate/Stargate.avi
17:44:57 T:2088   ERROR: CDVDDemuxFFmpeg::Open - error probing input format, smb://WHS/Movies/XVID/Stargate/Stargate.avi

And this:

Code:
17:45:05 T:5620   DEBUG: Artwork Downloader: * Image type: discart
17:45:05 T:5620   DEBUG: Artwork Downloader:  - Ignoring (Doesn't match preferred disctype: n/a): disc.png
17:45:05 T:5620   DEBUG: Previous line repeats 3 times.
17:45:05 T:5620   DEBUG: Artwork Downloader:  - Found a total of: 4 discart

"Ignoring (Doesn't match preferred disctype" so its not matched it for some reason? Because it couldn't probe the format type?

Thanks

EDIT 3:

Looks like that Stargate.avi file has got corrupted and is 0KB some how, it doesn't play which would explain the issue. I just searched my entire movie collection for 0KB video files and this is the only one, what are the chances of that, picking this title to run AD in solo mode against.

I just deleted the SD Stargate.avi file and created a new HD Stargate.mp4 file and cleaned / updated the library etc, upon first run of AD in solo mode no disc was downloaded. Second attempt running solo mode again and now a disc has been downloaded, not sure why it didn't do it the first time.

The Media Center Blog
The Digital Lifestyle
Authorised Euro Z-wave dealer contact for bespoke prices!
(This post was last modified: 2014-09-19 20:22 by cw-kid.)
find quote
djhifi Offline
Member
Posts: 69
Joined: Jan 2014
Reputation: 0
Post: #2093
(2014-09-19 14:44)cw-kid Wrote:  SOLVED

Hi

Artwork Downloader doesn't appear to always download Movie disc art images even though there is some present on Fanart.tv site. Has this been reported before?

Example: A Nightmare on Elm Street: The Dream Child. There are two disc art images for it on Fanart.tv here.

In this movies folder on my file server I currently do not have a disc art image present, so if I right click this movie title in XBMC and run AD in solo mode on it then I'd expect for it to find a disc image. But when I run solo mode it says Finished 0 Download.

Disc art is selected in the AD options etc.

Yet if I run AD again in GUI mode and select disc art it shows me those two disc art images fine and I can download one OK to my movies folder on the server.

Debug Log file attached:

http://xbmclogs.com/show.php?id=297637


Thank you very much for your time.

EDIT:

It appears Artwork Downloader is smarter than I am, in my example above the two disc art images on Fanart.tv one is Blu-ray and the other is German DVD. The title in my library is (English) SD XVID which is presumably why the Solo mode didn't download any of those disc arts. So it appears to be format SD vs HD specific as well as language specific which now makes sense.

Cheers

EDIT 2: OK I think I have found a better example, Stargate in my library is (English) SD XVID format. Looking on Fanart.tv there is one disc art image uploaded by a user called: Canyonhoppers, that is English and DVD so AD in Solo mode should download that disc right? The disc art image says on it, its Ultimate Edition Extended Cut. Does the Edition make any difference anyhow? I doubt it.

Here is the Stargate title from my library:

[Image: ArtworkDownloader-Stargate1_zps66684e1b.jpg]

When I run Solo mode this particular disc art image is not downloaded and I would expect it should be?

Here is a new debug log file for Startgate and running solo mode against it and it completes with Zero downloads.

Looking in the log file I can see this:

Code:
17:44:57 T:2088   DEBUG: CThumbExtractor::DoWork - trying to extract filestream details from video file smb://WHS/Movies/XVID/Stargate/Stargate.avi
17:44:57 T:2088   ERROR: CDVDDemuxFFmpeg::Open - error probing input format, smb://WHS/Movies/XVID/Stargate/Stargate.avi

And this:

Code:
17:45:05 T:5620   DEBUG: Artwork Downloader: * Image type: discart
17:45:05 T:5620   DEBUG: Artwork Downloader:  - Ignoring (Doesn't match preferred disctype: n/a): disc.png
17:45:05 T:5620   DEBUG: Previous line repeats 3 times.
17:45:05 T:5620   DEBUG: Artwork Downloader:  - Found a total of: 4 discart

"Ignoring (Doesn't match preferred disctype" so its not matched it for some reason? Because it couldn't probe the format type?

Thanks

EDIT 3:

Looks like that Stargate.avi file has got corrupted and is 0KB some how, it doesn't play which would explain the issue. I just searched my entire movie collection for 0KB video files and this is the only one, what are the chances of that, picking this title to run AD in solo mode against.

I just deleted the SD Stargate.avi file and created a new HD Stargate.mp4 file and cleaned / updated the library etc, upon first run of AD in solo mode no disc was downloaded. Second attempt running solo mode again and now a disc has been downloaded, not sure why it didn't do it the first time.


This also happens to me.
I think it's due to the artwork downloader reading your .mkv (or whatever file it is) and as it is not DVD quality, even if there is a disc (DVD), it will not download it automatically, unless you go via GUI mode.

Pretty bad, no solution till this day.

Do you have an idea? I guess it will have to go through a bug fix im afraid?

There should be an option on the program for us to tick, if we don't care for the origin of the disc art (my case).
(This post was last modified: 2014-09-20 17:14 by djhifi.)
find quote
GTunney Offline
Member
Posts: 85
Joined: Feb 2014
Reputation: 0
Post: #2094
Hi all,

Is there anyway to modify the file permissions that artwork downloader applies to it's downloaded files.

My artwork is stored is the same folder as my movie on my NAS. I have my NAS set to create all new files / folders as read/write but for some reason artwork downloader gives them a weird permissions and if I want to copy/ move / delete or even see any artwork via windows explorer I have to reforce the permissions on my NAS admin page.
find quote
Post Reply