Recordings don't play from LiveTV menu

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
lenx Offline
Junior Member
Posts: 23
Joined: Sep 2010
Reputation: 5
Post: #1
My setup ubuntu 10.04 with kernel 3.x. tvheadend backend and xbmc running on same asrock ion box. DVB-T2 usb tuner, confluence skin. dushmaniac,s build from the pulse site.
I've recently started on this and have had success watching and recording tv, HD and SD channel, thanks to those involved.

When I browse to the Recordings section of XBMC > LiveTV, i can see the list of recordings and delete or view their info. but I can't actually playback the recording. Nothing happens when i highlight the file name and press play/enter.
If I goto the Videos section and then browse through the root file system I can play back the recorded .mkv file OK.

Should I be able playback the tv recordings directly from the Recordings section or have I misunderstood this?

thanks
find quote
mrpg Offline
Member
Posts: 72
Joined: Sep 2010
Reputation: 0
Post: #2
Hi,

I have the same problem, but i am using the latest windows build from margro.

(used to work in the builds compiled in september)

Br
PG
find quote
lenx Offline
Junior Member
Posts: 23
Joined: Sep 2010
Reputation: 5
Post: #3
OK Thanks, at least I know it should work. As this is still a WIP I won't bother posting debug for the time being.
find quote
tsp42 Offline
Senior Member
Posts: 222
Joined: Aug 2011
Reputation: 11
Location: Denmark
Post: #4
You can try this fix I created for the mythtv addon:
https://github.com/tsp/xbmc/commit/9d56d...1b098aa988
find quote
vmalaga Offline
Junior Member
Posts: 6
Joined: Oct 2011
Reputation: 0
Location: Spain
Post: #5
tsp42 Wrote:You can try this fix I created for the mythtv addon:
https://github.com/tsp/xbmc/commit/9d56d...1b098aa988

I have the same problem.

my config is pvr+xbmc-xvdr-addon+vdr

now i have compiled one xbmc-prv that works fine, but since 15-20 nov, with the git-pull is not working any more

tsp42 I have apply your patch, and now i can play recordings if it is at the first level, but i have a directory-tree ( FILMS, DOCS, SERIES) and go into dirs and play recordings from it dont`t work, so i think that your patch is near to solve my problem
find quote
tsp42 Offline
Senior Member
Posts: 222
Joined: Aug 2011
Reputation: 11
Location: Denmark
Post: #6
I think I got it nailed now:
https://github.com/tsp/xbmc/commit/51a9e...9ac94708d6
Please undo the previous fix first if you have applied it before.
find quote
vmalaga Offline
Junior Member
Posts: 6
Joined: Oct 2011
Reputation: 0
Location: Spain
Post: #7
tsp42 Wrote:I think I got it nailed now:
https://github.com/tsp/xbmc/commit/51a9e...9ac94708d6
Please undo the previous fix first if you have applied it before.

with this patch, there is the same problem, i can play files but can`t go into dirs.

can i help you with any log ?
find quote
tsp42 Offline
Senior Member
Posts: 222
Joined: Aug 2011
Reputation: 11
Location: Denmark
Post: #8
vmalaga: Did you apply it to a clean version?
find quote
vmalaga Offline
Junior Member
Posts: 6
Joined: Oct 2011
Reputation: 0
Location: Spain
Post: #9
tsp42 Wrote:vmalaga: Did you apply it to a clean version?

Yes
find quote
vmalaga Offline
Junior Member
Posts: 6
Joined: Oct 2011
Reputation: 0
Location: Spain
Post: #10
tsp42 Wrote:vmalaga: Did you apply it to a clean version?

Hi tsp42

i have see your patch at the main pvr github repository and a lot of changes.

I have recompile and now it is working.

thxs
find quote