ReadVideoReDo & ReadEdl on sp-sc-auth broadcasted streams

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
prono Offline
Junior Member
Posts: 24
Joined: Apr 2011
Reputation: 0
Post: #1
Hello,

I'm seeing a strange issue while I try to play a stream generated using sp-sc-auth on openelec.

Environment:
openelec + XBMC PRE-11.0 Git:3ee0a1b (Compiled: Nov 22 2011)

custom plugin that

Code:
call(["/storage/.sopcast/run.sh", url, "3902", "8908"])
...
xbmc.Player( xbmc.PLAYER_CORE_DVDPLAYER ).play( 'http://127.0.0.1:8908/stream', listitem)

run.sh sets the environment ready and executes

Code:
exec ./sp-sc-auth $@ > /dev/null &

When it comes to play the stream I see these errors in the log:


Code:
08:54:52 T:2942303088  NOTICE: Mode: 3
08:54:52 T:2942303088  NOTICE: URL: sop://broker.sopcast.com:3912/80624
08:54:52 T:2942303088  NOTICE: Name: Test 1
08:54:52 T:2942303088  NOTICE: sop://broker.sopcast.com:3912/80624
08:54:52 T:2942303088  NOTICE: waiting 10 secs
08:55:02 T:2942303088  NOTICE: done waiting
08:55:02 T:2942303088  NOTICE: attempting to stream file
08:55:02 T:3048306432  NOTICE: DVDPlayer: Opening: http://127.0.0.1:8908/stream
08:55:02 T:3048306432 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
08:55:02 T:2942303088  NOTICE: Creating InputStream
08:55:02 T:2942303088  NOTICE: Creating Demuxer
08:55:02 T:2942303088  NOTICE: Opening video stream: 0 source: 256
08:55:02 T:2942303088  NOTICE: Creating video codec with codec id: 74
08:55:02 T:2942303088  NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(720x480, 74)
08:55:02 T:2942303088  NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000001
08:55:02 T:2942303088   ERROR: (VDPAU) unable to init VDPAU - vdp_st = 0x1.  Falling back.
08:55:02 T:2942303088  NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
08:55:02 T:2942303088  NOTICE:  (VDPAU) Close
08:55:02 T:2942303088  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: Windows Media Video 9
08:55:02 T:2942303088   ERROR: VAAPI - unable to initialize display -1 - unknown libva error
08:55:02 T:2942303088   ERROR: Previous line repeats 1 times.
08:55:02 T:2942303088  NOTICE: Creating video thread
08:55:02 T:2942303088  NOTICE: Opening audio stream: 1 source: 256
08:55:02 T:2942303088  NOTICE: Finding audio codec for: 86024
08:55:02 T:2891426672  NOTICE: running thread: video_thread
08:55:02 T:2942303088  NOTICE: Creating audio thread
08:55:02 T:2853264240  NOTICE: running thread: CDVDPlayerAudio::Process()
08:55:02 T:2942303088   ERROR: ReadVideoReDo - Invalid VideoReDo file: http://127.0.0.1:8908/stream.Vprj. Error reading line 1 - expected <Version>2. Only version 2 files are supported.
08:55:02 T:2942303088 WARNING: ReadEdl - Error on line 1 in EDL file: http://127.0.0.1:8908/stream.edl
08:55:02 T:2942303088 WARNING: ReadEdl - Error on line 2 in EDL file: http://127.0.0.1:8908/stream.edl

For some reason thinks that the stream is a local stream and needs a EDL file but it's not.

Did anybody encounter something similar to this? Any way to resolve it?

thank you.
find quote
TobiasTheCommie Offline
Skilled Python Coder
Posts: 618
Joined: Apr 2008
Reputation: 6
Post: #2
You could try ./configure --disable-edl

Though on OE i'm not sure if that is viable.
find quote
vonstring Offline
Junior Member
Posts: 4
Joined: Feb 2012
Reputation: 0
Post: #3
Seeing the same issue. Every URL where the host is 127.0.0.1 or 'localhost' is recognized as being on local harddrive. Worked around it with this patch:

Code:
diff --git a/xbmc/utils/URIUtils.cpp b/xbmc/utils/URIUtils.cpp
index b32ab10..9296293 100644
--- a/xbmc/utils/URIUtils.cpp
+++ b/xbmc/utils/URIUtils.cpp
@@ -498,7 +498,7 @@ bool URIUtils::IsHD(const CStdString& strFileName)
   if (IsInArchive(strFileName))
     return IsHD(url.GetHostName());

-  return url.IsLocal();
+  return url.IsLocal() && url.GetTranslatedProtocol() != "http" && url.GetTranslatedProtocol() != "https";
}

bool URIUtils::IsDVD(const CStdString& strFile)

Seems there is a ticket for this.
(This post was last modified: 2012-02-18 22:14 by vonstring.)
find quote
tocinillo Offline
Fan
Posts: 317
Joined: Dec 2010
Reputation: 2
Post: #4
Same error with RC2, infinite loop when I try to play sopcast streams:

17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 1 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 2 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 3 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 4 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 5 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 6 in EDL file: http://localhost:9001/.edl
17:51:45 T:2838494064 WARNING: ReadEdl - Error on line 7 in EDL file: http://localhost:9001/.edl
etc.

This not appears on Dharma....What's wrong?
find quote
vonstring Offline
Junior Member
Posts: 4
Joined: Feb 2012
Reputation: 0
Post: #5
What's wrong is that XBMC regards your local sopcast server as files on your local harddrive, and tries to read various files from your local Sopcast instance. Sopcast however will reply with a stream no matter what filename is specified, and XBMC in turn tries to parse the stream and gets stuck. The issue is pretty much clear, and I've commented on the bug report that I linked to above. Not sure how to go about to get some traction on it, though.
find quote
tocinillo Offline
Fan
Posts: 317
Joined: Dec 2010
Reputation: 2
Post: #6
Thanks for the info, vonstring. What is the patch that you mentioned in the last post?

I think that in Dharma this is fixed in Eden can fix.

I use x-sopcast (modified: http://forum.xbmc.org/showthread.php?tid=122866&page=3) under Linux and works fine on Dharma, but on Eden appaears this bug.
(This post was last modified: 2012-03-22 20:12 by tocinillo.)
find quote
vonstring Offline
Junior Member
Posts: 4
Joined: Feb 2012
Reputation: 0
Post: #7
The patch, if applied to the source code of Eden, is a workaround for this issue. Another workaround (haven't tried it) might be to use your computers IP address instead of localhost/127.0.0.1 in the stream URL.
(This post was last modified: 2012-03-22 20:54 by vonstring.)
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #8
https://github.com/xbmc/xbmc/pull/801
find quote
vonstring Offline
Junior Member
Posts: 4
Joined: Feb 2012
Reputation: 0
Post: #9
Excellent!
find quote
tocinillo Offline
Fan
Posts: 317
Joined: Dec 2010
Reputation: 2
Post: #10
really quickly!!
find quote