Problems with the color red...

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Celphish Offline
Junior Member
Posts: 2
Joined: Dec 2011
Reputation: 0
Question  Problems with the color red...
Post: #1
Hi there,

I have a problem.
Got a HTPC, running AMD A3850 llano and XBMC.
The issue is that the red is too intensive, makes the skin looks almost infected in some movies / tv-shows or it makes blond hair look like it has pink color in it.

I first thought it was my projector, a Epson EH-TW3200, but when I tried a clip (Bridesmaids) where the actress blond hair has a hint of pink in it, on VLC, it didn't look as bad as when I play it in XBMC.

An example of the skin-blush that appears, check out this image:
[Image: jtLhy.jpg]

I can't find any addons or other ways to try to adjust the color in XBMC...
What do I do?
find quote
wastingaeons Offline
Junior Member
Posts: 4
Joined: Nov 2011
Reputation: 0
Post: #2
Celphish Wrote:I can't find any addons or other ways to try to adjust the color in XBMC...
What do I do?
I have this problem too; I've turned magenta all the way down on my TV and it's helped, but I still notice it Confused
find quote
CrystalP Offline
Team-XBMC Developer
Posts: 822
Joined: Apr 2010
Reputation: 18
Location: The Great North
Post: #3
There is no color adjustment in XBMC.
If you're using dxva, then maybe it's a setting in the driver's control panel.

Can you create a sample? We'll see if it can be reproduced by others.

Always read the XBMC online-manual, FAQ, Wiki and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Celphish Offline
Junior Member
Posts: 2
Joined: Dec 2011
Reputation: 0
Post: #4
Why didn't I think of that, I can adjust the color in the panel OUTSIDE XBMC, nice, I'll try that when I get home later Big Grin
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #5
I have this same problem since moving to Eden! Is there a fix in XBMC because with VLC or MPC-HC all looks great but in XBMC it has the Blondes looking Pink haired!

[Image: all-thin-banner@2x.jpg]
find quote
creepwood Offline
Member
Posts: 68
Joined: Feb 2005
Reputation: 0
Location: gothenburg, sweden
Post: #6
I've recently discovered this problem as well. First I thought it was the TV, later the DVI -> HDMI cable, but I recently discovered it on my workstation running XBMC as well. No problem in VLC.

Someone mentioned DXVA and check the control panel for the driver. Is everybody here who experience this problem using Radeon graphic cards? Both the media center and my workstation is running Radeon cards with latest driver.
find quote
zachmanx Offline
Junior Member
Posts: 3
Joined: Jan 2013
Reputation: 0
Post: #7
Has anyone found a better fix for this issue? As others have mentioned, I only see this problem in XBMC 11.

AMD A4-3400 Llano 2.7GHz Socket FM1 65W Dual-Core Desktop APU (CPU + GPU) with DirectX 11 Graphic AMD Radeon HD 6410D AD3400OJHXBOX
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #8
Any fix for this?!

I still have this problem with Frodo! It only seems to happen with DXVA enabled... But for some movies it stutters if I don't have DXVA enabled.

[Image: all-thin-banner@2x.jpg]
find quote
jordandk Offline
Member
Posts: 80
Joined: Dec 2010
Reputation: 0
Location: Denmark
Post: #9
I have Radeon HD7750 and no problems of what I notice. Neighter with my HD5450.

Take a look here, I have used some of settings for my card too.

http://www.tomshardware.com/reviews/hqv-...844-2.html
find quote
zachmanx Offline
Junior Member
Posts: 3
Joined: Jan 2013
Reputation: 0
Post: #10
I've had this issue with XMBC 11, 12, and 12.1 with HD7750 and the onboard A-series. The color problem is only in XBMC, so I can't see the sense in pointing to any other cause but either a setting or a bug with XBMC. Do any Devs read these threads or someone in the know?
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #11
(2013-02-11 12:02)jordandk Wrote:  I have Radeon HD7750 and no problems of what I notice. Neighter with my HD5450.

Take a look here, I have used some of settings for my card too.

http://www.tomshardware.com/reviews/hqv-...844-2.html

I had to tweak my settings too because I had major red especially with blonde hair or yellow on the screen was washed out and looked red. But those settings from that link were not correct. I have an AMD 5570 and those settings with the color didn't change the Red problem. I just had to tinker until it was just right.

(2013-04-03 19:53)zachmanx Wrote:  I've had this issue with XMBC 11, 12, and 12.1 with HD7750 and the onboard A-series. The color problem is only in XBMC, so I can't see the sense in pointing to any other cause but either a setting or a bug with XBMC. Do any Devs read these threads or someone in the know?

The reason you are seeing the red in xbmc and not in other players is because of the way XBMC uses DXVA (GPU Rendering). I play a movie in VLC and in MPC-HC now and it looks no different now and I am using DXVA2 with XBMC always.

My advice is to go with the above link and then adjust from there until the red is gone. Until I did that DXVA would work but it was too red. If I disabled dxva I couldn't watch certain 1080p ripped blurays (Avengers) because they would have too much jitter because the CPU isn't the best for Video rendering even if its a quadcore.

[Image: all-thin-banner@2x.jpg]
find quote
zachmanx Offline
Junior Member
Posts: 3
Joined: Jan 2013
Reputation: 0
Post: #12
I disabled the DXVA2 hardware acceleration option and the pink hair went away.

It's under the video playback options in system settings.
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #13
(2013-04-06 01:51)zachmanx Wrote:  I disabled the DXVA2 hardware acceleration option and the pink hair went away.

It's under the video playback options in system settings.

Yes its because when you choose DXVA2 you are using your graphics card to render the videos. So it is all in the settings of your Graphics card. I don't know why the default for AMD(ATI) cards does this but it did with my old 4750 card too.

Just tinker with the settings and then DXVA2 will be your best video renderer because it works with all video without stuttering.

[Image: all-thin-banner@2x.jpg]
find quote
Kib Offline
Team XBMC
Posts: 3,202
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #14
Your name is oddly appropriate Wink

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #15
(2013-04-06 02:27)Kibje Wrote:  Your name is oddly appropriate Wink

Not sure I get what you're talking about? Its just my handle for everything and a description of my wife. lol.

[Image: all-thin-banner@2x.jpg]
find quote
Post Reply