Another External Player Code, but Very Simple to Setup

  Thread Rating:
  • 11 Votes - 4.27 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
andyd Online
Senior Member
Posts: 261
Joined: Nov 2004
Reputation: 0
Post: #781
Anyone here upgraded to the latest version of TMT5 and having issues with controls during playback?

I can longer exit out or control playback of a movie after launching a folder rip or iso
(This post was last modified: 2012-07-09 00:47 by andyd.)
find quote
sifuleeroy Offline
Junior Member
Posts: 3
Joined: Jul 2012
Reputation: 0
Post: #782
First time post so please be gentle!

I'm trying to setup XBMC to only launch TMT5 for ISO files and it's not working. I have put playercorefactory and PlayISO in my appdata/roaming/xbmc/userdata and made the following changes.

<filename>C:\Users\SiFuXBMC\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>

Everything else is the same. When I try to play any of my movies XBMC plays them and my TMT5 doesn't launch. Any help would be greatly appreciated.
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #783
(2012-07-09 04:12)sifuleeroy Wrote:  First time post so please be gentle!

I'm trying to setup XBMC to only launch TMT5 for ISO files and it's not working. I have put playercorefactory and PlayISO in my appdata/roaming/xbmc/userdata and made the following changes.

<filename>C:\Users\SiFuXBMC\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>

Everything else is the same. When I try to play any of my movies XBMC plays them and my TMT5 doesn't launch. Any help would be greatly appreciated.
Can you post your Playercorefactory.xml and PlayISO.bat codes in here?

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
sifuleeroy Offline
Junior Member
Posts: 3
Joined: Jul 2012
Reputation: 0
Post: #784
(2012-07-09 19:08)bluray Wrote:  
(2012-07-09 04:12)sifuleeroy Wrote:  First time post so please be gentle!

I'm trying to setup XBMC to only launch TMT5 for ISO files and it's not working. I have put playercorefactory and PlayISO in my appdata/roaming/xbmc/userdata and made the following changes.

<filename>C:\Users\SiFuXBMC\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>

Everything else is the same. When I try to play any of my movies XBMC plays them and my TMT5 doesn't launch. Any help would be greatly appreciated.
Can you post your Playercorefactory.xml and PlayISO.bat codes in here?

Hi bluray,

I actually got it working using these settings but turns out it wasn't your code but my computer. I went ahead and reinstalled windows and it started working. Thanks again everything is working great!

<playercorefactory>
<players>
<player name="ISO_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\HTPC\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="BDMV_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\HTPC\AppData\Roaming\XBMC\userdata\PlayBDMV.bat</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<!-- Bluray ISO -->
<rule filename=".*iso.*" player="ISO_Player"/>
<!-- Bluray BDMV -->
<rule filename=".*bdmv.*" player="BDMV_Player"/>
</rules>
</playercorefactory>

@echo off
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEPlayer5.exe" F:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #785
(2012-07-09 19:21)sifuleeroy Wrote:  Hi bluray,

I actually got it working using these settings but turns out it wasn't your code but my computer. I went ahead and reinstalled windows and it started working. Thanks again everything is working great!
I'm glad that you got it to work......Nod

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
andyd Online
Senior Member
Posts: 261
Joined: Nov 2004
Reputation: 0
Post: #786
(2012-07-09 00:47)andyd Wrote:  Anyone here upgraded to the latest version of TMT5 and having issues with controls during playback?

I can longer exit out or control playback of a movie after launching a folder rip or iso

No one? I'm having loads of issues controlling TMT after launching an iso from xbmc. Half the time controls aren't recognized. The other times I only have limited functionality. I use Hippo on my iPhone that lets me switch between templates for TMT, WMC and XBMC. None of which work anymore. This seemed to be less of an issue with TMT 3
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #787
(2012-07-14 15:31)andyd Wrote:  I use Hippo on my iPhone that lets me switch between templates for TMT, WMC and XBMC. None of which work anymore. This seemed to be less of an issue with TMT 3
Sorry, I don't own iPhone and I cannot help you on it.....TMT5, 7MCE and XBMC works fine with MCE remote controller.....I can launch 7MCE, then XBMC within 7MCE UI, then select ISO movie within XBMC UI and then TMT5 launch automatically using MCE remote controller.......

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
andyd Online
Senior Member
Posts: 261
Joined: Nov 2004
Reputation: 0
Post: #788
Sorry I didn't meant to isolate the issue to my phone. I'm having issues with control even with Harmony. Sometimes it'll register...other times it won't

Does launching it from WMC make a difference? I don't use WMC anymore since moving away from Mediabrowser
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #789
(2012-07-14 21:09)andyd Wrote:  Does launching it from WMC make a difference? I don't use WMC anymore since moving away from Mediabrowser
It shouldn't make any different. I can control TMT5 without launchin 7MCE.....

If you're interesting in linking everything to 7MCE, you can check out my post #751......

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
awong Offline
Junior Member
Posts: 2
Joined: Jul 2012
Reputation: 0
Post: #790
@bluray

I noticed that using the provided playercorefactory.xml broke the Crunchyroll Takeout add-on because the regexp for the ISO_Player was too permissive. In particular, any Cruncyroll URL that had the word "episode" in it would match ".*iso.*"

What do you think about changing the regexps to be more locked down to something that looks like a filepath with extension. Maybe something like ".*\.iso$" for example (assuming XBMC regexps understand the $ anchor).
find quote
scudlee Offline
Team-Kodi Member
Posts: 839
Joined: Jul 2011
Reputation: 51
Post: #791
@awong Use the rule filetypes="iso" instead, as that only acts on the file extension.
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #792
(2012-07-17 10:56)awong Wrote:  @bluray

I noticed that using the provided playercorefactory.xml broke the Crunchyroll Takeout add-on because the regexp for the ISO_Player was too permissive. In particular, any Cruncyroll URL that had the word "episode" in it would match ".*iso.*"

What do you think about changing the regexps to be more locked down to something that looks like a filepath with extension. Maybe something like ".*\.iso$" for example (assuming XBMC regexps understand the $ anchor).
You can try this (<rule filenames="iso" filetypes="iso" player="ISO_Player"/>) If you download playercorefactory from the 1st page, it should included this code.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
awong Offline
Junior Member
Posts: 2
Joined: Jul 2012
Reputation: 0
Post: #793
Ah, I though I had downloaded the XML from the 1st page but apparently I must have a different version. Will try your suggestions. Thanks!
find quote
Ghostdivision Offline
Posting Freak
Posts: 754
Joined: Jan 2012
Reputation: 0
Post: #794
Out of curiosity anyone with an mce remote, do your red green yellow and blue buttons at the bottom do anything in tmt?

Mine say "audo" and "subtitle" but they dont do anything tmt...
find quote
siamsquare Offline
Member
Posts: 57
Joined: Jul 2012
Reputation: 0
Post: #795
Yo,

I'm new to XBMC so bear with me....I come from the mediaplayer scene and have been fiddling for 2 days now with XBMC which I quite like. As my media player doesn't take Full 3DBD iso's I started looking here and saw that my game pc could possibly play Full 3D movies! If all goes well I'm planning to buy new hardware for a HTPC.
But I'm having trouble with Full BD-iso with menu.....I tried to follow your tutorial but I can't get it to work and when I select an BD-iso in XBMC nothing happens! I've installed everything on the 1st page and would like to run TMT5.
So if any1 could help....

TY
find quote
Post Reply