Another External Player Code, but Very Simple to Setup

  Thread Rating:
  • 11 Votes - 4.27 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #541
(2012-04-21 17:23)ponic Wrote:  @bluray
thank for you help, i'm using this XBMC version http://dsplayer.passion-xbmc.org/ ,i thought this is latest version for XBMC and dsplayer
Let's me try to update GPU driver and config in video output.
No, the latest XBMC stable version is the Eden 11.0.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
andyd Offline
Senior Member
Posts: 254
Joined: Nov 2004
Reputation: 0
Post: #542
Have I done something wrong? For some reason XBMC keeps trying to mount index.bdmv but VCDMount refuses. I tried loading the movie in TMT 3 and TMT 5 both of which load the movie through a folder add. Given that, I would imagine VCDMount wouldn't be needed at all.

Below are my configs. I tried switching the filename option for bdmv in corefactory to use the universal player instead so the batch process wouldn't run but I get the same results

@echo off
rem you can place your PlayBDMV file in \Roaming\XBMC\userdata\
set pth=%1
set pth=%pth:BDMV\index.bdmv=%
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEDVDPlayer5.exe" %pth% exit


<playercorefactory>
<players>
<player name="ISO_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\Andy D\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>
<args>"{1}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="BDMV_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\Andy D\AppData\Roaming\XBMC\userdata\PlayBDMV.bat</filename>
<args>"{1}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="Disc_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\Andy D\AppData\Roaming\XBMC\userdata\PlayDisc.bat</filename>
<args>"{1}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="Universal_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEDVDPlayer5.exe</filename>
<args>"{1}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>

</player>
</players>
<rules action="prepend">
<!-- Bluray ISO -->
<rule filename=".*iso.*" player="ISO_Player"/>
<!-- Bluray BDMV -->
<rule filename=".*bdmv.*" player="Universal_Player"/>
<!-- Bluray M2TS -->
<rule filename=".*m2ts.*" player="Universal_Player"/>

<!-- Bluray Disc -->
<rule protocols="bd|dvd" player="Disc_Player"/>
</rules>
</playercorefactory>
(This post was last modified: 2012-04-21 21:23 by andyd.)
find quote
wraslor Offline
Junior Member
Posts: 14
Joined: Aug 2011
Reputation: 0
Post: #543
I'm hoping someone can help me out here. I want to use power dvd 11 to play m2ts, DVD, Bluray, and ISO files. I'm linking my player core files below. When I try to launch a m2ts or iso file xbmc freezes for about 10 secs and nothing happens.


btw H: is virtual from vcd and G: is bluray drive.

http://dl.dropbox.com/u/27640703/PlayBDMV.bat
http://dl.dropbox.com/u/27640703/PlayDisc.bat
http://dl.dropbox.com/u/27640703/playercorefactory.xml
http://dl.dropbox.com/u/27640703/PlayISO.bat

If someone could take a quick look and tell me what I'm missing I would appreciate it.
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #544
(2012-04-21 20:23)andyd Wrote:  </player>
</players>
<rules action="prepend">
<!-- Bluray ISO -->
<rule filename=".*iso.*" player="ISO_Player"/>
<!-- Bluray BDMV -->
<rule filename=".*bdmv.*" player="Universal_Player"/>
<!-- Bluray M2TS -->
<rule filename=".*m2ts.*" player="Universal_Player"/>

<!-- Bluray Disc -->
<rule protocols="bd|dvd" player="Disc_Player"/>
</rules>
</playercorefactory>
Since you are using the wrong rule, XBMC is confused. It's probably trying to use the next posibility to playback BDMV file. For it to work right, you need to replace this rule "<rule filename=".*bdmv.*" player="Universal_Player"/>" with this rule "<rule filename=".*bdmv.*" player="BDMV_Player"/>"..........

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
(This post was last modified: 2012-04-21 22:29 by bluray.)
find quote
andyd Offline
Senior Member
Posts: 254
Joined: Nov 2004
Reputation: 0
Post: #545
Oh it was set to do that but I tried switching it to Universal Player just to try something different
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #546
(2012-04-21 21:58)wraslor Wrote:  I'm hoping someone can help me out here. I want to use power dvd 11 to play m2ts, DVD, Bluray, and ISO files. I'm linking my player core files below. When I try to launch a m2ts or iso file xbmc freezes for about 10 secs and nothing happens.


btw H: is virtual from vcd and G: is bluray drive.

http://dl.dropbox.com/u/27640703/PlayBDMV.bat
http://dl.dropbox.com/u/27640703/PlayDisc.bat
http://dl.dropbox.com/u/27640703/playercorefactory.xml
http://dl.dropbox.com/u/27640703/PlayISO.bat

If someone could take a quick look and tell me what I'm missing I would appreciate it.
You can try this rule for PDVD11 blu-ray disc- (<rule name="Blu-Ray" filename="G:\\.*" filetypes="bdmv" player="Disc_Player"/>)


You can try these codes for ISO-
@echo off

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /I=H /d=0 %1
"C:\Program Files (x86)\CyberLink\PowerDVD11\PowerDVD11.exe" H:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
andyd Offline
Senior Member
Posts: 254
Joined: Nov 2004
Reputation: 0
Post: #547
Nevermind. Figured it out. It was a mixture of things including not formatting the name of the exe properly for TMT 5

Update: So I finally figured out why I was having issues in the first place. For some reason, Star Wars won't load. All other movies do. When I try to load Star Wars Phantom Menace, I get the error that the vcdmount can't load
(This post was last modified: 2012-04-21 23:17 by andyd.)
find quote
wraslor Offline
Junior Member
Posts: 14
Joined: Aug 2011
Reputation: 0
Post: #548
(2012-04-21 22:46)bluray Wrote:  
(2012-04-21 21:58)wraslor Wrote:  I'm hoping someone can help me out here. I want to use power dvd 11 to play m2ts, DVD, Bluray, and ISO files. I'm linking my player core files below. When I try to launch a m2ts or iso file xbmc freezes for about 10 secs and nothing happens.


btw H: is virtual from vcd and G: is bluray drive.

http://dl.dropbox.com/u/27640703/PlayBDMV.bat
http://dl.dropbox.com/u/27640703/PlayDisc.bat
http://dl.dropbox.com/u/27640703/playercorefactory.xml
http://dl.dropbox.com/u/27640703/PlayISO.bat

If someone could take a quick look and tell me what I'm missing I would appreciate it.
You can try this rule for PDVD11 blu-ray disc- (<rule name="Blu-Ray" filename="G:\\.*" filetypes="bdmv" player="Disc_Player"/>)


You can try these codes for ISO-
@echo off

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /I=H /d=0 %1
"C:\Program Files (x86)\CyberLink\PowerDVD11\PowerDVD11.exe" H:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u

Tried these and still no go. If I change powerdvd11.exe to pdvdlaunchpolicy.exe it will launch power dvd and then go to a black screen and nothing happens. Any ideas?
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #549
(2012-04-22 06:20)wraslor Wrote:  
(2012-04-21 22:46)bluray Wrote:  
(2012-04-21 21:58)wraslor Wrote:  I'm hoping someone can help me out here. I want to use power dvd 11 to play m2ts, DVD, Bluray, and ISO files. I'm linking my player core files below. When I try to launch a m2ts or iso file xbmc freezes for about 10 secs and nothing happens.


btw H: is virtual from vcd and G: is bluray drive.

http://dl.dropbox.com/u/27640703/PlayBDMV.bat
http://dl.dropbox.com/u/27640703/PlayDisc.bat
http://dl.dropbox.com/u/27640703/playercorefactory.xml
http://dl.dropbox.com/u/27640703/PlayISO.bat

If someone could take a quick look and tell me what I'm missing I would appreciate it.
You can try this rule for PDVD11 blu-ray disc- (<rule name="Blu-Ray" filename="G:\\.*" filetypes="bdmv" player="Disc_Player"/>)


You can try these codes for ISO-
@echo off

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /I=H /d=0 %1
"C:\Program Files (x86)\CyberLink\PowerDVD11\PowerDVD11.exe" H:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u

Tried these and still no go. If I change powerdvd11.exe to pdvdlaunchpolicy.exe it will launch power dvd and then go to a black screen and nothing happens. Any ideas?
Maybe, your htpc need this- Microsoft Visual C++ 2010 Redistributable Package (x86).

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
wraslor Offline
Junior Member
Posts: 14
Joined: Aug 2011
Reputation: 0
Post: #550
(2012-04-22 06:36)bluray Wrote:  
(2012-04-22 06:20)wraslor Wrote:  
(2012-04-21 22:46)bluray Wrote:  You can try this rule for PDVD11 blu-ray disc- (<rule name="Blu-Ray" filename="G:\\.*" filetypes="bdmv" player="Disc_Player"/>)


You can try these codes for ISO-
@echo off

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /I=H /d=0 %1
"C:\Program Files (x86)\CyberLink\PowerDVD11\PowerDVD11.exe" H:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u

Tried these and still no go. If I change powerdvd11.exe to pdvdlaunchpolicy.exe it will launch power dvd and then go to a black screen and nothing happens. Any ideas?
Maybe, your htpc need this- Microsoft Visual C++ 2010 Redistributable Package (x86).

already installed. I did try an .iso and it unmounted before the movie could play so I deleted the line "C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u[/color] and they iso now plays fine. However none of the m2ts files are playing. With powerdvd11.exe I get nothing and with the pdvdlaunchpolicy I get the black screen. This isn't making any sense lol.

I appreciate all the help hopefully we can figure this out.
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #551
@wraslor-

Let try these-

Create a UniversalPlayer.bat file-

@echo off

"C:\Program Files (x86)\CyberLink\PowerDVD11\powerdvd11.exe"


and use these playercorefactory codes-

<player name="Universal_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Users\media center\AppData\Roaming\XBMC\userdata\UniversalPlayer.bat</filename>
<args>"{1}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<!-- Bluray ISO -->
<rule filename=".*iso.*" player="ISO_Player"/>
<!-- Bluray BDMV -->
<rule filename=".*bdmv.*" player="BDMV_Player"/>
<!-- Bluray M2TS -->
<rule filename=".*m2ts.*" player="Universal_Player"/>

<!-- Bluray Disc -->
<rule name="Blu-Ray" filename="G:\\.*" filetypes="bdmv" player="Disc_Player"/>
</rules>
</playercorefactory>


Make sure to set PDVD11 to automatic launch fullscreen in PDVD11 UI.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
(This post was last modified: 2012-04-22 17:57 by bluray.)
find quote
wraslor Offline
Junior Member
Posts: 14
Joined: Aug 2011
Reputation: 0
Post: #552
@bluray

Same result xbmc freezes for a min and nothing happens. If I open up the task manager I can see that it launched powerdvd11.exe

It's like it isn't being brought to the front and playing. Doesn't make sense. In media browser for example it works fine everytime do they have some special switch im not aware of? I've looked through their config file and nothing jumps out at me.
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #553
@wraslor-

Something is conflicting in your HTPC then, the codes are correct......

One last try...change these 4 lines with the codes below-

<args>"{1}"</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>

Let me ask you this- Is your m2ts file work fine on PDVD11 without XBMC?

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
wraslor Offline
Junior Member
Posts: 14
Joined: Aug 2011
Reputation: 0
Post: #554
I'll give it a shot when I get home this evening, I'm about to head out for work. Yes the m2ts files (I have quite a few 3D movies encoded to m2ts) launch and play fine from power dvd itself or via mediabrowser launching powerdvd.

I appreciate all the help and I'll let you know what I find.
find quote
andyd Offline
Senior Member
Posts: 254
Joined: Nov 2004
Reputation: 0
Post: #555
(2012-04-21 23:09)andyd Wrote:  Nevermind. Figured it out. It was a mixture of things including not formatting the name of the exe properly for TMT 5

Update: So I finally figured out why I was having issues in the first place. For some reason, Star Wars won't load. All other movies do. When I try to load Star Wars Phantom Menace, I get the error that the vcdmount can't load

Sorry to bother again on this but I can't figure out what's going on with my Star Wars bluray rips

All other bluray rips launch properly. If I load the movie manually into TMT5, that works. But if I try to launch within XBMC, it will return a VCDMount error which should never happen?
find quote
Post Reply