[RELEASE] OzWeather - Australian Weather Addon using BOM data

  Thread Rating:
  • 3 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Troyp42 Offline
Senior Member
Posts: 135
Joined: Dec 2011
Reputation: 0
Location: Melbourne, Australia
Post: #106
The mini forecast that shows when you pause a movie is a great idea. You've done a great job with this add on. Thanks heaps for the quick fix btw.

Running Eden V11 Beta3 on ATV2 networked to Win7 PC using SMB shares.
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #107
Yeah I like it Smile - I enourage you to jsut copy the skin files to standard Confluence and/or mod your own Confluence rather than use the one in my repo though as I am slowly customising various things you may not like. I am putting in conditionals so that most of the major changes are off by default and I have my own settings panel now, so it's not a huge deal, but there may be updates to mainline Confluence I miss for a while as they update it - and I am using PVR Confluence as well, which is of course not suitable for everyone.

My XBMC stuff:
find quote
Troyp42 Offline
Senior Member
Posts: 135
Joined: Dec 2011
Reputation: 0
Location: Melbourne, Australia
Post: #108
I couldnt do that as I couldnt find a confluence folder or a 720P folder in my xbmc on atv2.

Running Eden V11 Beta3 on ATV2 networked to Win7 PC using SMB shares.
find quote
fastdump Offline
Junior Member
Posts: 41
Joined: Feb 2008
Reputation: 0
Post: #109
Troyp42 Wrote:I couldnt do that as I couldnt find a confluence folder or a 720P folder in my xbmc on atv2.
Troyp42, not sure if this will help...

XBMC, like many programs, has two main file locations: one where the main program and associated files are installed and one where the per-user profile files are stored.

Add-ons like bossanova808's OzWeather and others that are not part of the default XBMC install are in the addons folder in your user profile location. However, add-ons like the default Confluence skin are in the addons folder in the main XBMC install location.

For example, on my Windows 7 machine, XBMC is installed in...
[INDENT]C:\Program Files (x86)\XBMC[/INDENT]
... whereas all of my per-user settings, including all extra add-ons and their settings and all user preferences are in...
[INDENT]C:\Users\[username]\AppData\Roaming\XBMC[/INDENT]

So, for ATV2 , the OzWeather skin files are at...
[INDENT]/private/var/mobile/Library/Preferences/XBMC/addons/weather.ozweather/Skin files for extended features (copy to Confluence 720p)[/INDENT]
... and you would copy those files to the Confluence skin's 720p folder at...
[INDENT]/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/720p[/INDENT]

NB: I'm not 100% sure of the exact paths for ATV2 as I don't own one - the above locations are best that I could source from the interwebs Big Grin

█▀ ▄▀▄ ▄▀▀ ▀█▀ █▀▄ █─█ █▄─▄█ █▀▄
█▀ █▀█ ─▀▄ ─█─ █─█ █─█ █─█─█ █─█
▀─ ▀─▀ ▀▀─ ─▀─ ▀▀─ ─▀─ ▀───▀ █▀─
XBMC Frodo ← Win 7 ← ZBOX HD-N22
find quote
Troyp42 Offline
Senior Member
Posts: 135
Joined: Dec 2011
Reputation: 0
Location: Melbourne, Australia
Post: #110
Mate..I found the Ozweather skin files at /private/var/mobile/Library/Preferences/XBMC/addons/weather.ozweather

And the location of my 720P folder finally at

/private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/720p so thanks for that

but how do I change my skin back to the default skin before I copy these oz.weather files into my 720P folder.

I know it was only a few weeks back but I cant remember how I updated to the Bossanova808 skin in the first place. If I go into settings skin I just see a setting for the Bossanova skin only and no way to change to the default confluence skin which I assume I have to do first.

Running Eden V11 Beta3 on ATV2 networked to Win7 PC using SMB shares.
(This post was last modified: 2012-01-31 08:34 by Troyp42.)
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #111
Settings -> appearance -> top group (can't remember name) -> skin

My XBMC stuff:
find quote
Troyp42 Offline
Senior Member
Posts: 135
Joined: Dec 2011
Reputation: 0
Location: Melbourne, Australia
Post: #112
Thanks mate.

Running Eden V11 Beta3 on ATV2 networked to Win7 PC using SMB shares.
find quote
Freakish Offline
Member
Posts: 75
Joined: Dec 2009
Reputation: 0
Post: #113
Mine was working for a day or so, but have recently started to get script failed message.

My log mentions:

10:01:17 T:8648 ERROR: Traceback (most recent call last):
File "C:\Users\Me\AppData\Roaming\XBMC\addons\weather.ozweather\default.py", line 39, in <module>
common = CommonFunctions.CommonFunctions()
AttributeError: 'module' object has no attribute 'CommonFunctions'
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #114
You Need To Update (try force refresh on the repo)- the current line in question is:
common = CommonFunctions

..whereas the line in your error is the what it used to be...so you are clearly using an older version. That's always the first thing to try if you're having trouble with an add on, as very often a fixed version will be available. For most people, leaving auto-updates on is the best way to go so this is automatic.

...as an add on the add on uses (parseDOM - comes with YouTube so update that too for good measure although it should be automatic) was updated recently.

It's been running smooth as here....

My XBMC stuff:
find quote
Freakish Offline
Member
Posts: 75
Joined: Dec 2009
Reputation: 0
Post: #115
bossanova808 Wrote:You Need To Update (try force refresh on the repo)- the current line in question is:
common = CommonFunctions

..whereas the line in your error is the what it used to be...so you are clearly using an older version. That's always the first thing to try if you're having trouble with an add on, as very often a fixed version will be available. For most people, leaving auto-updates on is the best way to go so this is automatic.

...as an add on the add on uses (parseDOM - comes with YouTube so update that too for good measure although it should be automatic) was updated recently.

It's been running smooth as here....

I did uninstall and reinstall from you repository before I posted the log, do I need to install from the .zip file again? All my other addons have updated, I notice the YouTube addon auto updated this morning, as did my skin.

I will have another look..

Cheers.
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #116
You shouldn't need to uninstall/re-install, it should be automatic, and at most a force refresh on my repo should do it.

I'd say then that's an old log message from before the update. Restart your xbmc and let the weather refresh, see how you go (confirm the add on version is 0.3.4 - I think that's current).

If you see any new errors, let me know and post any errors in your log, plus let me know which settings (postcode, radar etc) you are using.

My XBMC stuff:
find quote
Freakish Offline
Member
Posts: 75
Joined: Dec 2009
Reputation: 0
Post: #117
Cheers, I tried forcing refresh and restarted and it updated the script, tis working again.

Thanks.
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #118
No probs

My XBMC stuff:
find quote
kozak069 Offline
Junior Member
Posts: 2
Joined: Feb 2012
Reputation: 0
Post: #119
I'm keep getting this error in my logs. Any ideas?


11:32:08 T:2879949680 M:2023313408 NOTICE: -->Python Interpreter Initialized<--
11:32:08 T:2879949680 M:2023313408 ERROR: Error Type: exceptions.SyntaxError
11:32:08 T:2879949680 M:2023313408 ERROR: Error Contents: ('invalid syntax', ('/home/bill/.xbmc/addons/weather.ozweather/default.py', 110, 23, ' except Exception as inst:\n'))
11:32:08 T:2879949680 M:2023313408 ERROR: File "/home/bill/.xbmc/addons/weather.ozweather/default.py", line 110
except Exception as inst:
^
SyntaxError: invalid syntax
find quote
bossanova808 Offline
Donor
Posts: 2,237
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #120
No errors here under Windows 7 or Openelec (linux, basically) - what platform are you on?

That's a pretty basic bit of the script and the syntaax is definitely correct - maybe there's a weird CR/LF thing going on, I am not sure about that '\n' bit as that's not in the source obviously, but might be coming from the xbmc log stuff.

My XBMC stuff:
find quote
Post Reply