New Home for Ember Media Manager (Official Thread)

  Thread Rating:
  • 26 Votes - 4.58 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
MeMeMe Offline
Senior Member
Posts: 171
Joined: Sep 2011
Reputation: 5
Post: #1171
(2012-05-31 15:40)rocks911 Wrote:  Is there a program that can deal with creating folders for movies/TV shows?
I am interested in using Ember but dont have my movies in a folder of their own. I have lots of content and the process would be daunting to do by hand.

Check file2folder here: http://code.google.com/p/file2foldergui/downloads/list

When you run it, you'll pick a folder. It will then look at all the files in the folder, and for each one, create a folder and move the file into it.

The downside - if you have multiple files reloating to a single movie (like movie-cd1, movie-cd2, movie-srr) I think it creates a separate folder for each of them.

But it still dramatically reduces the amount of work to do for most people.You might just have a few to clean up and correct like that.
find
kevjs1982 Offline
Member
Posts: 78
Joined: Mar 2010
Reputation: 2
Location: South Nottinghamshire
Post: #1172
(2012-05-30 21:48)kevjs1982 Wrote:  I've tried to add a new folder to Ember today and when I attempt to scan it I get the following error

Code:
================= <Assembly Versions> =================


Title: Error
Message: String was not recognized as a valid DateTime.
StackTrace:    at System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
   at System.Convert.ToDateTime(String value)
   at EmberAPI.Scanner.bwPrelim_DoWork(Object sender, DoWorkEventArgs e)
Date/Time: 30/05/2012 20:42:33
================================================================================​===========

I have tried downloading the latest version and running from my desktop, disabling the scrapers and then adding a known good folder and it still does exactly the same thing - is there any further debugging I can see to see if it's my machine (running Vista) or library or is it a known bug. Any existing folder in my primary install can be scanned as normal.

Sorted it - looks like it's using an odd date format when adding a new folder.

If you open the Media.emm in a SQLite browser the LastScan of most files is in the format of "31/05/2012 21:26:51"

However for the newly added folder the LastScan value is "5/31/2012 9:30:05 PM" (note the day and month being back to front and the use of the 12 hour clock).

Running the query

update sources set LastScan = "01/01/2012 21:00:00" WHERE ID = 8

Got it working again Smile
(This post was last modified: 2012-05-31 23:47 by kevjs1982.)
find
sirreef Offline
Junior Member
Posts: 35
Joined: Aug 2008
Reputation: 0
Post: #1173
Perhaps I'm confused - but Ember keeps writing over my predownloaded folder.jpg/fanart.jpg.

I ask it to scrape a movie and it deletes the art.

Please help.
find
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #1174
Keeps freezing on me! I want to rescrape my whole movie section and it starts but after the 1st or 2nd one it freezes and has to be hard closed... What am I doing wrong? I just .nfo's and artwork for all of my movies so xbmc doesn't need to add any.

[Image: all-thin-banner@2x.jpg]
find
rocks911 Offline
Member
Posts: 68
Joined: Oct 2011
Reputation: 0
Post: #1175
Having trouble.
I am using v2421_x86 on my W7 64 bit machine.
I first created folders for each movie (I had them all in just a couple of folders) which took no time at all.
I then scraped my 600 movies. Darn few were successfully scraped, I mean like twenty or so.
I made no adjustments to the default scraper settings, just used auto. Dont know why so few were successful.

Any thoughts?
(This post was last modified: 2012-06-05 20:48 by rocks911.)
find
ciris Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #1176
(2012-06-03 10:57)crimsonfury Wrote:  Keeps freezing on me! I want to rescrape my whole movie section and it starts but after the 1st or 2nd one it freezes and has to be hard closed... What am I doing wrong? I just .nfo's and artwork for all of my movies so xbmc doesn't need to add any.



I got the same thing. When i turned off notifications everything went fine.
find
rocks911 Offline
Member
Posts: 68
Joined: Oct 2011
Reputation: 0
Post: #1177
Notifications?

Unfortunately the same is happening for me, cant find notifications though, in settings?
find
ciris Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #1178
Settings and then go to modules.
find
rocks911 Offline
Member
Posts: 68
Joined: Oct 2011
Reputation: 0
Post: #1179
Nevermind, found it.
Doesnt lock up now, but also doesnt return many results.

Is there a program that works better, or is this cutting edge?
find
ciris Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #1180
If you don't get many results it is probably a settings issue. Ember find everything here. Did you named your files correctly?
find
rocks911 Offline
Member
Posts: 68
Joined: Oct 2011
Reputation: 0
Post: #1181
I have used a pretty typical naming convention.
For example: Fear And Loathing In Las Vegas (1998)
Indiana Jones And The Kingdom Of The Crystal Skull (2008)
Clerks 2 (2006)

with both the movie and the folder having the same name.

Out of 538 movies 10 are tagged.

Does it matter what format they are in? I have MKV, AVI, and others, but really that doesnt seem to matter. Not sure what is going on.
find
ciris Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #1182
Did you make sure you chose for recursive scanning?
find
rocks911 Offline
Member
Posts: 68
Joined: Oct 2011
Reputation: 0
Post: #1183
I tried using Ember portable 1.2.2385, couldnt even successfully add a source. I specified the path but the OK button never illuminated.
Six hours later, no joy.
Try another day.
Any help would be appreciated.

Yes I chose recursive scanning.
I followed this tutorial:http://www.howtogeek.com/61976/how-to-use-ember-media-manager-to-whip-your-media-collection-into-shape/

This is how these things seem to go, I think its the W7 64 bit machine, I have nothing but trouble with it getting along with other programs.

Thanks Chris for taking the time, I really appreciate the kindness of strangers
(This post was last modified: 2012-06-05 22:20 by rocks911.)
find
ciris Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #1184
Wow, that's and old version. Check the new one. You can find it in the topicstart.
find
DanCooper Offline
Moderator
Posts: 1,362
Joined: Apr 2012
Reputation: 66
Location: Switzerland
Post: #1185
(2012-06-05 22:22)ciris Wrote:  Wow, that's and old version. Check the new one. You can find it in the topicstart.

Dont take the version from topicstart. This version have a SQL error. Thake the version from my signature.

Latest Ember-MM version - [Release] Ember Media Manager 1.3.x
German XBMCNerds
find
Thread Closed