How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs

  Thread Rating:
  • 23 Votes - 4.52 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #31
fritsch, more than an hour of LiveTV interlaced content playback with SS enabled and so far so good.
find
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #32
kobik Wrote:fritsch, more than an hour of LiveTV interlaced content playback with SS enabled and so far so good.

Yeah! This sounds really good. Packages will hit xbmc-xvba repository when launchpad ist ready - build pending.
find
Infinitatus Offline
Junior Member
Posts: 18
Joined: Nov 2011
Reputation: 0
Post: #33
[quote=kobik]@Infinitatus,
Set VSync to always on under System->Video settings.
It's the FPS that is going crazy here, but putting a limit on them will decrease your CPU usage on idle.

How dum of me. I see it now. Thanks (already down to 10%)
find
DejaVu Offline
Posting Freak
Posts: 1,159
Joined: May 2010
Reputation: 3
Location: United Kingdom
Post: #34
Installing using Oneiric Minimal is not an option for me. My Wifi card is not detected by it (I only have a Wifi card in this device!)

I've since downloaded the full 11.10 Ubuntu CD with the hope of installing a minimal CLI version of Ubuntu from that which does include the driver - but no dice - I couldnt work out or google the correct answer.

Can anyone assist getting a Minimal install on my system so I can attempt to do this please?!

[Image: watched-fanart.jpg]
Maraschino - Web based HTPC Organiser. Keep track of all your web based programs all in one place.
Home Page - Repo - Bug Tracker - Support Forum.
find
wsnipex Offline
Team-XBMC packaging monkey
Posts: 3,486
Joined: Jun 2011
Reputation: 84
Post: #35
DejaVu Wrote:Installing using Oneiric Minimal is not an option for me. My Wifi card is not detected by it (I only have a Wifi card in this device!)

I've since downloaded the full 11.10 Ubuntu CD with the hope of installing a minimal CLI version of Ubuntu from that which does include the driver - but no dice - I couldnt work out or google the correct answer.

Can anyone assist getting a Minimal install on my system so I can attempt to do this please?!

Just use the normal desktop version, if you start xbmc as a lightdm session as instructed in the guide, there won't be too much overhead. you can still slim down later on if you deem necessary.
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #36
No crashes at all on playing interlaced content this evening.
great work guys!
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #37
On system reboot XBMC crash in a loop for 6-8 times in row Sad
Happened for me a few times already also with the stable version.
find
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #38
kobik Wrote:On system reboot XBMC crash in a loop for 6-8 times in row Sad
Happened for me a few times already also with the stable version.

Did you install everything like provided by this howto?

Normally system reboot crashes are not xvba dependend, but the xbmc.log could tell more.
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #39
Of course.
Not to be offensive of course, but these and other menu navigation crashes didn't not happen using Lars' git.
find
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #40
Mmh, we are totally based on Lars git. We rebase on him.
Could you provide xbmc.log files? When this crash happens?

Again: Crash means: your xbmc session just "restarts"?
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #41
By crash I mean that XBMC process is destroyed.

I'll provide the logs later this evening when I'll get home.
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #42
I would recommend to add to the OP to set VSync to always on under System->Video settings, so the CPU usage on idle wouldn't be so high.

Edit: What extra packages or settings are required for suspend/resume besides what stated in the OP?
(This post was last modified: 2011-12-18 11:17 by kobik.)
find
kobik Offline
Senior Member
Posts: 100
Joined: Jan 2009
Reputation: 4
Post: #43
DejaVu Wrote:Installing using Oneiric Minimal is not an option for me. My Wifi card is not detected by it (I only have a Wifi card in this device!)

I've since downloaded the full 11.10 Ubuntu CD with the hope of installing a minimal CLI version of Ubuntu from that which does include the driver - but no dice - I couldnt work out or google the correct answer.

Can anyone assist getting a Minimal install on my system so I can attempt to do this please?!

Did you try to follow the logs?
On mine, my DVB card and network wasn't detected with 11.10, so I needed to download a firmware and deb files and install them manually.
find
grad Offline
Junior Member
Posts: 45
Joined: Dec 2011
Reputation: 0
Location: de
Post: #44
Hello,

first off, huge thanks for this effort. It made me - finally - seriously consider dumping the MythTV frontend.

However, there's one BIG showstopper: in MythTV, I used to have the player automatically switch the screen to the proper refresh rate, most notably 24p. While XBMC seems to support this, and even actually and properly xrandr's to the correct mode, the display is totally garbled. It's ok when I escape out of fullscreen mode back into the menu. xrandr works just fine on the console, and of course in the MythTV frontend.

Everything else seems to work just fine, including advanced shaders, XvBA, and shared surfaces. When I turn off all XvBA options, the problem persists.

My system: RS 780G Radeon HD 3200 on Mythbuntu 10.04 Natty. Compositing turned off in xfwm4. Catalyst 11.12. Using the xbmc-xvba ppa. I did turn on debugging and analysed the log, no apparent errors. Anything else needed to pinpoint the cause?

Thanks for any help and pointers!
find
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #45
grad Wrote:Hello,

first off, huge thanks for this effort. It made me - finally - seriously consider dumping the MythTV frontend.

However, there's one BIG showstopper: in MythTV, I used to have the player automatically switch the screen to the proper refresh rate, most notably 24p. While XBMC seems to support this, and even actually and properly xrandr's to the correct mode, the display is totally garbled. It's ok when I escape out of fullscreen mode back into the menu. xrandr works just fine on the console, and of course in the MythTV frontend.

Everything else seems to work just fine, including advanced shaders, XvBA, and shared surfaces. When I turn off all XvBA options, the problem persists.

My system: RS 780G Radeon HD 3200 on Mythbuntu 10.04 Natty. Compositing turned off in xfwm4. Catalyst 11.12. Using the xbmc-xvba ppa. I did turn on debugging and analysed the log, no apparent errors. Anything else needed to pinpoint the cause?

Thanks for any help and pointers!

This works fine with us. Could you give the output of xrandr -q?
Does it work, if you switch the mode in xfwm before and just leave it untouched in xbmc?
find
Thread Closed