Missing Movie Scanner

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Vaikin Offline
Fan
Posts: 729
Joined: Mar 2012
Reputation: 15
Location: Toronto, Canada
Post: #76
I don't know a whole hell of a lot, but it says it couldn't load json, which I think means you have an old version of python/xbmc. Not entirely sure though Confused

xbmc eden is version 11 btw.
find quote
buskeyl Offline
Junior Member
Posts: 3
Joined: Nov 2012
Reputation: 0
Post: #77
Sorry if this is a noob question, but the scanner worked great for me, it found 70 or so missing videos. Is it supposed to add them to the library for me? Also, with a coulpe of exceptions, it seems to be missing movies which are in folders that have underscores in them. Such as \\qnap\movies\_Batman Series

Is there anything I can do to deal with that or do I have to reanme the folders?
find quote
Vaikin Offline
Fan
Posts: 729
Joined: Mar 2012
Reputation: 15
Location: Toronto, Canada
Post: #78
It just identifies items that are in source directories but not added to the library. You'd have to manually add them yourself.

An easier and likely more long-term solution would be to maintain a better folder/naming structure to prevent having to do this again.

So having things named like:

Batman Begins (2005) and The Dark Knight (2008) would save you a lot of issues. They would be scraped and automatically added. Hassle free Smile
find quote
buskeyl Offline
Junior Member
Posts: 3
Joined: Nov 2012
Reputation: 0
Post: #79
Thanks,

It's still very helpful. Just was not sure if it was supposed to add them or not. I do have a very specific and structured naming standard, that ALMOST works perfectly with XBMC. Probalm is I am trying to use the same source location to run multiple devices, and there a bit of conflict apparently. I am trying to use XBMC on the house PC's, For the home theater systems (I use Popcorn Hour and Boxee Box) I use YAMJ running as a cron job on the home NAS to generate the skins those players load. It turns out not to be the underscores at all, but the file name, One of the allowed syntax rules within YAMJ is to prefix the file name with [Set - The batman series] which will cause YAMJ to build a set, very similar to XBMC collections. Unfortunately, XBMC doesn't know how to handle the file names that start with this bracketed syntax, and apparently just ignores them.
(This post was last modified: 2012-11-05 22:26 by buskeyl.)
find quote
rumpleforeskin Offline
Junior Member
Posts: 8
Joined: Oct 2012
Reputation: 0
Post: #80
(2012-07-18 05:42)ozp1 Wrote:  hello. I dont know if is too obvious, but what can we do when we find missing movies?
Besides changing the file name or finding the correct scraper, what if the movie is not listed anywhere?

Also when I search the TV series, I get 146 files not listed at library, but most of them are listed ok.

There are no error messages, but for sure this is not working as it should with this folder (TV series)

I use ubuntu 12.04 and xbmc version 11

same problem for me.
Movie scan was good and the addon found a few movies that are missing, I fixed the names (usually wrong year) and then they scraped correctly.

Moving on to the TV Show folder it listed over a 1000 missing shows, but I was sure I had watched some of them. So I noted a few down then checked my library and they were there!

Is this a known bug? if not I could post a log to paste bin if it will help.

Im running eden on win7 64

PS thanks for your work on this tool, it certainly saved me alot of time comparing a list of my movies with the xbmc library Smile
find quote
bsphere Offline
Junior Member
Posts: 11
Joined: Aug 2010
Reputation: 0
Post: #81
Thanks for this plugin I had 10 missing movies reported and I could add one after checking xbmc debug log to see what went wrong. The rest are false positives or xbmc being weird on me, like adding Kung Fu Panda, but refusing to show Kung Fu Panda 2 in the library.

edit: oh, removing nfo files did the trick yay
edit2: alright, down to 5 false positives and they are all VIDEO_TS.IFO - I guess that is hard to match.
(This post was last modified: 2012-11-11 13:05 by bsphere.)
find quote
rickginer Offline
Junior Member
Posts: 1
Joined: Nov 2012
Reputation: 0
Post: #82
(2012-11-10 19:46)rumpleforeskin Wrote:  
(2012-07-18 05:42)ozp1 Wrote:  Also when I search the TV series, I get 146 files not listed at library, but most of them are listed ok.

same problem for me.
Movie scan was good and the addon found a few movies that are missing, I fixed the names (usually wrong year) and then they scraped correctly.

Moving on to the TV Show folder it listed over a 1000 missing shows, but I was sure I had watched some of them. So I noted a few down then checked my library and they were there!

Is this a known bug? if not I could post a log to paste bin if it will help.

Really helped me find missing movies! Great tool!

But I am also getting false errors when scanning TV shows. Could it be due to the large number of files? It handled 800 in the movies share no problem, reporting 30 missing files, but all my TV shares failed (ranging from 2000-6000 files per share). For example, scanned 6000 files, said 2000 files found, 1995 missing - but nearly all of those reported as missing are in the library.

I have tried this on Eden with v. 3.3 and 3.5
find quote
asturnauta Offline
Junior Member
Posts: 25
Joined: Nov 2012
Reputation: 0
Post: #83
(2012-11-13 08:25)rickginer Wrote:  
(2012-11-10 19:46)rumpleforeskin Wrote:  
(2012-07-18 05:42)ozp1 Wrote:  Also when I search the TV series, I get 146 files not listed at library, but most of them are listed ok.

same problem for me.
Movie scan was good and the addon found a few movies that are missing, I fixed the names (usually wrong year) and then they scraped correctly.

Moving on to the TV Show folder it listed over a 1000 missing shows, but I was sure I had watched some of them. So I noted a few down then checked my library and they were there!

Is this a known bug? if not I could post a log to paste bin if it will help.

Really helped me find missing movies! Great tool!

But I am also getting false errors when scanning TV shows. Could it be due to the large number of files? It handled 800 in the movies share no problem, reporting 30 missing files, but all my TV shares failed (ranging from 2000-6000 files per share). For example, scanned 6000 files, said 2000 files found, 1995 missing - but nearly all of those reported as missing are in the library.

I have tried this on Eden with v. 3.3 and 3.5

Same problem in my XBMC Eden. For movies works fine, but TV Shows has all episodes as false positives.


Regards.
find quote
matt77303 Offline
Fan
Posts: 349
Joined: Dec 2011
Reputation: 6
Post: #84
Thanks for this addon works great for movies.

But same as above reports all tv shows missing.

Matt

CPU - AMD Athlon™ II X2 Dual-Core 3.4Ghz
MB - ASUS M5A78L-M/USB3, Nvidia 610 2GB
RAM - 4GB DDR3 Dual-Channel
OS - XBMC Frodo
TV - Panasonic TX-P50S21B
Home Cinema - Pioneer VSX-S300 5.1
Remote - Harmony one
find quote
photonoxx Offline
Junior Member
Posts: 3
Joined: Jan 2013
Reputation: 0
Post: #85
Hi,

This addons is a great tool, but it would be nice if i was possible too access to some function like rename or refresh info (with title asking) directly from the MMS list.

I notice the same behavior for the TV Shows, but I think it's due to the fact the episodes infos are not in the same database table.
find quote
TomTom2000 Offline
Junior Member
Posts: 25
Joined: Dec 2012
Reputation: 0
Post: #86
What does "error walking the source path" mean?

I got it when scanning the TV directory of my selected folders.
find quote
photonoxx Offline
Junior Member
Posts: 3
Joined: Jan 2013
Reputation: 0
Post: #87
Hi,

For the error message, it seems to say there's a problem to list what's inside a particular directory (may it's empty ?)

Anyway MMS is not designed to look for missing TV shows files in library.

I don't really know python scripting (just a bit PHP) but I try to modify MMS extension to get working with TV Shows episodes.

After some test, I found something which seems to be functional.

http://photonoxx.free.fr/forum/plugin.video.mtvs.zip

you have to install this addons with install from zip functionality (do this at your own risk, even if it should not be risky)

What I do :
I quickly modify addons name (in addons.xml) and file name, so you can use beside MMS.
I change scan_movie_source function (in default.py) method to get info, from videolibrary.getmovies to videolibrary.getepisodes, I remove the catching about trailer info in Videolibrary.getEpisodes (trailer info doesn't exists for tvshows) and comment part of the script related to Movies trailer.

After some test, it seems to work, initially, MMS found 1993 files over more 4000 files and 1993 files was missing.

Now I get only 90 missing files (all seems to met with really not recognized files (merged episodes and other things)).

Since MMS only work for movies, MTVS (missing TV scanner) should only work with tv shows sources (do more is beyond my competences... sorry).

I probably can't do more, but if it works for you too, I would appreciate to know it Wink (and sorry for my poor and awful english)
find quote
falafael Offline
Fan
Posts: 498
Joined: Aug 2006
Reputation: 1
Location: Nottinghamshire, united kingdom
Post: #88
is this addon still working?

[Image: widget]
find quote
codepony Offline
Junior Member
Posts: 11
Joined: Dec 2012
Reputation: 1
Post: #89
(2013-01-24 00:06)falafael Wrote:  is this addon still working?

I just tried it, the output is really messed up and it seems to ignore the "don't search sub-directories" option.

I hope someone can update it, it's a function that should be built into XBMC.
find quote
Marx1 Offline
Senior Member
Posts: 273
Joined: Jan 2011
Reputation: 3
Post: #90
I've tried photonoxx change and it works on Frodo
find quote
Post Reply