MediaPortal TV recordings not showing in XBMC listing

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
steve_s741 Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #1
I am using MediaPortal 1.2.2.0 with the XBMC TV Server plugin (v1.2.1.109) as the TV server backend, and I have XBMC (Eden PVR build) front ends running on 2 machines, one of which is the same host as the backend. Both are Windows 7 machines. My problem is that when I go to Live TV - Recordings in XBMC, I see two directories listed as follows:

:\ProgramData\Team Media Portal TV Server\recordings
:\recorded tv

but when I select either of these, I get an empty list with just the backup one directory level (.., up arrow) option available to me.

I can see recordings in the directory I specified in the MediaPortal TV Server configuration under TV Servers-Folders-Recording folder (in my case I have set this to "D:\recorded tv"). In this directory I see files of type MPEG-2 TSVideo and XML for the recordings I have made. I can also see and play these recordings in the TV/Recorded TV listing when I run MediaPortal. So this all suggests that MediaPortal configuration is good and problem seems to be in the interaction between XBMC PVR build and MediaPortal backend, as the recordings directory doesn't appear to be configurable in XBMC (and shouldn't be if I understand the architecture as this would be a backend configuration item as I see it). Any clues where I should look to fix this?

Otherwise, very happy with the setup. Keep up the good work!

Steve
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #2
I've added some logic to determine recording subdirs relative to a base path.
At startup, the addon asks the TV Server what the storage location is of the recordings.
When adding the recordings to XBMC it removes the base path.
Somehow in your case, it detects "D" as base path, which is of course not correct. I'll look into this... Thanks for reporting.

Could you try the following? Make the recording path the same for all cards. Use the "Same recording folder for all cards" button under "Recording" tab "Folders" in the TV server configuration and try again.
If this does not work either, I'm very interested in a debug XBMC.log file posted on pastebin.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
steve_s741 Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Smile   
Post: #3
Thanks margro for your prompt reply. I actually have the "same folder for all cards" setting already selected. But I will try and find the log file to which you refer, and then work out what a "pastebin" is:-)

Steve
find quote
steve_s741 Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #4
ah, ok...

http://pastebin.com/azExDiqf
find quote
steve_s741 Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #5
Hi margro. Any clues on this issue? Do you need any more debugs to help with this?

Thanks, Steve
find quote
Cromm Offline
Junior Member
Posts: 3
Joined: Feb 2012
Reputation: 0
Post: #6
I have exactly the same problem here. Recordings directory registered correctly and browse-able from within XBMC but no actual recordings visible within the directory structure. I was using eden beta 1 but recently upgraded to beta3 and also updated the mediaportal plugin to the latest version to see if the problem sorted itself out but no joy.

I'll hunt the forums for a possible solution and post here if I manage to sort it out.

Cheers,
Crom
find quote
Cromm Offline
Junior Member
Posts: 3
Joined: Feb 2012
Reputation: 0
Post: #7
I've discovered the problem. Mediaportal was saving the recordings in a folder structure underneath the recording folder. This was not being scanned correctly by XBMC which lead to a list of folders with no contents being shown under the 'recordings' tab.

To solve this, I opened up Mediaportal TV server config and went to recordings and then manually chose a custom file name (that meant that all the recordings were saved in the root of my chosen recordings folder) for BOTH series and one-off recordings.

I now have a perfect list of recordings.

Apologies if I missed this step in the documentation but if I didn't then it might be worth adding it.

Hope this helps others,
Crom
find quote