[RELEASE] 4oD (Video) Addon - UK Channel 4 on demand

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
eagle-eye Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 0
Post: #181
Sorry, I was talking rubbish. Index error is there in Linux log as well.

I'll shut up now.

19:33:09 T:2766142320 NOTICE: File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/default.py", line 322, in <module>
19:33:09 T:2766142320 NOTICE: PlayOrDownloadEpisode( episodeId, title, mycgi.Param('fn') )
19:33:09 T:2766142320 NOTICE: File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/default.py", line 148, in PlayOrDownloadEpisode
19:33:09 T:2766142320 NOTICE: decodedToken = fourOD_token_decoder.Decode4odToken(token)
19:33:09 T:2766142320 NOTICE: File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 495, in Decode4odToken
19:33:09 T:2766142320 NOTICE: decryptedBytes = bf.decrypt( encryptedBytes )
19:33:09 T:2766142320 NOTICE: File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 486, in decrypt
19:33:09 T:2766142320 NOTICE: self.unpad( decrypted )
19:33:09 T:2766142320 NOTICE: File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 461, in unpad
19:33:09 T:2766142320 NOTICE: a.pop()
19:33:09 T:2766142320 NOTICE: IndexError: pop from empty list
19:33:09 T:2766142320 ERROR: Error Type: <type 'exceptions.IndexError'>
19:33:09 T:2766142320 ERROR: Error Contents: pop from empty list
19:33:09 T:2766142320 ERROR: Traceback (most recent call last):
File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/default.py", line 322, in <module>
PlayOrDownloadEpisode( episodeId, title, mycgi.Param('fn') )
File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/default.py", line 148, in PlayOrDownloadEpisode
decodedToken = fourOD_token_decoder.Decode4odToken(token)
File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 495, in Decode4odToken
decryptedBytes = bf.decrypt( encryptedBytes )
File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 486, in decrypt
self.unpad( decrypted )
File "/home/ee/.xbmc/addons/paddycarey-plugin.video.4od-0068424/fourOD_token_decoder.py", line 461, in unpad
a.pop()
IndexError: pop from empty list
find
stammie Offline
Senior Member
Posts: 111
Joined: Oct 2011
Reputation: 4
Post: #182
For those experiencing problems with 4od especially with Homeland I've just read on another forum that there are issues with 40d which they have admitted is an ongoing problem

Quote:Up to 2 weeks ago I could watch Homeland on 4oD without any problem. Now I can no longer stream nor even watch older episodes that are still available. The adverts leading up to recent episodes stream ok, but when the show starts I get the error message "rights to this asset is no longer available".. Other 4oD shows play with no problem. Anyone else finding the same problem?

Quote:Have you complained to Channel 4?

Quote:Yes. I sent them an email on Sunday. They've replied today and admitted there's an issue with 4oD at the moment which they have been trying to resolve, so I'm glad it's not my pc or browser, although the problem occurs on 2 other browsers that I've tried.
find
eagle-eye Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 0
Post: #183
I had this issue of "rights to this asset" when trying to watch Homeland through a browser too.

I also did some tests on the script error in XBMC on about a dozen different programmes. In my limited tests the script error only occurred on programmes with adult or strong language warnings, although not on all of them.
find
procrastinator Offline
Fan
Posts: 443
Joined: Aug 2008
Reputation: 4
Location: UK
Post: #184
Problem: When I try and watch a show then it'll play fine for about 1 minute, and then will stop.

How I got there: I was originally running the Nibor version, and getting a script error on loading the plugin. So then I installed the fixed plugin file that was uploaded by paddycarey in post#171 (thanks paddycarey!), and since then have been able to access the program list and start playing programs. However, as stated above playback stops after about 1 minute.

What I've tried to fix the problem: The problem reminded me of SWF verification problems that I've experienced with other plugins in the past (e.g. BBC iPlayer), so I tried changing the librtmp file. I'm running XBMC on an ATV2 so the one I used was this one which was brought up on the iOS help forums a while ago. This one was uploaded in December, so to be honest I don't know if this one is older or newer than the one packaged with XBMC Eden, but either way I experience the same problem.

Example: This example was performed in XBMC Eden (11.0) for iOS (on ATV2), with the modified librtmp as described above. The course of events in the log file (below) was:
1. open 4oD plugin, and navigate to program
2. select episode to play
3. On this occasion the episode immediately failed to play twice with a plugin error notification on-screen (this doesn't always happen). In the log file these events are on line #576 and #610 (same error: "Error Type: <type 'exceptions.AttributeError'>")
4. Played an episode, which starts fine, plays for about a minute, and then hits an error and playback stops (log file line#1058 "ERROR: WriteN, RTMP send error 32 (46 bytes)").
5. unrelated: TV Catchup script automatically updates its EPG listings
6. Tried playing another episode. Again, played fine for a about a minute and then failed again (log file line#2921: "ERROR: WriteN, RTMP send error 32 (5 bytes)")

log file link: http://pastebin.com/SKXv9sZr

So has anyone got any suggestions as to what's causing this, and what might be done to fix it?
find
Jarviss Offline
Member
Posts: 51
Joined: Aug 2011
Reputation: 0
Post: #185
I'm having his exactissue. Havent had time to look at a log yet though.
find
dazzer272 Offline
Junior Member
Posts: 15
Joined: Mar 2012
Reputation: 0
Post: #186
Hi having probs with 4od cutting out after 1min i eden final build on aptv2 any ideas to fix many thanks
find
Sneeka Offline
Member
Posts: 87
Joined: Apr 2009
Reputation: 0
Post: #187
Have you tried paddycarey's edit available here?: http://forum.xbmc.org/showthread.php?tid...pid1081384

Works for me. Although sometimes a script error will popup when I first select a video to play, but if I retry a couple of times it eventually starts.

EDIT: sorry, didn't read your post clearly enough, it appears you have tried that.
(This post was last modified: 2012-05-02 21:56 by Sneeka.)
find
alnicol Offline
Junior Member
Posts: 6
Joined: Mar 2012
Reputation: 0
Post: #188
(2012-05-02 21:51)Sneeka Wrote:  Although sometimes a script error will popup when I first select a video to play, but if I retry a couple of times it eventually starts.

The 'paddycarey' version doesn't include the fix to the ll delivery network and so whenever you get (randomly?) a ll url it will fail. The fix is available here if paddycarey wants to add it to his fork:
http://code.google.com/p/nibor-xbmc-repo...etail?id=3
find
castalla Offline
Fan
Posts: 549
Joined: Aug 2011
Reputation: 11
Post: #189
Whatever this is supposed to do, it just produces a script error.

This plugin is pretty much buggered.
find
eagle-eye Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 0
Post: #190
Alnicol's version seems to work much better.

I did some random testing of about 20 programmes and the only ones to fail with the script error were Homeland and The Killing.

Some programmes which failed on my previous tests worked ok although in some cases you had to have two goes before they would play.

I'm running the latest version of XBMC on a laptop with Linux Mint.
find
castalla Offline
Fan
Posts: 549
Joined: Aug 2011
Reputation: 11
Post: #191
(2012-05-03 23:13)eagle-eye Wrote:  Alnicol's version seems to work much better.

I did some random testing of about 20 programmes and the only ones to fail with the script error were Homeland and The Killing.

Some programmes which failed on my previous tests worked ok although in some cases you had to have two goes before they would play.

I'm running the latest version of XBMC on a laptop with Linux Mint.


I must have done something very wrong - but what?

This Alnicol version just produces a script error as soon as the plugin starts.
find
eagle-eye Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 0
Post: #192
Booted my laptop in Windows 7 and installed the Alnicol plugin.

Guess what? Script error as soon as the plugin starts.

Have to do some more experiments tomorrow.
find
cromity123 Offline
Member
Posts: 60
Joined: Oct 2008
Reputation: 0
Location: UK
Post: #193
OK, looks like I got it working again on my ATV2... As others have said Homeland doesn't work but was able to watch over 1 minute of 2 Broke Girls - advise you not to bother - it's rubbish. Not tried anything else, will have a go tomorrow to see whether i can get to the end of a programme.

Anyway, this is what i did...

I downloaded the plugin posted here and installed it - still getting script errors and nothing worked:
http://code.google.com/p/nibor-xbmc-repo...etail?id=3


Looking at the log it mentioned something about T: and permission denied, found the post below made the change and script error gone and works (so far):

http://code.google.com/p/nibor-xbmc-repo...etail?id=5

Quote:I fixed the issue by modifying the 'default.py' file.
I changed this line:
geturllib.SetCacheDir( xbmc.translatePath(os.path.join( "T:"+os.sep,"addon_data", gPluginName,'cache' )) )

to

geturllib.SetCacheDir( xbmc.translatePath(os.path.join("special://home","addon_data", gPluginName,'cache' )) )
find
eagle-eye Offline
Junior Member
Posts: 11
Joined: Apr 2012
Reputation: 0
Post: #194
I downloaded the wrong zip in Windows.

The alnicol version is here - https://github.com/alnicol/xbmc-4od
find
castalla Offline
Fan
Posts: 549
Joined: Aug 2011
Reputation: 11
Post: #195
Thanks! Working again with that version!
find
Thread Closed