[MAC] Audio stutters during network pause

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #1
I am testing out Eden Beta 1. I have noticed that when I play a ripped DVD, that is stored on a network drive, the audio stutters when there is a network rebuffer pause.

Is there a setting that will automatically mute the audio in this situation? With Dharam 10.1 the audio automatically mutes when there is a network rebuffer pause.

Debug Log

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
(This post was last modified: 2012-02-17 16:33 by winestock.)
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #2
Anyone else encountered this issue? I have opened a ticket (#12453) for this issue.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #3
By the way, I am using AFP for my network connections. As I understand it, in the AFP support in Eden is new. So maybe the bugs have not yet been worked out. I tried using Beta 2 but the audio stutter still happens.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,330
Joined: Jan 2011
Reputation: 256
Location: Arizona, USA
Post: #4
Haven't seen (err, heard) this myself, but there are indeed some AFP bugs that are out of our reach right now (things within the AFP client library that XBMC uses). Not sure if that's the issue or not.
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #5
Thanks for the resonse Ned. I suspect that the issue is in the new Eden code as 10.1 does not have the issue. Hopefully, this will get fixed before the actual release of 11.0.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #6
The ticket I opened has not been replied to as of yet. Can any of the XBMC developers give me some insight on this issue.

I have not been able to switch over from 10.1 to 11 because of the audio stutter issue. Also, if I use XBMC 10.1 on the same Mac running 10.7.3 the audio stutter does not happen when a network rebuffer pause happens.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #7
Cannot reproduce, in fact, I never see a network rebuffer pause under osx even over wifi.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #8
Davilla,

I attached a movie clip, to ticket 12453, showing the audio stuttering issue.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #9
winestock Wrote:I attached a movie clip, to ticket 12453, showing the audio stuttering issue.

And this helps me help you how? You already said it was doing a network rebuffer pause. I said I could not reproduce and have never seen it... not that I did not believe you Smile


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #10
I was just trying to submit as much information as possible. What about the debug log file I submitted was there anything in that file that stood out that might point to the problem I am seeing/hearing?

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #11
The audio stuttering issue seems to be in Beta 3 as well.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #12
I tried playing a ripped DVD movie over my network, using SMB instead of AFP and the audio stuttering issue is still happening.

Debug Log when using SMB.

Has anyone experienced this issue with Beta 1, Beta 2 or Beta 3?

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #13
I have been trying to analyze why the audio stuttering might be happening. I took another debug log. The time where the stuttering occurred was at 20:35:03.

To any of the XBMC developers, is there anything in the above debug log at 20:35:03 that might point to why I am having the stuttering issue? I do see some errors noted for CDVDPlayerAudio.

Another interesting thing to note, is I get a constant audio stuttering when I enter one of the DVD sub-menus. I played the same DVD movie using the Mac OS X DVD player and when I enter the same DVD sub-menu there is no audio stuttering. I captured a screen recording showing this and another debug log file. I attached these to ticket 12453.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
(This post was last modified: 2012-02-16 04:40 by winestock.)
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #14
I have been doing some more testing and investigation. The audio stuttering has nothing to do with network re-buffering. I took a DVD, in this case Rise of the Planet of the Apes, and had XBMC 11 Beta 3 play it. When the main menu was displayed, I entered the setup sub-menu and there was a continual audio stuttering. I even started a fresh copy of XBMC 11 Beta 3 and a new ~/Library/Application Support/XBMC directory.

I played this same DVD with XBMC 10.1 and there was no audio stuttering.

DVDs I have tried as a test:
  • Justice League: Crisis on Two Earths
  • Despicable Me
  • Tangled
  • Rise of the Planet of the Apes

Of the above DVDs, Tangled was the only one that did not exhibit the audio stuttering issue when I went into the setup menu.

Would someone try this out and see if it happens for you.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #15
I just tried Eden RC1 and I am still getting the audio stuttering when playing a DVD movie.

Can some one please try out a DVD physical disc with Eden RC1, such as Rise of the Planet of the Apes, go into the setup menu and see if you get the audio stuttering issue.

I am not sure what to do at this point. I have opened a ticket on this issue but have not heard anything back. This is driving me nuts.

I would like some of the XBMC developers to also try this out on the Mac platform and let me know if they also have the issue.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
Post Reply