The complete SABnzbd, Sickbeard, Couchpotato and Headphones setup guide for newbies

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
saitoh183 Offline
Posting Freak
Posts: 924
Joined: Jul 2011
Reputation: 15
Location: Canada
Post: #31
BLKMGK Wrote:Installed but used the installable binary for Windows vs installing Python. Not seeing the NZB.SU search engine as an option - is this only in the from source build?

Edit: Actually, looking more closely it looks like sickbeard's standalone installers are up to date with their source for Python. Have they pulled support for that indexer? Sad.

I just added it manually like many others. if you check Here you will see that you can just add the indexer

[Image: watched-clearlogo.jpg]

If my replies help you, please click on my reputation [Image: rep_xbmc.JPG] below :) thanks :)
find quote
fender4645 Offline
Junior Member
Posts: 5
Joined: Feb 2012
Reputation: 0
Post: #32
I finally got around to configuring CouchPotato and it's only half working. It's sending the nzb to SAB and that's downloading it and putting it in the directory I specified in the 'movies' category. However CouchPotato is not renaming it and putting it in the "Movie destination" folder.

How exactly is SAB letting CP know the file is done downloading? I know with Sickbeard, the sabtosickbeard script is what sends it back to Sickbeard. But there is no such script for CP. Is CP supposed to monitor that folder?
find quote
Dilligaf Offline
Fan
Posts: 673
Joined: Dec 2008
Reputation: 25
Post: #33
Follow this link to a guide to setting up a reverse proxy for Windows for sab, sick, couchpotato, headphones.
http://forum.xbmc.org/showpost.php?p=102...tcount=551

Mike

If I have been of help, please add to my reputation as a way of saying thanks, it's free.
find quote
saitoh183 Offline
Posting Freak
Posts: 924
Joined: Jul 2011
Reputation: 15
Location: Canada
Post: #34
fender4645 Wrote:I finally got around to configuring CouchPotato and it's only half working. It's sending the nzb to SAB and that's downloading it and putting it in the directory I specified in the 'movies' category. However CouchPotato is not renaming it and putting it in the "Movie destination" folder.

How exactly is SAB letting CP know the file is done downloading? I know with Sickbeard, the sabtosickbeard script is what sends it back to Sickbeard. But there is no such script for CP. Is CP supposed to monitor that folder?

first did you remove any post-processing from SAB so it doesnt process the files after downloading.

Second, in CP under Renaming, you have a check mark under enabled and everything configured?

[Image: watched-clearlogo.jpg]

If my replies help you, please click on my reputation [Image: rep_xbmc.JPG] below :) thanks :)
find quote
MrHaugen Offline
Junior Member
Posts: 46
Joined: Jul 2011
Reputation: 1
Post: #35
fender4645 Wrote:How exactly is SAB letting CP know the file is done downloading? I know with Sickbeard, the sabtosickbeard script is what sends it back to Sickbeard. But there is no such script for CP. Is CP supposed to monitor that folder?

I think there's a couple of possibilities. Output folder from SAB or import folder in Couchpotato. You might have put some strange post processing settings in SAB or you might have the wrong folder set up in Couchpotato. When Couchpotato does not process the downloaded files, it means that it probably can't find any new files in it's monitored folder. Or it might be a password protected compressed file. That CAN happen as well.
(This post was last modified: 2012-02-22 10:29 by MrHaugen.)
find quote
fender4645 Offline
Junior Member
Posts: 5
Joined: Feb 2012
Reputation: 0
Post: #36
Thanks all for the replies. It's probably something misconfigured on my end with one of the folders. Will take a look at it tonight and verify.
find quote
bruceree Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #37
Hello,

I've followed all the steps here for SAB, SickBeard, and CouchPotato. SAB and Sickbeard work well, but I can't get CouchPotato to work. Here are my logs from CP:

Code:
22:00:00 ERROR [         app.lib.cron.eta] Failed to open http://couchpotatoapp.com/api/eta/tt1568346/.
22:00:00 ERROR [     app.lib.provider.rss] Something went wrong in urlopen: <urlopen error timed out>
21:59:55 INFO  [er.yarr.sources.nzbmatrix] Found:

Looks like it finds the nzb fine but fails to connect with SAB? Nothing shows up on nzb.

I know my SAB api key has been entered correctly.

Anyone seen this before?

Thanks
find quote
MrGuvernment Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #38
registered just to say thanks! trying this out..
find quote
sbarrow57 Offline
Junior Member
Posts: 12
Joined: Mar 2012
Reputation: 0
Post: #39
Thank you very much! This guide made setting everything up a relatively painless experience.
find quote
jda2631 Offline
Junior Member
Posts: 13
Joined: Sep 2011
Reputation: 0
Post: #40
Thank you for the guide!

I am getting the nzb's sent to sab and its downloading them great and putting them in the destination folder i specified. But its not sending them back to sickbeard to have it rename, clean up, and move to my series folders.

I have that script set up correctly i think. Can anyone give me a more detailed description of how to get sab to send downloads to sickbeard to be renamed, cleaned up, and transferred to the correct tv show folder? thanks in advance
find quote
reksveks Offline
Member
Posts: 75
Joined: Sep 2010
Reputation: 0
Post: #41
2 ways you can do this,

1) Go to Sickbeard > Config > Post-Processing and using scan and process with the directory correct
2) Go to Sickbeard > Config > Search Setting ; look for SABnzbd Category and insert a name like TV then go into SAB and create a category ( SAB > Config > Categories; create a category with the same name as set in Sickbeard and ensure the script to sabtosickbeard and the directory is correct )
find quote
jda2631 Offline
Junior Member
Posts: 13
Joined: Sep 2011
Reputation: 0
Post: #42
ok. I typed "tv" in the look for sabnxbd category. i went into the sick beard install folder and copied the files "autoprocessTV.cfg' and "sabtosickbeard.exe" then pasted them into a folder in the sab install folder.

in sab i created a category "tv" and pointed the "script" to the sabtosickbeard.exe"

still got nothing, its just leaving the files that sab downloads in the download folder i specified.

did i do everything correctly?
find quote
reksveks Offline
Member
Posts: 75
Joined: Sep 2010
Reputation: 0
Post: #43
If the files are already downloaded then the script won't run on them, try to download another episode and see if it runs the script in SAB.

You can use method 1 to ensure the files (that are already downloaded or missed by the script) are processed by Sickbeard, you shouldn't really use method 1 and 2 but it creates a sort of failsafe.

Otherwise just use manual post processing in Sickbeard for your current downloads.
find quote
jda2631 Offline
Junior Member
Posts: 13
Joined: Sep 2011
Reputation: 0
Post: #44
Ok, i downloaded a few more episodes and they downloaded in the specified download folder then after they get done downloading, I'm guessing its getting run through sickbeard, but all the shows stay in that same folder and the names of each individual tv show episode folder are changed to "UNKNOWN_tv show name S01E01 episode name" but while they are downloading that "UNKOWN_" isnt there.

But after it does that, if i go into sickbeard and do a "manual post process" it works great.

Any idea whats going on? and it will do this for every episode
(This post was last modified: 2012-04-24 03:24 by jda2631.)
find quote
reksveks Offline
Member
Posts: 75
Joined: Sep 2010
Reputation: 0
Post: #45
Thats extremely weird and i am a bit stump, I would get take a piece of the log file when the script is running and ask on the Sickbeard thread or the sickbeard forum
find quote
Post Reply