[RELEASE] Advanced Wake On Lan (WOL) Addon - Wake up a remote computer/server

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ich4711 Offline
Junior Member
Posts: 12
Joined: Sep 2010
Reputation: 0
Post: #31
moin mandark !
first: thanks for that really helpful plugin !

i´m using it on openelec_pvr to wakeup my tvheadend server.
works fine. "wol on startup" and "wol on demand" works stable.

i´m using "suspend to ram" for my xbmc/openelec so i have a feature request:
"wol on resume" would be really nice.

thanks
find quote
mandark Offline
Member
Posts: 87
Joined: Jun 2009
Reputation: 3
Post: #32
(2012-03-28 21:45)ich4711 Wrote:  i´m using it on openelec_pvr to wakeup my tvheadend server.
works fine. "wol on startup" and "wol on demand" works stable.

i´m using "suspend to ram" for my xbmc/openelec so i have a feature request:
"wol on resume" would be really nice.

i'm sorry, but i don't really know how to find out, if the PC has returned from sleep from within a XBMC-script. i'm not sure, if it's even possible.

i'd suggest to acomplish this on the OS-level and not in XBMC. this thread should help you in achieving this.
find quote
ich4711 Offline
Junior Member
Posts: 12
Joined: Sep 2010
Reputation: 0
Post: #33
moin mandark !
thanks for the hint.

a wonder happend after update to the latest openelec_pvr release (march 28) based on final eden.
WOL packet is send to my server on xbmc resume Big Grin

dunnow how Huh , but it works like a charm Laugh

again, thanks for your plugin !
find quote
michelskovbo Offline
Junior Member
Posts: 40
Joined: Nov 2010
Reputation: 0
Location: Denmark
Post: #34
Hi

I'm having som trouble with this program.

When i press AWOL in XBMC, my server is Awake within 15 seconds. But after that, none of my SMB shares are working.
The file "hangs" and after 1 - 3 mins, a box will tell me that the file doesnt exist and want to delete it.
Then the server "jumps" of the network, and i will have to restart my server to get acces.

This ONLY happens when i use WOL, not when i power on my server on the chasis.

Can anyone tell me, what can be wrong?
find quote
rids Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #35
is there any chance of getting this to run on a keypress "h" i have tried key mapping to get it to run script but im just to thick it seems. i just want to be able to run this from xbmc commander as my router wont support WOL and my apple tv is always on
find quote
GuyJustHere Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #36
Would there be a way to send the packet when I exit the screen saver? I don't see why ppl would want to send the packet when XBMC boots, since I am always running XBMC. I really just need to send the packet when i wake up xbmc/ATV2

BTW, this is an amazing add-on. Thank you!
find quote
luca_c Offline
Junior Member
Posts: 13
Joined: Oct 2010
Reputation: 0
Location: Rome - Italy
Post: #37
Hi!
I Need an Help....Blush
How can start wol when I enter a specific section ... for example "movie/video section" from Home without select the operation from favourite menu?TongueTongue
Thanks! Luca
find quote
yunti Offline
Member
Posts: 91
Joined: Dec 2008
Reputation: 0
Post: #38
I use this on the latest version of openelec (eden based) beta 4 and it works well. However although I can get it to wake my server when I power up the openelec box, when the openelec box resumes from sleep it doesn't send a WOL packet to the server. Is there a way to do this?
find quote
yunti Offline
Member
Posts: 91
Joined: Dec 2008
Reputation: 0
Post: #39
(2012-06-13 13:31)yunti Wrote:  I use this on the latest version of openelec (eden based) beta 4 and it works well. However although I can get it to wake my server when I power up the openelec box, when the openelec box resumes from sleep it doesn't send a WOL packet to the server. Is there a way to do this?

Any idea how to do this - this would help a lot?
Thanks.
find quote
wally101 Offline
Member
Posts: 61
Joined: Dec 2011
Reputation: 0
Location: Ireland
Post: #40
I cant seem to get this to work.

I took my MAC address from my unraid server and entered it but any time I start xbmc I get the Error on hostup-check error saying
it cannot find tower:8080.

I have started xbmc normally and got the message about admin rights so I ran xbmc as admin to see if the error would go away, which it did but I still got the hostup-check error


edit: I was adding my server name AND port. Silly

So I hear I can run xbmc off my old commodore 64.

Pretty cool......pretty really cool
(This post was last modified: 2012-07-08 01:04 by wally101.)
find quote
bilbonvidia Offline
Fan
Posts: 458
Joined: Jun 2011
Reputation: 2
Location: Britain
Post: #41
I need some clarification please.

I have a shared mysql library and media files on a separate computer. Can this addon be used to wake the separate computer up before xbmc tries to connect to the shared library?
find quote
bilbonvidia Offline
Fan
Posts: 458
Joined: Jun 2011
Reputation: 2
Location: Britain
Post: #42
(2012-08-14 11:07)bilbonvidia Wrote:  I need some clarification please.

I have a shared mysql library and media files on a separate computer. Can this addon be used to wake the separate computer up before xbmc tries to connect to the shared library?

No.
find quote
sw4y Offline
Member
Posts: 75
Joined: Apr 2011
Reputation: 0
Post: #43
Hey,
I was looking for a way to wake up my homeserver only when xbmc starts and had it going with eventghost.
Then I found your awesome plugin which is everything I need, so thank you for your work!

Is it possible (maybe with parameters) to wake the server up when xbmc starts ("this is possible"), wait until it's awake and then start searching for new files in the libraries?

Would be a great thing!
find quote
Clansman Offline
Junior Member
Posts: 13
Joined: Sep 2011
Reputation: 0
Post: #44
Many thanks for this addon, it works great with my newly built file server.

But as an aside, I found out this morning not only does it wake the server from sleep mode, It also switchs the server on when it's shutdown.

The server wasn't `on' this morning as it wouldn't be needed, but i wanted to check something on XBMC. As it (xbmc) started, it sent the wake-on-lan packet, i got the `waking up the server' message and timer countdown & after 30sec's got the `server is not awake' message (as i expected) then later i went into the room where the server is and found it up and running. So to test this, i switched the server off and sent a wakeup packet from XBMC and watched the server switch on from shutdown.

As the server takes more than 30sec's to boot up, it was still booting up when the wake-on-lan timer ran out, so after about another 30/40seconds i found i could access the media files.

The m/b in the server is an AsusE35M1-I mITX.

Clansman
find quote
sw4y Offline
Member
Posts: 75
Joined: Apr 2011
Reputation: 0
Post: #45
As far as I know that's standard for "Wake-on-Lan" (your m/b has to support this).
find quote
Post Reply