[WINDOWS][PATCH]Bitstream output of HD audio formats

  Thread Rating:
  • 17 Votes - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
jhaze Offline
Junior Member
Posts: 7
Joined: Jul 2012
Reputation: 0
Post: #1471
Hello Group,

I am late arriving to the party.. but fell in love this weekend, with a woman named "Eden!!!"

Anyway, just wanted to make sure before I read all 147 pages of this thread that the most recent versions are in the 1st post of this sticky, which hasn't been updated since april.

I am currently using "xbmc 11.0 pre git: 20120228 - 4bddfbd", based on a guide, but am not sure if this is the same version of 11.0 that is posted on this page. I am most concerned with hd audio (dolby true HD and dts-ma or dts-hd) and do both versions in the 1st page provide native hd audio support?

Thank you very much for your time and responses,

jhaze
find
voip-ninja Offline
Donor
Posts: 1,111
Joined: Jan 2010
Reputation: 23
Post: #1472
yes, this patch will provide bit-stream support of HD audio formats if that is your question.
find
publicENEMY Offline
Fan
Posts: 310
Joined: Nov 2010
Reputation: 0
Post: #1473
which is recommended for truehd and dtsma?
1. DanielaE release
2. DDDamian
3. xbmc official snapshot/testbuild

Thanks.
(This post was last modified: 2012-08-10 04:42 by publicENEMY.)
find
jjd-uk Offline
Team-Kodi Member
Posts: 3,234
Joined: Oct 2011
Reputation: 62
Post: #1474
(2012-08-10 04:41)publicENEMY Wrote:  which is recommended for truehd and dtsma?
1. DanielaE release
2. DDDamian
3. xbmc official snapshot/testbuild

Thanks.
I would suggest DanielaE release on 1st post if you want maximum stability & compatibility, AudioEngine in the nightlies/snapshots is still a work in progress and still appears to have quite a few bugs & annoyances.
find
PatrickBateman Offline
Posting Freak
Posts: 1,676
Joined: Mar 2011
Reputation: 17
Location: Another Earth
Post: #1475
Just out of curiosity, what are the major differences between the 2 versions posted on The First page, I'm using the Eden version and looking for the most recent stable version of this patch.
(This post was last modified: 2012-08-10 13:02 by PatrickBateman.)
find
jjd-uk Offline
Team-Kodi Member
Posts: 3,234
Joined: Oct 2011
Reputation: 62
Post: #1476
(2012-08-10 13:01)PatrickBateman Wrote:  Just out of curiosity, what are the major differences between the 2 versions posted on The First page, I'm using the Eden version and looking for the most recent stable version of this patch.
DanielaE's is the full Final Eden release with the HD Audio whereas DDDamian's is the Release Candidate 2 (RC2) Beta version of Eden with HD Audio.

From what I remember, the reason for this is some people stated they had problems when they moved from DanielaE's RC2 version to the Final Eden release, but since no one who stated they had problems submitted any logs or detailed bug reports it was thought to be down to individuals particular setup's.

However since no one could be 100% what was going on without logs or sample clips of files to see if what if anything changed between RC2 & Final, Damian has kept the RC2 build available so people can rollback to it if they wish.

DanielaE also has the first Frodo (12) alpha on her 1st post with the HD audio patch, this is the newest version but this is mainly for people who want 10bit H.264 file playback, as shortly after Eden was released the ffmeg library in XBMC was bumped to a newer version.
(This post was last modified: 2012-08-10 13:32 by jjd-uk.)
find
Ossot Offline
Junior Member
Posts: 2
Joined: Aug 2012
Reputation: 0
Post: #1477
I created an account just to say thanks and amazing job.

My receiver always showed a dolby digital logo, so I always assumed things were fine. Some movies, though, would cause horrible sound at times -- as if a speaker is blown. I assumed that was the case. After installing this I now have many more DD logos appearing on my receiver, and I've played scenes I know would make my ears bleed in the past, and they sound perfect now.

I switched from Mediabrowser to XBMC last week. This was the icing on the HTPC cake.
find
PatrickBateman Offline
Posting Freak
Posts: 1,676
Joined: Mar 2011
Reputation: 17
Location: Another Earth
Post: #1478
(2012-08-10 13:27)jjd-uk Wrote:  
(2012-08-10 13:01)PatrickBateman Wrote:  Just out of curiosity, what are the major differences between the 2 versions posted on The First page, I'm using the Eden version and looking for the most recent stable version of this patch.
DanielaE's is the full Final Eden release with the HD Audio whereas DDDamian's is the Release Candidate 2 (RC2) Beta version of Eden with HD Audio.

From what I remember, the reason for this is some people stated they had problems when they moved from DanielaE's RC2 version to the Final Eden release, but since no one who stated they had problems submitted any logs or detailed bug reports it was thought to be down to individuals particular setup's.

However since no one could be 100% what was going on without logs or sample clips of files to see if what if anything changed between RC2 & Final, Damian has kept the RC2 build available so people can rollback to it if they wish.

DanielaE also has the first Frodo (12) alpha on her 1st post with the HD audio patch, this is the newest version but this is mainly for people who want 10bit H.264 file playback, as shortly after Eden was released the ffmeg library in XBMC was bumped to a newer version.

Ahh,
Thanks for the info...

So the frodo version on the first page, is basically Eden final with a ffmpeg lib update? Are/were there any other additional changes to that build that would hinder plugins/skins etc from working? Was there any other major changes between these 2 builds of Daniellas on the front page?

I'f the difference between Eden final and the frodo version is just the ffmpeg bump that's fantastic and I'll move onto that version for a short while (until ae is complete) Smile
find
jjd-uk Offline
Team-Kodi Member
Posts: 3,234
Joined: Oct 2011
Reputation: 62
Post: #1479
(2012-08-13 09:14)PatrickBateman Wrote:  Ahh,
Thanks for the info...

So the frodo version on the first page, is basically Eden final with a ffmpeg lib update? Are/were there any other additional changes to that build that would hinder plugins/skins etc from working? Was there any other major changes between these 2 builds of Daniellas on the front page?

I'f the difference between Eden final and the frodo version is just the ffmpeg bump that's fantastic and I'll move onto that version for a short while (until ae is complete) Smile
I believe it was too early in the Frodo cycle for any significant changes, aside from the ffmeg lib bump, I've not used it myself as I'm happy with the patched Eden Final version. You could try it out in portable mode until you're happy it doesn't break anything like skins.
(This post was last modified: 2012-08-13 11:07 by jjd-uk.)
find
PatrickBateman Offline
Posting Freak
Posts: 1,676
Joined: Mar 2011
Reputation: 17
Location: Another Earth
Post: #1480
Cool,

I'll give it a blast Smile
Cheers for the info, much appreciated.
find
HwKok Offline
Junior Member
Posts: 11
Joined: Jul 2012
Reputation: 0
Post: #1481
Hello all,

First of all, thanx DanielA for all your efforts.
I recently build a brand new HTPC, dedicated for XBMC.
So I downloaded Eden v11 + HD audio and installed it. I tested with some Dolby and DTS movies and it worked fine.

But when I'm playing a DTS-HD master movie, it begins to stutter and there is no audio. There also is a warning when starting the movie: Failed to initialize audio device.

Everything is connected via HDMI to my Onkyo amplifier, type HT-R548 (part of the HT-S5405 package). It supports DTS-HD Master.
The specs of my HTPC are:

Motherboard: Asrock A75M
RAM: 2x 2GB Gskill F3-12800
APU: AMD A4-3400
HDD: Western Digital 2TB WD20EARX

Running W7 Ultimate. In the sound settings of W7 I calibrated the output to 5.1 surround.
In XBMC- audio settings I checked everything, since my receiver is capable of every format listed in there (I guess?).
As audio output device I selected WASAPI AMD HDMI output.

Note: when I go to Audio settings in XBMC and change 'receiver supports:' to something other than DTS HD Master Audio, I have no problems and the DTS or Dolby logo on my amplifier is lit. In that case movie plays fine and sound is ok.

Somebody any idea what to change?
find
jjd-uk Offline
Team-Kodi Member
Posts: 3,234
Joined: Oct 2011
Reputation: 62
Post: #1482
You need to check you Windows settings.

This page will show you what you should have http://www.jensign.com/HDMI_Studio1558/index.html

Basically:

1. Check ATI HDMI is default device
2. Speakers set to 5.1
3. Check all formats are listed in the Supported formats tab in the Encoded Formats box, if DTS-HD is not listed here then XBMC will not play DTS-MA audio.
4. Ensure both tick boxes under Exclusive Mode in Advanced tab are checked (I think it's this you've most likely not done)
find
HwKok Offline
Junior Member
Posts: 11
Joined: Jul 2012
Reputation: 0
Post: #1483
Hello jjd/uk, thanks for your advice.
Unfortunately, this didnĀ“t work out.

1. Done (it was already)
2. Done (it was already)
3. DTS-HD is on the list, same as TrueHD.
4. Done (it was already).

So, every movie runs fine, DTS and Dolby are working correcty. Only when starting DTS-HD it flips totally (I think it drops down to 5fps) and sound is gone.

What else could it be? :/
(This post was last modified: 2012-08-23 18:10 by HwKok.)
find
jjd-uk Offline
Team-Kodi Member
Posts: 3,234
Joined: Oct 2011
Reputation: 62
Post: #1484
The only other things I can think of at the moment is to check in Settings -> Video -> Playback to see if you've "Sync playback to display" enabled and if so disable it, and perhaps check in Settings -> System -> Video Output and make sure "Use a fullscreen window rather than true fullscreen" is not enabled.
find
BenchTT Offline
Junior Member
Posts: 4
Joined: Jul 2012
Reputation: 0
Post: #1485
I had the same problem. Mine was because I wasn't using the correct build. Make sure you are using the correct version found here;

https://github.com/DDDamian/xbmc/downloads

I also had to change an HDMI setting on my onkyo receiver, can't remember what it was right now.
find
Thread Closed