[RELEASE] buggalo - automatic exception collector

  Thread Rating:
  • 3 Votes - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fightnight Offline
Senior Member
Posts: 121
Joined: Dec 2012
Reputation: 1
Location: Portugal
Post: #31
Thanks for update.. error:

Code:
13:36:16 T:2956  NOTICE: Thread Background Loader start, auto delete: false
13:36:21 T:2644   ERROR: Traceback (most recent call last):
13:36:21 T:2644   ERROR:   File "C:\Users\**\AppData\Roaming\XBMC\addons\script.module.buggalo\lib\buggalo_gui.py​", line 106, in onClick
13:36:21 T:2644   ERROR:     client.emailData(self.gmailRecipient, self.data)
13:36:21 T:2644   ERROR:   File "C:\Users\**\AppData\Roaming\XBMC\addons\script.module.buggalo\lib\buggalo_client​.py", line 172, in emailData
13:36:21 T:2644   ERROR:     smtp.sendmail(msg['From'], msg['To'], msg.as_string(9))
13:36:21 T:2644   ERROR:   File "C:\Program Files\XBMC\system\python\Lib\smtplib.py", line 712, in sendmail
13:36:21 T:2644   ERROR:     self.rset()
13:36:21 T:2644   ERROR:   File "C:\Program Files\XBMC\system\python\Lib\smtplib.py", line 438, in rset
13:36:21 T:2644   ERROR:     return self.docmd("rset")
13:36:21 T:2644   ERROR:   File "C:\Program Files\XBMC\system\python\Lib\smtplib.py", line 363, in docmd
13:36:21 T:2644   ERROR:     return self.getreply()
13:36:21 T:2644   ERROR:   File "C:\Program Files\XBMC\system\python\Lib\smtplib.py", line 340, in getreply
13:36:21 T:2644   ERROR:     raise SMTPServerDisconnected("Connection unexpectedly closed")
13:36:21 T:2644   ERROR: SMTPServerDisconnected: Connection unexpectedly closed
(This post was last modified: 2014-04-16 15:58 by fightnight.)
find quote
twinther Offline
Fan
Posts: 308
Joined: Sep 2004
Reputation: 10
Location: Denmark
Post: #32
Hi, judging from the stacktrace it looks like your are not able to connect to gmail's server via port 25, the SMTP port.
Perhaps your ISP is blocking this, or perhaps your local firewall or antivirus is blocking it.
There's not much I can do to avoid this unfortunately.

Br.
Tommy
find quote
fightnight Offline
Senior Member
Posts: 121
Joined: Dec 2012
Reputation: 1
Location: Portugal
Post: #33
I'm trying to configure buggalo web and shows this:

[Image: MRzWMBL.png]

and in issues.json.php:

Code:
Warning: Invalid argument supplied for foreach() in /home/u426997694/public_html/buggalo/issues.json.php on line 53
{"sEcho":-1,"iTotalRecords":null,"iTotalDisplayRecords":0,"aaData":[]}

Any idea?
(This post was last modified: 2013-07-08 15:01 by fightnight.)
find quote
twinther Offline
Fan
Posts: 308
Joined: Sep 2004
Reputation: 10
Location: Denmark
Post: #34
Yeah, it probably breaks because you don't have any error reports in the database yet.
Try submitting one and this problem will probably go away.
Br.
Tommy
find quote
fightnight Offline
Senior Member
Posts: 121
Joined: Dec 2012
Reputation: 1
Location: Portugal
Post: #35
Code:
    if (is_array($rows))
    {
        foreach($rows as $row) {
                $issues[] = array(
                    $row['id'],
                    $row['timestamp'],
                    $row['addon_name'],
                    $row['addon_version'],
                    $row['title'],
                    $row['ip'],
                    $row['status']
                );
            }
    }

Changed to this and worked, but I tried to submit on addon but nothing appears on page.

I created an new mysql on server and changed config.php.. Nothing in mysql server.

You have any sugestion for this? sorry.. i'm noob Big Grin

EDIT: Solved! Imported the sql file and everything works ok! Smile

You can update the issues.json.php with this fix. Works good Smile

Please push the 1.1.4 to the official repo. Wink
(This post was last modified: 2013-07-08 19:13 by fightnight.)
find quote
schapplm Offline
Junior Member
Posts: 29
Joined: Apr 2013
Reputation: 0
Post: #36
(2013-07-08 17:35)fightnight Wrote:  Please push the 1.1.4 to the official repo. Wink

I'm sorry I have to be nagging too Wink I didn't manage to configure the web server but email report works for me. It would be nice to have 1.1.3 or 1.1.4 in the official repo, so that I can distribute my addon with buggalo-support, which helped me find a lot of errors btw I would never have found myself Big Grin

My addon: service.watchedlist
My HTPC: XBMC 13.2; Ubuntu 14.04 LTS x64; AMD A6-6400K; MSI FM2-A55M-E33; 4GB Kingston HyperX RAM; Digital Devices Cine CT V6 DVB-C; Streacom FC8B Evo with 120W picoPSU
find quote
Karnagious Offline
Fan
Posts: 592
Joined: Nov 2012
Reputation: 24
Post: #37
(2013-09-09 09:33)schapplm Wrote:  
(2013-07-08 17:35)fightnight Wrote:  Please push the 1.1.4 to the official repo. Wink

I'm sorry I have to be nagging too Wink I didn't manage to configure the web server but email report works for me. It would be nice to have 1.1.3 or 1.1.4 in the official repo, so that I can distribute my addon with buggalo-support, which helped me find a lot of errors btw I would never have found myself Big Grin

+1

Please!
find quote
fightnight Offline
Senior Member
Posts: 121
Joined: Dec 2012
Reputation: 1
Location: Portugal
Post: #38
And for eden too. Works great here but gives script error, because doesn't have the lib.
find quote
twinther Offline
Fan
Posts: 308
Joined: Sep 2004
Reputation: 10
Location: Denmark
Post: #39
Hi guys, I'll get back to this asap. hopefully next week.

I guess you have tested the 1.1.4 version pretty good while you have been testing your own addons?
So the release should pretty much be ready for a push to the repo.

Br.
Tommy
find quote
schapplm Offline
Junior Member
Posts: 29
Joined: Apr 2013
Reputation: 0
Post: #40
(2013-09-11 19:32)twinther Wrote:  I guess you have tested the 1.1.4 version pretty good while you have been testing your own addons?
So the release should pretty much be ready for a push to the repo.
I provided version 1.1.3 with my addon and got buggalo-emails from a lot of users.
But there is still a bug in the buggalo addon. In German translation, the string no. 91000 has not the %s placeholder.
This leads to an error when the error report pops up. I already changed the German translation in transifex, you just have to download them. The other translations seem to have been corrected since I last checked.
strings.xml
Code:
Englisch: <string id="91000">Unfortunately an error occurred in the [B]%s[/B] addon.</string>
Dansk: <string id="91000">Der er desværre opstået en fejl i [B]%s[/B] addon.</string>
Deutsch: <string id="91000">Es ist leider ein Fehler im Addon aufgetreten.</string>
Everything else worked great. If all addons would use this, the development process of xbmc could be a lot faster.

My addon: service.watchedlist
My HTPC: XBMC 13.2; Ubuntu 14.04 LTS x64; AMD A6-6400K; MSI FM2-A55M-E33; 4GB Kingston HyperX RAM; Digital Devices Cine CT V6 DVB-C; Streacom FC8B Evo with 120W picoPSU
find quote
twinther Offline
Fan
Posts: 308
Joined: Sep 2004
Reputation: 10
Location: Denmark
Post: #41
Hi guys,

I have uploaded v1.1.5 to my beta repository at http://tommy.winther.nu/xbmc/
Can you give it a try? The only changes is updated language files as you mentioned.

I guess I'll have to change the version number to be able to update the Eden version as well.
Does any of you need the email support for the Eden version - otherwise I probably won't update it.

Br.
Tommy
find quote
schapplm Offline
Junior Member
Posts: 29
Joined: Apr 2013
Reputation: 0
Post: #42
Just checked it. 1.1.5 works. Thank you for your support. I really gave the webpage a try, but after an hour I gave up. I think my (free) web hoster did not support php classes.

My addon: service.watchedlist
My HTPC: XBMC 13.2; Ubuntu 14.04 LTS x64; AMD A6-6400K; MSI FM2-A55M-E33; 4GB Kingston HyperX RAM; Digital Devices Cine CT V6 DVB-C; Streacom FC8B Evo with 120W picoPSU
find quote
twinther Offline
Fan
Posts: 308
Joined: Sep 2004
Reputation: 10
Location: Denmark
Post: #43
Thanks.

I have just now sent the pull request for inclusion in the addon repository.
Only for frodo / gotham though. Version is 1.1.5.

It'll probably get pulled within a day or two.

Let me know if any of you need it for Eden or have any input for improvements Smile
----

FYI. The new version was pulled earlier today and should be available in the official repo now.
(This post was last modified: 2013-09-20 19:37 by twinther.)
find quote
MisterX Offline
Junior Member
Posts: 11
Joined: Sep 2013
Reputation: 0
Post: #44
I had this error when I browsed to the submit.php page:

Strict Standards: Non-static method mysql_connection::get_instance() should not be called statically in /home/xxx/public_html/buggalo/config.php on line 9

The problem was the following

This code (in config.php):
Code:
    new mysql_connection('database', 'localhost', 'username', 'password');
    $conn = &mysql_connection::get_instance();
    $conn->open();

has to be changed to:

Code:
    $conn = new mysql_connection('database', 'localhost', 'username', 'password');
    $conn->get_instance();
    $conn->open();
(This post was last modified: 2013-10-03 14:41 by MisterX.)
find quote
Post Reply