XBMC Eden beta 2 wont downmix audio

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
hop6919 Offline
Junior Member
Posts: 13
Joined: Feb 2012
Reputation: 0
Post: #1
Hi Everyone,

I'm having trouble downmixing audio to stereo on a 1080p h264 MKV. The audio is encoded as 7.1 FLAC and I'm missing a few of the tracks - at least the center channel and probably more. This renders the film unwatchable. I have tried this on an iMac outputting to stereo speakers connected through the 3.5mm jack and also a Mac Mini 2011 outputting through HDMI to a stereo amplifier.

After endless fiddling with settings with absolutely no difference can I ask if anyone has any suggestions or should I report this as a bug? The same file works fine on OS X Lion in XBMC 10.1 and also on Windows 7 XBMC 11 beta 2. I have also tried using Soundflower but to no avail.

Here is a link to my log: http://www.pastebucket.com/1437

I understand there are audio multichannel issues in OS X but I haven't seen a post specifically about down-sampling audio. Any insight would be great!

Thanks,

Simon
(This post was last modified: 2012-02-07 01:08 by hop6919.)
find quote
dennis69 Offline
Junior Member
Posts: 2
Joined: Oct 2011
Reputation: 0
Post: #2
Same here. No center channel with multichannel FLAC.
find quote
hop6919 Offline
Junior Member
Posts: 13
Joined: Feb 2012
Reputation: 0
Post: #3
A bug report has been created:

http://trac.xbmc.org/ticket/12612
find quote
phi2039 Offline
Team-XBMC Developer
Posts: 260
Joined: Aug 2008
Reputation: 0
Location: Baltimore, MD
Post: #4
Commit
8e89949547ea15b7d19f6b9439768bd7898ce9ee

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: project_thin_badge.gif]
find quote