XBMC 11.0 Eden: Beta3 available now

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
TugboatBill Offline
Posting Freak
Posts: 829
Joined: Oct 2009
Reputation: 7
Post: #91
WNDLL Wrote:Please help Karaoke mp3+cdg still out of sync. Already disappointed. :-(

http://wiki.xbmc.org/index.php?title=HOW...Bug_Report
find
nzcarrick Offline
Junior Member
Posts: 2
Joined: Nov 2011
Reputation: 0
Post: #92
Hi

Just wondering has anyone been able to successfully add a video source from an NFS mount? I can see the mounts in the menu but when I highlight and select them they dont appear as a path, all i get is NFS//192.168.0.10 with no path appended to it.

There is no permission error as the log says - i think it is a bug in XBMC (/etc/exports listed below)

XBMC Debug log

Code:
19:16:30 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:30 T:140038208407456   DEBUG: ExecuteXBMCAction : Translating ActivateWindow(Videos,Files,return)
19:16:30 T:140038208407456   DEBUG: ExecuteXBMCAction : To ActivateWindow(Videos,Files,return)
19:16:30 T:140038208407456   DEBUG: Activating window ID: 10025
19:16:30 T:140038208407456   DEBUG: ------ Window Deinit (Home.xml) ------
19:16:30 T:140038208407456   DEBUG: ------ Window Init (MyVideoNav.xml) ------
19:16:30 T:140038208407456    INFO: Loading skin file: MyVideoNav.xml
19:16:30 T:140038208407456   DEBUG: CGUIMediaWindow::GetDirectory (sources://video/)
19:16:30 T:140038208407456   DEBUG:   ParentPath = [sources://video/]
19:16:30 T:140037937157888   DEBUG: Thread Background Loader start, auto delete: 0
19:16:30 T:140037937157888   DEBUG: Thread Background Loader 140037937157888 terminating
19:16:31 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:31 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:31 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:31 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:31 T:140038208407456    INFO: Loading skin file: DialogMediaSource.xml
19:16:31 T:140038208407456   DEBUG: ------ Window Init (DialogMediaSource.xml) ------
19:16:33 T:140038208407456   DEBUG: SDLKeyboard: scancode: 72, sym: 0113, unicode: 0000, modifier: 1000
19:16:33 T:140038208407456   DEBUG: OnKey: right (f083) pressed, action is Right
19:16:33 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:33 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:33 T:140038208407456    INFO: Loading skin file: FileBrowser.xml
19:16:33 T:140038208407456   DEBUG: ------ Window Init (FileBrowser.xml) ------
19:16:34 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:34 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:34 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:34 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:34 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:34 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:35 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:35 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:35 T:140037945550592   ERROR: Unable to lookup host: ''
19:16:35 T:140037945550592   DEBUG: SECTION:LoadDLL(libnfs.so.0)
19:16:35 T:140037945550592   DEBUG: Loading: libnfs.so.0
19:16:35 T:140038208407456   DEBUG: ------ Window Init (DialogBusy.xml) ------
19:16:38 T:140038208407456   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
19:16:38 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:38 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:40 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:40 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:40 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:40 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:41 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:41 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:41 T:140038119819008   DEBUG: NFS: Context for 192.168.0.10/share/Music not open - get a new context.
19:16:41 T:140038119819008   ERROR: NFS: Failed to mount nfs share: /share/Music (mount/mnt call failed with "RPC error: Mount failed with error MNT3ERR_ACCES(13) Permission denied(13)")
19:16:41 T:140038208407456   ERROR: GetDirectory - Error getting nfs://192.168.0.10/share/Music/
19:16:41 T:140038208407456   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.0.10/share/Music/) failed
19:16:45 T:140038208407456   DEBUG: SDLKeyboard: scancode: 68, sym: 010f, unicode: 000d, modifier: 1000
19:16:45 T:140038208407456   DEBUG: OnKey: enter (f065) pressed, action is Select
19:16:45 T:140038111426304   DEBUG: NFS: Refreshing context for 192.168.0.10/share/Music, old: 45236, new: 49741
19:16:45 T:140038111426304   DEBUG: NFS: Using cached context.
19:16:45 T:140038111426304   ERROR: Failed to open(//) opendir call failed with "Server responded: Program not available"
19:16:45 T:140038208407456   ERROR: GetDirectory - Error getting nfs://192.168.0.10/share/Music/
19:16:45 T:140038208407456   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.0.10/share/Music/) failed
19:16:49 T:140038208407456   DEBUG: SDLKeyboard: scancode: 72, sym: 0113, unicode: 0000, modifier: 1000
19:16:49 T:140038208407456   DEBUG: OnKey: right (f083) pressed, action is Right
19:16:50 T:140038208407456   DEBUG: SDLKeyboard: scancode: 72, sym: 0113, unicode: 0000, modifier: 1000
19:16:50 T:140038208407456   DEBUG: OnKey: right (f083) pressed, action is Right
19:16:50 T:140038208407456   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib-x86_64-linux.so)
19:16:50 T:140038208407456   DEBUG: Unloading: ImageLib-x86_64-linux.so
19:16:51 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:51 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:51 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:51 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down
19:16:52 T:140038208407456   DEBUG: SDLKeyboard: scancode: 74, sym: 0112, unicode: 0000, modifier: 1000
19:16:52 T:140038208407456   DEBUG: OnKey: down (f081) pressed, action is Down



/etc/exports

Code:
cam@zotac:~$ cat /etc/exports
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/share/Video *(subtree_check,rw,async)
/share/Music *(subtree_check,rw,async)
/share/Photos *(subtree_check,rw,async)
/share/scratch *(subtree_check,rw,async)
/share/tftp/Backtrack/5/R1/x64/gnome/ *(rw,sync,no_subtree_check)
/share/tftp/Backtrack/5/R1/x64/kde *(rw,sync,no_subtree_check)
/share/tftp/Backtrack/5/R1/x86/gnome/ *(rw,sync,no_subtree_check)
/share/tftp/Ubuntu/10.10_maverick/desktop/x64/  *(rw,sync,no_subtree_check)
/share/tftp/Ubuntu/11.10_Oneiric/desktop/x64/  *(rw,sync,no_subtree_check)
/share/tftp/Archbang/2011.11/x64/ *(rw,sync,no_subtree_check)
/share/tftp/xbmc/beta3/ *(rw,sync,no_subtree_check)


If someone can help confirm I will raise a bug report

Regards

Carrick
find
krypstocken Offline
Junior Member
Posts: 10
Joined: Jun 2010
Reputation: 0
Post: #93
Hi

How do I toggle between the LXDE desktop and the normal XBMC window?

OK found that I can log out and in out of XBMC homscreen and LXDE.

Can LXDE be booted into automatically so I can truly toggle between them?

I run EDEN Beta 3 installed from Live CD.

Kristoffer
(This post was last modified: 2012-02-18 14:28 by krypstocken.)
find
navarro Offline
Junior Member
Posts: 1
Joined: Jan 2012
Reputation: 0
Post: #94
Is it already available for Apple TV 2?
I can't install it with an 'apt-get install' i'm on beta 1 right now.
find
funkysven_4 Offline
Junior Member
Posts: 20
Joined: May 2011
Reputation: 0
Post: #95
If I want to install Eden Beta 3 without deleting my library and watched statuses, how do I go about doing this?
find
Tight_wad Offline
Fan
Posts: 330
Joined: Oct 2010
Reputation: 4
Post: #96
Using NFS, I can't seem to get VIDEO_TS movies to play in library mode. If I go into file mode it plays fine. If I use SMB everything works just fine. Am I missing something on using NFS?
find
mukati Offline
Junior Member
Posts: 43
Joined: Jan 2012
Reputation: 0
Post: #97
Guys quick question.. If i use IMDB as scrapper, it wont make movie sets? Same was the case with Beta 1 and moving to Beta 3 (skipped beta 2).. IMDB scrapper and it wont make movie sets..

One interesting thing I had noticed in Beta 1 atleast, if I pick every movie that should belong to a set and refresh the movie information, it would then add them in a set.

anyone else facing similar behavior?
find
Mysqo Offline
Junior Member
Posts: 31
Joined: Feb 2012
Reputation: 0
Post: #98
Why doesnt the movies i delete dissapear in movie sets?

HTPC: Asus E-450 | 4Gb Ram | 1TB HD | Ubuntu 14.04
find
pumkinut Offline
Posting Freak
Posts: 968
Joined: May 2006
Reputation: 9
Post: #99
Mysqo Wrote:Why doesnt the movies i delete dissapear in movie sets?
Are you updating your library after deleting the movies?
find
Mysqo Offline
Junior Member
Posts: 31
Joined: Feb 2012
Reputation: 0
Post: #100
pumkinut Wrote:Are you updating your library after deleting the movies?

Yes i do, maybe a setting im missing or something, when i try to start a deleted movie i get the question if i want to remove it from the db.

HTPC: Asus E-450 | 4Gb Ram | 1TB HD | Ubuntu 14.04
find
TheCasa Offline
Member
Posts: 67
Joined: Feb 2011
Reputation: 0
Post: #101
In Windows, when XBMC should go to screensaver after watching a strm, from say, hulu or amazon, it continually crashes. Every time it gives the same error:

http://pastebin.com/d7M142yD

I'll post this in the video addon place also in case it's an addon issue.
find
Diggs Offline
Senior Member
Posts: 154
Joined: Jan 2012
Reputation: 1
Post: #102
Mysqo Wrote:Why doesnt the movies i delete dissapear in movie sets?

The option you need is Clean Library, not update. I believe update simply adds any new content, where clean will remove any entries where it couldn't locate the path.

Diggs
find
sdedgar Offline
Junior Member
Posts: 1
Joined: Feb 2012
Reputation: 0
Post: #103
I can confirm the issue with NFS sources not working, XBMC Live mounting off an Ubuntu 11.04 NFS server. I can successfully mount the NFS exports just fine from the command line on the XBMC box, but the NFS sources in XBMC just show the NFS export name, and cannot see anything under it.
find
Tight_wad Offline
Fan
Posts: 330
Joined: Oct 2010
Reputation: 4
Post: #104
sdedgar Wrote:I can confirm the issue with NFS sources not working, XBMC Live mounting off an Ubuntu 11.04 NFS server. I can successfully mount the NFS exports just fine from the command line on the XBMC box, but the NFS sources in XBMC just show the NFS export name, and cannot see anything under it.

Had this issue also. Here is what I did for my access rights on my NFS system.

I had to change my access rights for NFS on my server. Normally *(rw) should give read and write access, but it didn't. I had to use *(rw,insecure) and then I was able to see everything under my NFS source.

My issue now is that I can't play VIDEO_TS format movies in library mode. It will play anything else. I can play them in file mode, but if I try to do it in library, log says that XBMC can't find the iso file, when it should be looking for an ifo.

Back to dharma for me till this works!
find
kartunes Offline
Junior Member
Posts: 1
Joined: Feb 2012
Reputation: 0
Post: #105
Loving the new betas...

but if I minimize it when playing music (from NAS) with milkdrop vis and try to bring it up again, I get a blank screen, then it finishes the song and stops responding.

Win 7 x64

Can anyone confirm?

Hmm...seems to be a milkdrop issue now that I've played around a bit. No problems when no vis is selected.
(This post was last modified: 2012-02-22 07:01 by kartunes.)
find
Thread Closed