[linux] Error recording with TVHeadend

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bibi Offline
Senior Member
Posts: 202
Joined: Sep 2009
Reputation: 0
Post: #1
Hi,

I just set my server with Tvheadend 2.12. I can display tv on my openelec-pvr box, set a record from the web interface of Tvheadend, but can't record from xbmc... . In the log, i get :

[CODE13:04:27 T:3018267344 DEBUG: ExecuteXBMCAction : Translating PlayerControl(Record)
13:04:27 T:3018267344 DEBUG: ExecuteXBMCAction : To PlayerControl(Record)
13:04:27 T:2874645360 DEBUG: AddOnLog: Tvheadend HTSP Client: AddTimer - channelUid=27 title=France 3 epgid=-1
13:04:27 T:2874645360 DEBUG: AddOnLog: Tvheadend HTSP Client: GetBackendTime - tvheadend reported time=1328875467, timezone=-60, correction=-1298902400
13:04:27 T:2874645360 DEBUG: AddOnLog: Tvheadend HTSP Client: AddTimer - Error adding timer: 'Event does not exist'
13:04:27 T:2874645360 ERROR: PVRClient - AddTimer - addon 'HTS Tvheadend:192.168.0.11:9982' returns bad error (-3) from AddTimer()
][/CODE]

Any idea ?

Thanks,

Bibi
find quote
Begall Offline
Senior Member
Posts: 172
Joined: Dec 2011
Reputation: 6
Post: #2
You need to install a newer version of TVHeadend, the official 2.12 build does not support recording from within XBMC. You can either compile a version directly from the TVHE repo or use one of the .99~pulse4 builds here:

https://launchpad.net/~pulse-eight/+archive/pulse
find quote
bibi Offline
Senior Member
Posts: 202
Joined: Sep 2009
Reputation: 0
Post: #3
Thnak you, it did the trick ^^.
find quote