[LINUX] Audio Problems with Eden Beta 3 and Ubuntu 11.10

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nsviper Offline
Senior Member
Posts: 287
Joined: Feb 2011
Reputation: 3
Post: #31
I actually found that enabled AC3 and DTS on the audio screen AND THEN disabling them again worked for me.

HDMI sound thru my TV now working.

2xPi 512mb[XBian][Amber Skin]
QNAP TS410 NAS - 4x2TB Raided with NFS Support & Central MySQL DB
Samsung 46" ES7000 Smart TV & HT-E5550 3D BD Sound System
Solwise 200Mb Powerline adapters

Blog coming soon : XBian/Hyperion/LED Ambient Lights
find quote
Slurp Offline
Junior Member
Posts: 21
Joined: Sep 2009
Reputation: 0
Post: #32
NVsniper, when you disable it, it will no passthrough the sound but encode it on your machine.

Found a soulution that worked for me:

In your /etc/pulse/default.pa file

you got a line like this #load-module module-alsa-source device=hw:0,1

remove the # and change the device to your aplay -l device.

Other issue is that you are not a member of the audio group. Add your current usert tot that group and it should all work.
find quote
gaco Offline
Junior Member
Posts: 6
Joined: Feb 2012
Reputation: 0
Post: #33
thank you slurp for this attempt, but unfortunately all this sink-source thing does it is preventing pulseaudio from starting at least on my rig with ubuntu 11.10

all other apps and aplay, play perfectly to any alsa device only eden has problem, all the time it says it cannot initialize audio.

Of course killing pulseaudio makes it work but it is not solution Smile.

The strange thing is, usually in such situations pasuspender worked for other applications now even that cannot help. you have to kill pulseaudio or use pulseaudio output in xbmc which is kinda flaky :/
find quote
haed Offline
Junior Member
Posts: 2
Joined: Jan 2010
Reputation: 0
Post: #34
I'm not sure that my issue is the same others are having ... but anyway.
For me it looks like something has changed between 290.10 and 295.20 NVidia drivers.
With 290.10 I can have sound (LPCM) over HDMI both in menu/navigation and in videos and everything works flawlessly.
With 295.20 I can choose:
- if I configure default device in /etc/asound.conf - there is sound in menus but any attempt to play videos ends up with
Code:
23:10:32 T:2766629696   ERROR: Initialize - failed to open custom device plug:'hdmi:0,3' (error:Device or resource busy), retry with default hdmi:0,3
23:10:32 T:2766629696   ERROR: Initialize - pcm_open_lconf, alsa error: -16 - Device or resource busy
23:10:32 T:2766629696   ERROR: Unable to open audio mixer
- if I remove /etc/asound.conf sound in menus is gone (as expected) but it works in videos

So it looks like, in 295.20 sound device is not freed while switching from menus to video player ...
find quote
earache Offline
Junior Member
Posts: 14
Joined: Nov 2010
Reputation: 0
Location: South Australia
Post: #35
ran into similar problems as in this thread a little while back trying to get HDMI audio working. what worked for me was setting both outputs to custom hdmi:1

my aplay -L output includes:
Code:
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output

my aplay -l output:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887 Digital [ALC887 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,082
Joined: Jul 2010
Reputation: 62
Location: Munich
Post: #36
Quote:So it looks like, in 295.20 sound device is not freed while switching from menus to video player

That's actually a problem of XBMC. It does not disable menu sound in time. Until this is fixed you can disable navigation sounds.
find quote
sfinx Offline
Junior Member
Posts: 10
Joined: Oct 2010
Reputation: 0
Location: The Netherlands
Post: #37
FernetMenta Wrote:That's actually a problem of XBMC. It does not disable menu sound in time. Until this is fixed you can disable navigation sounds.
Thanks, that fixed my no sound issue while playing movies in Eden RC2.
find quote
Knabbel Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #38
Just solved my audio problems with my Zotac ID41

I'm running xbmcbuntu Eden beta3 and have a HT receiver connected via the optical output.

This did the trick for me:

[Image: xbmc-ubuntu-zotac-id41-optical-sml.png]
find quote
luger Offline
Member
Posts: 94
Joined: Apr 2010
Reputation: 0
Post: #39
HDMI sound had previously been working fine for a while on my Revo using XBMCbuntu. We were watching a movie and I paused it, downloaded XBMC Subtitles so I could add subtitles to the movie, restarted the computer and now I cannot get sound to work on anything I play. Any ideas on possible fixes for this? Not even sure where to start.
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,082
Joined: Jul 2010
Reputation: 62
Location: Munich
Post: #40
Knabbel Wrote:Just solved my audio problems with my Zotac ID41

I'm running xbmcbuntu Eden beta3 and have a HT receiver connected via the optical output.

This did the trick for me:

[Image: xbmc-ubuntu-zotac-id41-optical-sml.png]

The setting for passthrough is wrong. plughw is not an iec device and won't accept AES parameters. Try hdmi:Intel
find quote
Matthias.He Offline
Junior Member
Posts: 4
Joined: Oct 2011
Reputation: 0
Post: #41
FernetMenta Wrote:The setting for passthrough is wrong. plughw is not an iec device and won't accept AES parameters. Try hdmi:Intel

But it works at my zotac too

thank you!!!
find quote
afroallen Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #42
I came across this thread while researching the same problem that everyone else here seems to have. This was the error I was seeing in my xbmc.log file:

Code:
21:35:11 T:2829056880  NOTICE: Creating audio device with codec id: 86019, channels: 2, sample rate: 48000, pass-through
21:35:11 T:2829056880   ERROR: Initialize - failed to open custom device iec958:CARD=PCH,DEV=0,AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2 (error:No such file or directory), retry with default iec958:CARD=PCH,DEV=0
21:35:11 T:2829056880   ERROR: Initialize - pcm_open_lconf, alsa error: -2 - No such file or directory

I had an XBMC Live distro (Dharma) running on my HTPC and my audio goes through spdif (my hdmi cable goes directly to my TV since my receiver doesn't have an HDMI input).

I recently upgraded all the way to 11.10 and XBMC Eden RC2. Everything was working fine and while tweaking a few things here and there, after a reboot my audio stopped working.

I tried everything in this thread but without any luck.

It ended up being caused by a change I made to lightdm.conf - the upgrade from Dharma to Eden didn't seem to update this config file, so I followed advice in another thread in order to remove the text on the screen during boot up (I did this before I had any audio problems):

Code:
[SeatDefaults]
autologin-user=xbmc
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter

My theory is that using this lightdm config caused my system to start using Pulse Audio whereas it wasn't before. Anyway, I commented out the lines in the config file and rebooted and I got my sound back.

I still plan to get to the bottom of the root cause but for now I can watch my basketball..
find quote
dzan Offline
Junior Member
Posts: 39
Joined: Jul 2010
Reputation: 0
Post: #43
Hi,

Someone here with a Asrock Ion 125D? ( it's an ion2 chipset too ) If so, what settings worked for you? I tried everything in this thread, no luck! When I do aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav I do have sound!

My aplay -l
Quote:**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

My aplay -L
Quote:xbmc@xbmc-living:~$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default
both
multi
hdmi_formatted
hdmi_complete
front:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
HDA Intel, ALC892 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
Direct sample mixing device
dmix:CARD=Intel,DEV=1
HDA Intel, ALC892 Digital
Direct sample mixing device
dsnoop:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
Direct sample snooping device
dsnoop:CARD=Intel,DEV=1
HDA Intel, ALC892 Digital
Direct sample snooping device
hw:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
Direct hardware device without any conversions
hw:CARD=Intel,DEV=1
HDA Intel, ALC892 Digital
Direct hardware device without any conversions
plughw:CARD=Intel,DEV=0
HDA Intel, ALC892 Analog
Hardware device with all software conversions
plughw:CARD=Intel,DEV=1
HDA Intel, ALC892 Digital
Hardware device with all software conversions
hdmi:CARD=NVidia,DEV=0
HDA NVidia, HDMI 0
HDMI Audio Output
dmix:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample snooping device
hw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Hardware device with all software conversions

Strange thing is, it all works fine every time while running live! ( Xbmcbuntu ) or the first boot after install.

Greets


UPDATE:

I noticed setting both audio and passthrough to pluwhw: 1,3 gives me audio while playback and when set to "Analog". Set to HDMI it's some terrible noise and menu sounds aren't their either way.
(This post was last modified: 2012-03-19 13:14 by dzan.)
find quote
EvilMordor Offline
Junior Member
Posts: 47
Joined: Mar 2012
Reputation: 1
Post: #44
I have a ga-z68xp-ud3p what should i use? tried a few but dint worked :-(
find quote
crosslink Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #45
Just installed XBMCBuntu on my Zotac GeForce 9300-ITX board and after struggling with the hdmi audio for an hour I thought I'd post my solution here. The fix was adapted from what I found here actually:

http://www.zotacusa.com/forum/topic/5380...den-audio/

My output from aplay -l was:

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

So based on the configuration from the link above I used the following:

Custom audio device: plughw:0,3
Custom passthrough device: plughw:0,1

All is well now. Thanks to all who contributed!
find quote