Intel HD Graphics 3000, 24p issues

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
alex3305 Offline
Junior Member
Posts: 8
Joined: Apr 2011
Reputation: 0
Question  Intel HD Graphics 3000, 24p issues
Post: #1
Hi all,

I've been using XBMC for a while now and it's really my favorite player. I've used it with a Nvidia ION system (Asrock 330 pro) but I recently upgraded to a more powerful system.

Specs:
  • ASUS P8H67-M Pro (mATX) motherboard
  • Intel Core i3-2105 processor with integrated Intel HD graphics 3000
  • Sharp LE700-series 40" inch tv (Sharp LC-40LE700E)
  • Analogue 5.1 Logitech audio set
  • Samsung SLC SSD as boot disk
  • 5x Western Digital Green 2TB
  • Windows 7 Professional (64-bit)

Everything is working quite well, especially my 5.1 speakerset which didn't work well in the past. Also my whole system feels really faster and I'm quite pleased with it overall.

However I have problems with playing 24Hz and 23.975Hz material on my new system. Whenever I enable "Adjust display refresh rate to match video" my tv responds with a message that 24Hz is enabled on 24p material, but the video is really choppy.

I had this problem in the past with my ION system but the problem was solved when I used a newer build of XBMC (pre-eden). But now I have the same problem with XBMC pre-eden beta 3.

Is this a known issue on Intel graphics or is because of my tv? I have enabled and disabled things like "Movie mode" and "100Hz" and all 'movie enhancing' functions, but to no avail.

I would really appriciate it if someone could help me with this to create my perfect HTPC/NAS combination.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,236
Joined: Nov 2008
Reputation: 118
Location: Chester, UK
Post: #2
Intel GPUs are problematic. Try turning off the hardware acceleration.

JR
find quote
alex3305 Offline
Junior Member
Posts: 8
Joined: Apr 2011
Reputation: 0
Post: #3
Thanks for your reply. I already read the XBMC forums from top to bottom and indeed came to the conclusion that Intel integrated gpu's have some issues.

However I already tried turning off DXVA(2) and I fiddled with different render methods but it didn't solve the problem unfortunately.
find quote
SvenB Offline
Junior Member
Posts: 4
Joined: Feb 2012
Reputation: 0
Post: #4
I have the same problem with an Intel gpu but have it only with high bitrate movies. I think I am going to buy an ATi or Nvidia videocard.
(This post was last modified: 2012-02-13 17:59 by SvenB.)
find quote
charlievoviii Offline
Member
Posts: 70
Joined: Mar 2011
Reputation: 0
Post: #5
what's your video card Intel control panel video HZ set as ? 23hx or 24hz?
find quote
alex3305 Offline
Junior Member
Posts: 8
Joined: Apr 2011
Reputation: 0
Post: #6
It was set on 24Hz, but anyway today I bought a new card, an simple AMD Radeon HD 5450 to solve the issue. Unfortunately it didn't fix anything. The judder is still there. When I set the Radeon to 24Hz even my mouse cursor judders. I also disabled UAC but it didn't make a difference.

I just can't get it to work smoothly, any suggestions? Sad
find quote
cyradix Offline
Junior Member
Posts: 33
Joined: Nov 2009
Reputation: 0
Post: #7
Need to set it to 23hz as in Windows 23hz is actually the correct 23.976hz...
find quote
alex3305 Offline
Junior Member
Posts: 8
Joined: Apr 2011
Reputation: 0
Post: #8
With some help on the Gathering of Tweakers (Dutch IT forum), I found the solution.

Turn off "Usa a fullscreen window rather than true fullscreen" and my lovely 1080p24 playback was back Smile. Thank you all for replying.
find quote
jegjeg Offline
Junior Member
Posts: 7
Joined: Nov 2011
Reputation: 0
Post: #9
Thanks!! Big GrinBig Grin This made me really glad, simple solution Wink
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #10
Yes, a fullscreen window really makes a performance hit. It seems to fight the desktop refresh rate. Always recommend true fullscreen

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
bluray Offline
Posting Freak
Posts: 8,316
Joined: May 2011
Reputation: 145
Post: #11
You can turn off UAC "Disable User Account Control (UAC) in Windows 7". Here is a good thread for this issue- Let's set this straight - No one can do 24p consistently well.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
(This post was last modified: 2012-05-11 22:03 by bluray.)
find quote