Newbie: issues with jumpy playback / dropping frames

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
AmitUK1978 Offline
Junior Member
Posts: 40
Joined: Oct 2011
Reputation: 0
Post: #1
Hi guys

I am still a newbie when it comes to XBMC.

I am having issues with HD content playback appearing to drop frames?

I have tried searching, but I dont know the tech term for my issue so its hard to make heads or tales of whats going on.

When playing video, it will appear to jump forward a few frames? There is no picture corruption, but for example if the camera is panning across a scene, there will be a small skip as it pans across, not a smooth flow.

This seems to happen on most of my downloaded HD content

My setup is as below. As far as I can tell, more than sufficient.

350W PSU, Be Quiet BN134
Asus P8H61-M PRO
Intel Core i3 2120 CPU
Scythe Shuriken BIG 120mm CPU cooler
Sony AD-7690H Slot DVD±R
4GB (2x2GB) Corsair DDR3 XMS3 Ram
64GB Crucial RealSSD M4, 2.5" SSD

Software wise, its windows 7 and xbmc 10

no codec pacs or any other software. Its a pretty virgin system.

Is there a way to diagnose the problem?
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,239
Joined: Nov 2008
Reputation: 118
Location: Chester, UK
Post: #2
System settings, System, Video output and check that "Use a fullscreen window rather than true fullscreen" is disabled.

JR
find quote
AmitUK1978 Offline
Junior Member
Posts: 40
Joined: Oct 2011
Reputation: 0
Post: #3
You are a genius!

Thank you that sorted it.

Are there any other tweaks I should do? Like enable hardware acceleration?
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,239
Joined: Nov 2008
Reputation: 118
Location: Chester, UK
Post: #4
Try enabling hardware acceleration and see how well it works. In most cases it will work very well, but with a few GPUs (principally Intel) you may see artefacts on the display. If that happens just turn acceleration off again.

JR
find quote
siksik6 Offline
Junior Member
Posts: 3
Joined: Jul 2011
Reputation: 0
Post: #5
I have a similar problem with my nettop machine running an NVDIA Nforce chipset.

Plex plays anything I throw at it, even 1080p content (all MKVs) but XBMC keeps dropping frames, only a couple every minute or so, but enough to be visible (and irritating) when watching the film.

I did try Xbmc live to see if it was a Windows "thing" and it did improve, but still dropped some frames.

I tried the above, but playback became terribly poor. Any other tips please?

Many thanks
Mark
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,239
Joined: Nov 2008
Reputation: 118
Location: Chester, UK
Post: #6
When you say "I tried the above, but playback became terribly poor" what do you mean? Do you mean enabling hardware acceleration made the playback poor, and if so in what way?

We need to see a debug log. Enable debug logging from System settings, System, Debugging, and restart XBMC then wait a minute or two for all the startup tasks to finish. Play some suitable test film until you get a couple of skips, then stop the film and close XBMC.

Open the debug log by pressing Windows-R and in the Run dialog type:

"%appdata%\xbmc\xbmc.log"

(including the quotes). Click OK and the log should open in Notepad. Copy and paste the log into http://pastebin.com/ and post the link it gives you here.

JR
find quote
siksik6 Offline
Junior Member
Posts: 3
Joined: Jul 2011
Reputation: 0
Post: #7
First of all, apologies for the delay in replying.

I tried selecting "Use a fullscreen window rather than true fullscreen" which made playback very jerky indeed. Without it checked, it's "smooth" but still drops frames, causing a perceivable stutter.

Here's the log output...

http://pastebin.com/download.php?i=xetu50nT

thanks
M
find quote
AmitUK1978 Offline
Junior Member
Posts: 40
Joined: Oct 2011
Reputation: 0
Post: #8
Sorry to bring this thread back from the dead, but my machine has started doing the jumpy playback thing.

I haven't changed any settings, and the full screen window thing is still unchecked.

How do I go about getting to the bottom of the issue?

It's like some one is pressing pause really fast every couple of seconds.
find quote