Live TV and Interlacing

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Dojrude Offline
Junior Member
Posts: 20
Joined: Jan 2011
Reputation: 0
Post: #1
When using 4therecord I have to enable de-interlacing on the video settings to get a decent picture when watching TV. The problem I have is that this setting remains when watching any of my other media which isn't interlaced, which then results in stutter until it's turned off.

Is it possible to have different video settings for live tv and movies or is there a setting which should resolve this problem? I tried the auto setting with de-interlacing set to on, but it seems that if interlacing is on it always applies one of the de-interlacing profiles to what ever content is being played.

Thanks.
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,681
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #2
Video settings are stored with a channel or file if the settings differ from the defaults. When you change de-interlacing while playing a channel this setting is stored to the db when the channel is closed. When a new channel is opened and it has video settings stored to it those are taken.

When de-interlacing mode is set to auto it would only engage de-interlacing if it detects the interlace flag for a frame.
find quote
ant_thomas Offline
Fan
Posts: 360
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #3
To continue from FernetMenta...

XBMC now has deinterlacing settings that lets you put it on Auto so it detects when deinterlacing is required, and then you can select the type you require. I personally have it set to Auto and Bob.

It didn't used to be like this, it used to be a case of selecting Auto or the type of deinterlacing. So if you wanted all your TV channels using a certain type it would end up doing films too.

The new method is much better.
find quote
Dojrude Offline
Junior Member
Posts: 20
Joined: Jan 2011
Reputation: 0
Post: #4
Not quite sure how I missed the auto setting, but I've now set that and all media and TV seems to be working perfectly.

Many thanks for your help.
find quote
Brent212 Offline
Member
Posts: 81
Joined: Oct 2009
Reputation: 0
Post: #5
(2012-02-17 11:33)ant_thomas Wrote:  XBMC now has deinterlacing settings that lets you put it on Auto so it detects when deinterlacing is required, and then you can select the type you require. I personally have it set to Auto and Bob.

How do you set the type to "Bob"? I'm missing that option. I have "auto select", "deinterlace", and something like "software" (can't remember exactly what it is and I'm not home right now).
find quote
ant_thomas Offline
Fan
Posts: 360
Joined: May 2008
Reputation: 0
Location: Manchester, UK
Post: #6
Not sure but it could just be a deinterlacing method only available with VDPAU (nvidia) systems on Linux.

Under Deinterlace Method I have:

Auto (ION Optimized)
Auto Select
Temporal/Spatial
Temporal
Bob
Temporal/Spatial (Half)
Temporal (Half)
Inverse Telecine
find quote
Brent212 Offline
Member
Posts: 81
Joined: Oct 2009
Reputation: 0
Post: #7
I had to change the rendering method under system->video->playback from "auto" to "dxva". Now I have "dxva bob" and "dxva best", which works great.
find quote
perskym Offline
Junior Member
Posts: 10
Joined: Dec 2011
Reputation: 0
Post: #8
I have thoroughly read all the posts, but didn't find in XBMC any option mentioned here - no "deinterlacing", neither "rendering". Any help would be appreciated!
find quote
ivonovak Offline
Junior Member
Posts: 19
Joined: Jan 2010
Reputation: 0
Post: #9
For the first time, many thanks to opdenkamp and other developers for very good work with implementation of TV.

90% tv broadcasting over SAT o terrestrial is interlaced
90% "home(ripped) video" is non interlaced

When I set default deintelace method "Temporal" for video , TV picture is in most cases perfect, but
some HD or DVD rip (non interlaced material) is not goog (tearing picture is upper part ). I have to set deinterlace to OFF ad then picture is good

With deinterlace set to auto, most TV channels is still interlaced, auto mode cannot switch deinterlace to ON

It would be better if deffault video setting is different for TV and FILMS and individual setting for channel or video file is changed manually ....


Linux, OpenSuse12.1 32bit, VDPAU, NVIDIA ION - ASUS AT5IoNT
find quote
perskym Offline
Junior Member
Posts: 10
Joined: Dec 2011
Reputation: 0
Post: #10
(2012-04-25 07:00)perskym Wrote:  I have thoroughly read all the posts, but didn't find in XBMC any option mentioned here - no "deinterlacing", neither "rendering". Any help would be appreciated!

I've found the placement where de-interlacing could be altered - under the "OSD" menu ("M" from keyboard).
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,681
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #11
(2012-04-25 09:02)ivonovak Wrote:  For the first time, many thanks to opdenkamp and other developers for very good work with implementation of TV.

90% tv broadcasting over SAT o terrestrial is interlaced
90% "home(ripped) video" is non interlaced

When I set default deintelace method "Temporal" for video , TV picture is in most cases perfect, but
some HD or DVD rip (non interlaced material) is not goog (tearing picture is upper part ). I have to set deinterlace to OFF ad then picture is good

With deinterlace set to auto, most TV channels is still interlaced, auto mode cannot switch deinterlace to ON

It would be better if deffault video setting is different for TV and FILMS and individual setting for channel or video file is changed manually ....


Linux, OpenSuse12.1 32bit, VDPAU, NVIDIA ION - ASUS AT5IoNT

You should be more precise on deinterlace mode and method. Setting deinterlace mode to AUTO should work. I have seen some TV channels where the interlace flag toggled but no yet any progressive content which was detected as interlaced.
find quote