Australian ratings

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
earache Offline
Junior Member
Posts: 14
Joined: Nov 2010
Reputation: 0
Location: South Australia
Lightbulb  Australian ratings
Post: #1
firstly, nice skin ronie!

Apols if this has been covered, I did a quick search and couldn't find anything.
Today I created some Australian ratings icons based on what is already included (linked below) and edited what I think are the appropriate parts in 720p/Includes_Variables.xml to use them. (see code below)
note: I did this for my own setup and my graphics skills are limited Smile

Code:
<value condition="StringCompare(ListItem.Mpaa,Australia:G">flags/movies/rating/au_ratedg.png</value>
<value condition="StringCompare(ListItem.Mpaa,Australia:PG">flags/movies/rating/au_ratedpg.png</value>
<value condition="StringCompare(ListItem.Mpaa,Australia:M">flags/movies/rating/au_ratedm.png</value>
<value condition="substring(ListItem.Mpaa,Australia:MA">flags/movies/rating/au_ratedma.png</value>
<value condition="StringCompare(ListItem.Mpaa,Australia:R">flags/movies/rating/au_ratedr.png</value>
<value condition="StringCompare(ListItem.Mpaa,Australia:X">flags/movies/rating/au_ratedx.png</value>

I'm not completely clear on the accepted format for non mpaa ratings in xbmc, but it seems to me people are using the country format scraped from IMDB, hence I have done the same. The ratings I have come across and made icons for are:
Australia:G
AustraliaTongueG
Australia:M
Australia:MA
Australia:MA15+
(alternate of above)
Australia:R
Australia:X


In addition, if anyone is interested I will post the simple shell script I used to update the mpaa ratings in the xbmc db with the Australian ones (it relies on the db already knowing the IMDB ID for the title)

icons zip download (4shared link)
find quote
ronie Offline
Team-XBMC Member
Posts: 9,097
Joined: Jan 2009
Reputation: 157
Post: #2
looks good to me, i've added it to Transparency!

thanx!

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
earache Offline
Junior Member
Posts: 14
Joined: Nov 2010
Reputation: 0
Location: South Australia
Post: #3
thanks ronie.

I just pulled the latest svn and it looks like the Australian ratings sections in 720p/Includes_Variables.xml are missing the flags/movies/rating/ prefix to the icons.

Also, some records in IMDB have the MA rating as Australia:MA and some as Australia:MA15+ Is it possible to have both included ?
find quote
ronie Offline
Team-XBMC Member
Posts: 9,097
Joined: Jan 2009
Reputation: 157
Post: #4
cheers for looking into it :-)
i've fixed it right away.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
earache Offline
Junior Member
Posts: 14
Joined: Nov 2010
Reputation: 0
Location: South Australia
Post: #5
quick work! thanks, I've been wanting this for a while now Smile

One remaining issue, there seems to be a problem matching Australia:MA15+
When I was testing this myself and came across this I assumed it was due to the + needing to be escaped for StringCompare (or something like that) which is why I used the substring match instead.
find quote
ronie Offline
Team-XBMC Member
Posts: 9,097
Joined: Jan 2009
Reputation: 157
Post: #6
ok, changed it to that one as well :-)

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
urbanhunter Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #7
Ok I'm loving the skin but found a small bug and have tried to fix this myself without success. When playing a movie or TV show the rating is always NR, the ratings show up correctly in the normal list and info views but not while playing. I copied the Australian ratings from the variable includesmediaflagsvideorating to the variable includesmediaflagsvideofullscreenrating but it did nothing. I don't know if i have the right variable so any help would be appreciated.
[Image: screenshot000s.png] [Image: screenshot001mx.png]
find quote
ronie Offline
Team-XBMC Member
Posts: 9,097
Joined: Jan 2009
Reputation: 157
Post: #8
cheers!

looks like i forgot to add them to the video osd.
will fix that right away.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote