XBMCbuntu boots too fast.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
joolz Offline
Junior Member
Posts: 33
Joined: Oct 2008
Reputation: 0
Post: #1
Hi,
I boot xbmcbuntu from an Intel 520 SSD drive. I mount my movies using nfs from a NAS.

The problem is, about half the time i boot up the library is not re-scaned. I think its beacuse my network and/or nfs mounts is not ready yet. If i do a manual "scan for new content" it works fine.

Question, is there any way to somehow delay the start of xbmc or delay the scan?
find quote
Wozza_au Offline
Senior Member
Posts: 195
Joined: Jan 2011
Reputation: 1
Location: South Australia
Post: #2
joolz Wrote:Hi,
I boot xbmcbuntu from an Intel 520 SSD drive. I mount my movies using nfs from a NAS.

The problem is, about half the time i boot up the library is not re-scaned. I think its beacuse my network and/or nfs mounts is not ready yet. If i do a manual "scan for new content" it works fine.

Question, is there any way to somehow delay the start of xbmc or delay the scan?
Maybe this?
http://forum.xbmc.org/showthread.php?tid...rtup+delay
find quote
joethefox Offline
Team-XBMC Member
Posts: 1,277
Joined: Nov 2010
Reputation: 22
Post: #3
and if can help to speed up nfs mounts, disable any DNS lookups in the nfs server, for example putting the ipaddress of the clients into the /etc/hosts of the nfs server (there are several and much more elegant ways, I think this is the fastest)
find quote
tpunder Offline
Junior Member
Posts: 21
Joined: Jul 2010
Reputation: 0
Post: #4
I had this exact problem with my network not coming up by the time XBMC loaded. I fixed it by editing /etc/network/interfaces and added this:

Code:
auto eth0
iface eth0 inet dhcp

Tweak the interface name based on your hardware...

That made the startup scripts wait for the network to come up before it loaded XBMC.

Hope that helps!
find quote
joolz Offline
Junior Member
Posts: 33
Joined: Oct 2008
Reputation: 0
Post: #5
Thanks for the suggestions. Tried both static network configuration and disabling dns lookups on the nfs server. Still no go.

I'm wondering where the best place is to put a sleep statement. /usr/bin/runXBMC is not used in xbmcbuntu. I tired putting it in /usr/bin/startxbmcbuntu but it had no effect.
find quote
vikjon0 Offline
---
Posts: 2,497
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #6
Good question. I cant find the start script for the xbmc session on github right now but it is not startxbmcbuntu. Thats script start the openbox based xbmcbuntu session, not XBMC.

You could put a timeout in lightdm.conf ( I guess) as a workaround until you find the right script.
find quote
vikjon0 Offline
---
Posts: 2,497
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #7
/usr/bin/xbmc-standalone it looks like.. part of xbmc not XBMCbuntu. Called from XBMC.desktop?
find quote
.:B:. Offline
Fan
Posts: 405
Joined: Mar 2010
Reputation: 0
Post: #8
Why not mount the NFS shares inside Xbmc? Eden has support for that. Maybe that solves your problem if you have them in fstab now.

* Netgear WNDR3700, OpenWrt Attitude Adjustment 12.09.1 :: HP Procurve V1410-8G switch
* OpenELEC 4: HTPC Zotac Nano AD10 with Pulse-Eight CEC adapter, Sony KDL52-NX800 :: Desktop Phenom II X4 980 BE / AMD HD6950 / 23" Dell Full HD
* Debian Jessie x86_64: Celeron G1610, HTTP/NFS/MySQL/ZFS server
* Blog
find quote
TugboatBill Offline
Posting Freak
Posts: 829
Joined: Oct 2009
Reputation: 7
Post: #9
I'm running the release xbmcbuntu and the script I put my delay in is /usr/bin/xbmc. I confirmed that it is running and the delay I added ensured the nfs mount was complete before XBMC started.
find quote
JaccoH Offline
Member
Posts: 79
Joined: May 2009
Reputation: 0
Post: #10
Adding delays is ugly in my opinion. Either use the NFS support in XBMC or use automount.
find quote
WonderStivi Offline
Junior Member
Posts: 19
Joined: Apr 2009
Reputation: 0
Post: #11
I'm mounting my NFS-shares in fstab, and I had some issues where the shares took a while to mount and were not ready when scanning. Adding nfsvers=3 in fstab solved it. Fstab then looked like this:

Path:/to/share /mount/point nfs nfsvers=3,defaults 0 0
find quote
TugboatBill Offline
Posting Freak
Posts: 829
Joined: Oct 2009
Reputation: 7
Post: #12
(2012-04-25 12:33)JaccoH Wrote:  Adding delays is ugly in my opinion. Either use the NFS support in XBMC or use automount.

Could you post an example of how to set up & configure automount to mount a nfs share to an xbmc client?
find quote
lcapriotti Offline
a.k.a Luigi, Team-XBMC XBMCbuntu Dev
Posts: 811
Joined: Jan 2008
Reputation: 12
Location: Italy
Post: #13
welcome indeed!

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
xbmcoholic Offline
Junior Member
Posts: 43
Joined: May 2010
Reputation: 0
Post: #14
Here's a copy of my automount(autofs) configuration in Ubuntu... Works pretty good but I find most times when resuming from standby, my network adapter cant wakeup before xbmc tries to scan for updates. I just hit yes to resume and it goes through fine.

Quote:Aspire-R3610:~$ cat /etc/auto.master
+auto.master
/mnt /etc/auto.nfs --ghost --timeout=15

Aspire-R3610:~$ cat /etc/auto.nfs
SHARE -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/SHARE
FreshDownloads -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/FreshDownloads
HD -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/HD
HDTV -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/HDTV
TV -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/TV
Music -fstype=nfs,rw,sync,soft,intr,rsize=262144,wsize=262144,timeo=5,retry=20 172.17.17.99:/Music

You may notice the high retry and timeout settings. This worked around a WiFi interference issue I've been having causing the mounts to time out...

For those of you trying to stream HD over WiFi I strongly urge you to use NFS instead of CIFS/SAMBA. I get a performance ratio of roughly 3:1 for NFS vs. SAMBA and stepping through 1080p video is instant. Further tweaking on my WiFi configuration got me up to 130Mbps of actual application throughput. I installed the Windows SFU 3.5 (services for unix) on my WinXP server to get NFS server support.

Ubuntu 12.04 LTS - 32bit
Acer Aspire Revo R3610
Intel Atom 330
4GB RAM (Shared)
NVIDIA Ion HDMI
Boxee Remote
find quote
msoka Offline
Junior Member
Posts: 2
Joined: Apr 2013
Reputation: 0
Post: #15
(2012-03-02 19:31)tpunder Wrote:  I had this exact problem with my network not coming up by the time XBMC loaded. I fixed it by editing /etc/network/interfaces and added this:

Code:
auto eth0
iface eth0 inet dhcp

Tweak the interface name based on your hardware...

That made the startup scripts wait for the network to come up before it loaded XBMC.

Hope that helps!

Tnx a lot this solved my problem!
find quote
Post Reply