Sometimes no fullscreen video on xbmcbuntu

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kingmob Offline
Junior Member
Posts: 40
Joined: Dec 2008
Reputation: 0
Post: #1
Every so often when I start a file on my XBMCbuntu installation, the audio starts for a few seconds but there is no video. After a while the audio also stops, but the interface is non-responsive. If I press the keyboard button that normally switches to windowed mode, I get fullscreen video back and it plays as normal. If I press any other button, xbmc will be unresponsive untill I restart lightdm/xbmc.

Here is my log file during this issue, I can not spot any obvious clues to what is wrong.

Code:
16:34:16 T:3016615696  NOTICE: CDVDPlayer::CloseFile()
16:34:16 T:3016615696  NOTICE: DVDPlayer: waiting for threads to exit
16:34:16 T:2779855728  NOTICE: CDVDPlayer::OnExit()
16:34:16 T:2779855728  NOTICE: DVDPlayer: closing audio stream
16:34:16 T:2779855728  NOTICE: Closing audio stream
16:34:16 T:2779855728  NOTICE: Waiting for audio thread to exit
16:34:16 T:2706029424  NOTICE: thread end: CDVDPlayerAudio::OnExit()
16:34:16 T:2779855728  NOTICE: Closing audio device
16:34:16 T:2779855728   ERROR: Unable to open audio mixer
16:34:16 T:2779855728  NOTICE: Deleting audio codec
16:34:16 T:2779855728  NOTICE: DVDPlayer: closing video stream
16:34:16 T:2779855728  NOTICE: Closing video stream
16:34:16 T:2779855728  NOTICE: waiting for video thread to exit
16:34:16 T:2714422128  NOTICE: thread end: video_thread
16:34:16 T:2779855728  NOTICE: deleting video codec
16:34:16 T:2779855728  NOTICE: DVDPlayer: closing subtitle stream
16:34:16 T:2779855728  NOTICE: Closing subtitle stream
16:34:16 T:2779855728  NOTICE: CDVDPlayer::OnExit() deleting demuxer
16:34:16 T:2779855728  NOTICE: CDVDPlayer::OnExit() deleting input stream
16:34:16 T:3016615696  NOTICE: DVDPlayer: finished waiting
16:34:16 T:3016615696  NOTICE:  (VDPAU) Close
16:34:16 T:3016615696  NOTICE:  (VDPAU) FiniVDPAUOutput
16:34:16 T:3016615696   ERROR: GLX: Same window as before, refreshing context
16:34:17 T:2779855728   ERROR: NFS: Failed to stat(volume1/video/series/24/Season 1/fanart.jpg) stat call failed with "NFS: Lookup of //series failed with NFS3ERR_NOENT(-2)"
16:34:17 T:2779855728   ERROR: NFS: Failed to stat(volume1/video/series/24/Season 1/logo.png) stat call failed with "NFS: Lookup of //series failed with NFS3ERR_NOENT(-2)"
16:34:17 T:2714422128   ERROR: NFS: Failed to stat(volume1/video/series/24/Season 1/../logo.png) stat call failed with "NFS: Lookup of //series failed with NFS3ERR_NOENT(-2)"
16:34:17 T:3016615696  NOTICE: CDVDPlayer::CloseFile()
16:34:17 T:3016615696 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
16:34:17 T:3016615696  NOTICE: DVDPlayer: waiting for threads to exit
16:34:17 T:3016615696  NOTICE: DVDPlayer: finished waiting
16:34:21 T:3016615696  NOTICE: DVDPlayer: Opening: nfs://192.168.1.140/volume1/video/series/24/Season 1/24 - S01E11 - 10.00 A.M - 11.00 A.M.mkv
16:34:21 T:3016615696 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
16:34:21 T:2706029424  NOTICE: Creating InputStream
16:34:21 T:2706029424  NOTICE: Creating Demuxer
16:34:21 T:2706029424  NOTICE: Opening video stream: 0 source: 256
16:34:21 T:2706029424  NOTICE: Creating video codec with codec id: 28
16:34:21 T:2706029424  NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(640x352, 28)
16:34:21 T:2706029424  NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000000
16:34:21 T:2706029424  NOTICE: VDPAU Decoder capabilities:
16:34:21 T:2706029424  NOTICE: name          level macbs width height
16:34:21 T:2706029424  NOTICE: ------------------------------------
16:34:21 T:2706029424  NOTICE: MPEG1             0  8192  2048  2048
16:34:21 T:2706029424  NOTICE: MPEG2_SIMPLE      3  8192  2048  2048
16:34:21 T:2706029424  NOTICE: MPEG2_MAIN        3  8192  2048  2048
16:34:21 T:2706029424  NOTICE: H264_MAIN        41  8192  2048  2048
16:34:21 T:2706029424  NOTICE: H264_HIGH        41  8192  2048  2048
16:34:21 T:2706029424  NOTICE: VC1_SIMPLE        1  8190  2048  2048
16:34:21 T:2706029424  NOTICE: VC1_MAIN          2  8190  2048  2048
16:34:21 T:2706029424  NOTICE: VC1_ADVANCED      4  8190  2048  2048
16:34:21 T:2706029424  NOTICE: MPEG4_PART2_ASP   5  8192  2048  2048
16:34:21 T:2706029424  NOTICE: ------------------------------------
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_SHARPNESS
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL_SPATIAL
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE
16:34:21 T:2706029424  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1
16:34:21 T:2706029424  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (VDPAU acceleration)
16:34:21 T:2706029424  NOTICE: Creating video thread
16:34:21 T:2706029424  NOTICE: Opening audio stream: 1 source: 256
16:34:21 T:2706029424  NOTICE: Finding audio codec for: 86018
16:34:21 T:2706029424  NOTICE: Creating audio thread
16:34:21 T:2706029424  NOTICE: Opening Subtitle stream: 0 source: 1024
16:34:21 T:2752220016  NOTICE: running thread: CDVDPlayerAudio::Process()
16:34:21 T:2771463024  NOTICE: running thread: video_thread
16:34:21 T:2752220016  NOTICE: Creating audio device with codec id: 86018, channels: 2, sample rate: 48000, no pass-through
16:34:21 T:2771463024  NOTICE:  (VDPAU) screenWidth:0 vidWidth:640 surfaceWidth:640
16:34:21 T:2771463024  NOTICE:  (VDPAU) screenHeight:0 vidHeight:352 surfaceHeight:352
16:34:30 T:2752220016 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
16:34:30 T:2752220016   ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe
16:34:32 T:3016615696   ERROR: GLX: Same window as before, refreshing context
16:34:32 T:2771463024  NOTICE: Creating 640x352 pixmap
16:34:32 T:2771463024  NOTICE:  (VDPAU) Total Output Surfaces Available: 4 of a max (tmp: 4 const: 4)
16:34:32 T:2771463024  NOTICE:  (VDPAU) Creating the video mixer
16:34:32 T:2771463024  NOTICE:  fps: 25.000000, pwidth: 640, pheight: 352, dwidth: 640, dheight: 352
16:34:32 T:2771463024  NOTICE: Display resolution ADJUST : default: 1920x1080 @ 50.00Hz (14) (weight: 0.000)
16:34:33 T:3016615696  NOTICE: Using GL_TEXTURE_2D
16:34:33 T:3016615696  NOTICE: GL: Using VDPAU render method
16:34:33 T:3016615696  NOTICE: GL: NPOT texture support detected
16:34:33 T:3016615696  NOTICE: GL: Using GL_ARB_pixel_buffer_object
16:34:34 T:3016615696  NOTICE: CVDPAU::OnLostDevice event
16:34:34 T:3016615696  NOTICE:  (VDPAU) FiniVDPAUOutput
16:34:34 T:3016615696   ERROR: GLX: Same window as before, refreshing context
16:34:34 T:3016615696  NOTICE: Using GL_TEXTURE_2D
16:34:34 T:3016615696  NOTICE: GL: Using VDPAU render method
16:34:34 T:2771463024  NOTICE: CVDPAU::Check waiting for display reset event
16:34:34 T:3016615696  NOTICE: GL: NPOT texture support detected
16:34:34 T:3016615696  NOTICE: GL: Using GL_ARB_pixel_buffer_object
16:34:34 T:3016615696  NOTICE: CVDPAU::OnResetDevice event
16:34:34 T:2771463024  NOTICE: Attempting recovery
16:34:34 T:2771463024  NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000000
16:34:35 T:2771463024  NOTICE:  (VDPAU) screenWidth:640 vidWidth:640 surfaceWidth:640
16:34:35 T:2771463024  NOTICE:  (VDPAU) screenHeight:352 vidHeight:352 surfaceHeight:352
16:34:35 T:2771463024  NOTICE: Creating 640x352 pixmap
16:34:35 T:2771463024  NOTICE:  (VDPAU) Total Output Surfaces Available: 4 of a max (tmp: 4 const: 4)
16:34:35 T:2771463024  NOTICE:  (VDPAU) Creating the video mixer
find quote
errornumber419 Offline
Junior Member
Posts: 29
Joined: Dec 2011
Reputation: 0
Location: Wisconsin
Post: #2
Pretty sure I just had this happen too.

Eden rc1 on xubuntu.
GeForce 210.
find quote
mrreload Offline
Junior Member
Posts: 13
Joined: Jan 2011
Reputation: 0
Post: #3
I have been having this issue for a few months now. I was building from development git Eden-Pre and thought the issue would have disappeared in the recent Eden stable release, Unfortunately the issue persists.
Issue exists using every skin I have tried.
Strangely, the issue only started showing for me when I switched from using PulseAudio to Alsa. I don't like Pulse for it's inability to use Passthrough.
All movies are MKV with DTS or DD using passthrough to my receiver.

Is there any info I can provide that will help solve the issue?

Ubuntu 11.10 64bit
Phenom x6 1055T
4Gb Ram
GeForce 240
Audio out via Motherboard's SPDIF port
(This post was last modified: 2012-04-07 21:17 by mrreload.)
find quote
kingmob Offline
Junior Member
Posts: 40
Joined: Dec 2008
Reputation: 0
Post: #4
Sorry for such a late reply, but this thread is a lot more active and discusses the same problem:
http://forum.xbmc.org/showthread.php?tid...pid1091910
find quote