[Windows] AudioEngine testers - Windows platform only

  Thread Rating:
  • 3 Votes - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #46
Hi two_OH_five, the drop-outs you see are more obvious on slower hardware, but are not really a hardware problem per se. It's a bug pure and simple, it just becomes more noticeable on slower machine. Once we post this fixed version your hardware will be more than enough to handle full bitsteaming and 24bit audio with AE. I believe at this time we have a fix for this specific issue, and have gathered enough data on it, so a Debug Log won't really help us further on that issue, but thanks for offering.

Basically though, your hardware is fine to use this once we release then next build.

As an update - we are looking at a merge into nightlies in mid-to-late April across all platforms, which is not that far off! There is some concerted effort now by devs across platforms to prepare for the merge, so there's definite progress towards integration!

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
liquidskin76 Offline
Skilled Skinner
Posts: 1,366
Joined: Aug 2009
Reputation: 17
Location: Arkham, Gotham City
Post: #47
(2012-03-19 20:41)DDDamian Wrote:  As an update - we are looking at a merge into nightlies in mid-to-late April across all platforms, which is not that far off! There is some concerted effort now by devs across platforms to prepare for the merge, so there's definite progress towards integration!

[giggle... cough] just a little excited. Big Grin

HTPC: Streacom F1C | Asus H87I-Plus ITX | Intel Core i5-4670T | Kingston HyperX SSD | Kingston DDR3 RAM
Home AV: Sony KDL-40HX723 | Sky+HD | Sony BDP-S480 BD Player | Sony STR-DH820 AV Receiver | Sony 5.1 Speaker System | Sony PS3 Slim | Logitech Harmony Touch
find quote
Mettbrot Offline
Senior Member
Posts: 191
Joined: Jan 2011
Reputation: 2
Post: #48
(2012-03-19 20:41)DDDamian Wrote:  As an update - we are looking at a merge into nightlies in mid-to-late April across all platforms, which is not that far off! There is some concerted effort now by devs across platforms to prepare for the merge, so there's definite progress towards integration!

Do you mean AudioEngine in general (gnifs branch) or is it just the windows versions of AE?
(This post was last modified: 2012-03-27 16:11 by Mettbrot.)
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #49
AE in general - it will only be merged to master for all platforms - anything else is "unofficial", The master branch will always be multi-platform.

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
abudabi Offline
Senior Member
Posts: 109
Joined: Aug 2011
Reputation: 1
Post: #50
Now that Eden has landed.. Still mid-to-late April?

When the merge into nightlies happen, it will already be compiled.. correct?


Thanks for the work chaps!
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #51
@abudabi - yessir

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #52
Hi folks - just wanted to let you know that after a long delay there's a new version uploaded to GitHub! You can use the link on the first post of this thread as always or look here. As always look for XBMC-AE-xxxxxxxx.zip with the latest date, so todays is XBMC-AE-20120331.zip.

Changes:
- increase internal buffers to reduce sync issues
- add interlock to prevent crash when switching to allchannelstereo with multichannel LPCM disabled
- fixed issue with WASAPI buffer not always being filled - led to garbled high-def music
- move useful settings to GUI under Settings>System>Audio Output (scroll down)
- better debug logging for testing

Some of these changes were a direct result of your previous testing - thanks. I've tested on 1080p with TrueHD and DTS-MA and have no drop-outs or synch issues with "Adjust refresh rate to match video" enabled and "Sync Video to Display" disabled, which are the settings I would recommend.

Right now I'm very happy with this build - does all the good things it should. Give it a try and see what you think!

Cheers,
Damian

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-01 01:43 by DDDamian.)
find quote
ix400 Offline
Senior Member
Posts: 207
Joined: Aug 2010
Reputation: 0
Location: Germany
Post: #53
I just tried the new version. Still this permanent switching between PCM and DTS-HD:

http://dl.dropbox.com/u/7782292/Video%20...6%2055.mov

and log:

http://dl.dropbox.com/u/7782292/xbmc.old.log

The log contains a playback with the standard setting for the buffer. Then I stopped the playback and increased the buffer a bit, that's the second part of the log.

Increasing the buffer size didn't do the job. The receiver stops the switching then, but it doesn't recognize the signal at all. Hence, no sound.

I'm using a Zotac Nano AD10 directly hooked to a Pioneer Vsx-Lx52.

Cheers,

Chris

unRAID Server, Pioneer VSX-LX52, Panasonic 65VT30, Marusys VU+ Duo, Zotac AD10
find quote
HeresJohnny Offline
Senior Member
Posts: 156
Joined: Mar 2011
Reputation: 2
Location: Germany
Post: #54
(2012-04-01 01:42)DDDamian Wrote:  new version uploaded to GitHub!

Thanks! Is there a special reason you compiled it against RC2 rather than Eden final?
Update: Actually, the file inside XBMC-AE-20120331.zip is still named XBMCSetup-20120306-f5b1f34-dx.exe, same as the previous one. Late night mistake, maybe?
(This post was last modified: 2012-04-01 10:40 by HeresJohnny.)
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #55
(2012-04-01 10:02)HeresJohnny Wrote:  
(2012-04-01 01:42)DDDamian Wrote:  new version uploaded to GitHub!

Thanks! Is there a special reason you compiled it against RC2 rather than Eden final?
Update: Actually, the file inside XBMC-AE-20120331.zip is still named XBMCSetup-20120306-f5b1f34-dx.exe, same as the previous one. Late night mistake, maybe?

Very late-night mistake Smile Didn't commit to Git yet, so version hasn't changed in filename. The "Date Modified" of the file should be March 31st, 2012.

The RC2 part was intentional - just wanted as few other changes as possible for testing purposes and still allow users to use the myvideos60.db library as it was updated to that version in Beta 3.

I've been testing and on my rig the only issue I've found is on a change to a different music format it re-opens the audio driver twice - just creates a slightly longer delay switching formats. Let me know how it goes for you!

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-01 20:12 by DDDamian.)
find quote
HeresJohnny Offline
Senior Member
Posts: 156
Joined: Mar 2011
Reputation: 2
Location: Germany
Post: #56
Ok, my first try with AE on an NVIDIA ION platform - no go. Flac Hires playback is choppy and DTS gives either "error initializing device" or freezes XBMC completely. Sad
Here's my log: http://pastebin.com/MLQ6wnXc
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #57
(2012-04-01 19:40)HeresJohnny Wrote:  Ok, my first try with AE on an NVIDIA ION platform - no go. Flac Hires playback is choppy and DTS gives either "error initializing device" or freezes XBMC completely. Sad
Here's my log: http://pastebin.com/MLQ6wnXc

Hi HeresJohnny. Thanks for the log.

The 24/96 Elvis Costello track should play beautifully - but I see lot's of
Code:
19:26:40 T:3804   DEBUG: CSoftAEStream::GetFrame - Underrun
19:26:43 T:5836   DEBUG: Previous line repeats 4 times.

It's almost like it's not reading it from drive "Q:\" fast enough. Can you copy the file to a local drive and try?

The log is chopped off (too long), but I have an ISO of Peter Gabriel - Play the Videos and it works great for me in DTS 96/24. Nice pic btw. In your windows audio properties does it show DTS-HD as a supported format?

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
(This post was last modified: 2012-04-01 20:24 by DDDamian.)
find quote
ix400 Offline
Senior Member
Posts: 207
Joined: Aug 2010
Reputation: 0
Location: Germany
Post: #58
DDDamian, did you have a look on the log I posted above? Do you have an idea what might be wrong ?

Would be nice if you could have a look on it.

Chris

unRAID Server, Pioneer VSX-LX52, Panasonic 65VT30, Marusys VU+ Duo, Zotac AD10
(This post was last modified: 2012-04-01 20:30 by ix400.)
find quote
liquidskin76 Offline
Skilled Skinner
Posts: 1,366
Joined: Aug 2009
Reputation: 17
Location: Arkham, Gotham City
Post: #59
Hey DDDamian,

Will test later tonight and report back if the issues i was seeing are sortred.

Cheers mate!

HTPC: Streacom F1C | Asus H87I-Plus ITX | Intel Core i5-4670T | Kingston HyperX SSD | Kingston DDR3 RAM
Home AV: Sony KDL-40HX723 | Sky+HD | Sony BDP-S480 BD Player | Sony STR-DH820 AV Receiver | Sony 5.1 Speaker System | Sony PS3 Slim | Logitech Harmony Touch
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #60
thx liquidskin - much appreciated

ix400 - sorry - missed that post - multi-tasking fail Smile checking now and will post comments - much appreciated

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
Post Reply