[RELEASE] Artist Slideshow 1.3.0 addon (with skin and addon integration)

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
thechinmaster Offline
Member
Posts: 64
Joined: Aug 2011
Reputation: 0
Post: #31
thanks for the answer pkscuot, I have got artist slideshow working in both confluence and neon. it works if i use no visualization but if i use milkdrop I cannot see artist slideshow at all (even in full-screen music player screen ha ha)

any ideas?

debugging-enabled paste here

Cheers
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #32
(2012-03-20 10:25)thechinmaster Wrote:  thanks for the answer pkscuot, I have got artist slideshow working in both confluence and neon. it works if i use no visualization but if i use milkdrop I cannot see artist slideshow at all (even in full-screen music player screen ha ha)

any ideas?

I don't have milkdrop, but I did try a couple of the built in visualizations. Some of them take the entire screen, so you definitely can't see the artist slideshow behind them. But the ones I had (like Waveform) did show the slideshow behind the visualization. There might be some setting in Milkdrop to have a transparent background that would let the artist slideshow show through. Hopefully the person who posted about doing that with Milkdrop will wander back and let us know how they did it.
find quote
thechinmaster Offline
Member
Posts: 64
Joined: Aug 2011
Reputation: 0
Post: #33
thanks for the answer - tried waveform - not too bad, and does as you said. I think I may explore other visualizations in the mean time. thanks again for the cracking addon
find quote
ronie Offline
Team-XBMC Member
Posts: 8,986
Joined: Jan 2009
Reputation: 147
Post: #34
i was revisiting the old script as a needed some bits and pieces for a script i'm working on
and i think i found a bug in the old script that's still present today.
the caching code of the .nfo files looks broken to me, once a .nfo file exists it'll never get updated afaict.

changing
Code:
elif ForceUpdate:
to
Code:
if ForceUpdate:
should fix it.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #35
(2012-03-24 01:27)ronie Wrote:  i was revisiting the old script as a needed some bits and pieces for a script i'm working on
and i think i found a bug in the old script that's still present today.
the caching code of the .nfo files looks broken to me, once a .nfo file exists it'll never get updated afaict.

Got it. I have this fix and an update to the internet stream support. I was waiting until Eden "shipped" as they're pretty small updates. So I'll do a pull request soon I hope. Big Grin
find quote
fredphoesh Offline
Donor
Posts: 263
Joined: Apr 2010
Reputation: 1
Location: South of London North of Brighton
Post: #36
Thanks again guys... since being a squeaky wheel requesting this feature years ago, to Ronie developing an existing script to this with Eden now... the main reason why I was very happy to donate $50 to xbmc...

I struggled to make this add on work with Eden, as I thought it would be as easy as to go to Settings > Add-Ons > Program Add-Ons > Artist Slideshow and then to download and enable that.

This did not work in Confluence skin.
I then went to the wiki, and found, under "How to use this addon in your skin" a bunch of very technical detals which were not expaining how to use the addon... but has Changes to MusicVisualisation.xml, To run the script: <onload>RunScript(script.artistslideshow)</onload> etc...

Nowhere on the wiki that I could see is there an explanation of how to add this addon, and to me its a pity cos its an uber-fantastic thing of great joy... next best thing to holding a real album cover in your hands...

Please add on the Ops, fist post, that to make this work with the default xbmc skin, you must download the zip file in post 2, then unzip those files and copy them to C:\Program Files (x86)\XBMC\addons\skin.confluence\720p (or equivalent) replacing the existing ones.

At the moment I am trying to figure if this will work with Transparency! which is my skin of choice... is it compatible, how do I make that work?

Thanks again for the fantastic work...

Mark.



Thanks,
Mark
(This post was last modified: 2012-03-24 15:28 by fredphoesh.)
find quote
ronie Offline
Team-XBMC Member
Posts: 8,986
Joined: Jan 2009
Reputation: 147
Post: #37
(2012-03-24 12:07)fredphoesh Wrote:  One thing though, I cant make it work LOL.
Seriously. I have it working on my other computer with Dharma, but Ive installed v1.3.0 under Programs as an add on, but nothing shows in full screen mode. I have tried Confluence and Transparency skins.

in Transparency!, you can enable it on the MusicOSD:

[Image: artistslideshow.jpg]

for Confluence, you should use the mod found in the second post:
http://forum.xbmc.org/showthread.php?tid...pid1039757

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-XBMC members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
fredphoesh Offline
Donor
Posts: 263
Joined: Apr 2010
Reputation: 1
Location: South of London North of Brighton
Post: #38
(2012-03-24 15:27)ronie Wrote:  
(2012-03-24 12:07)fredphoesh Wrote:  One thing though, I cant make it work LOL.
Seriously. I have it working on my other computer with Dharma, but Ive installed v1.3.0 under Programs as an add on, but nothing shows in full screen mode. I have tried Confluence and Transparency skins.

in Transparency!, you can enable it on the MusicOSD:


for Confluence, you should use the mod found in the second post:
http://forum.xbmc.org/showthread.php?tid...pid1039757


Thanks Ronie and Hi!!
I was bz modifying my post above yours when you responded.
Cheers, have a great day.
Mark.
(This post was last modified: 2012-03-24 15:30 by fredphoesh.)
find quote
Martijn Offline
Team-XBMC
Posts: 10,299
Joined: Jul 2011
Reputation: 154
Location: Dawn of time
Post: #39
Script stop immediately after it was started

full log

Using T!
All artists are properly tagged. Image are available on htbackdrops

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #40
(2012-03-27 18:32)Martijn Wrote:  Using T!

Is T! a skin? I'll download it and try. All I can say for now is that I agree, the script is definitely stopping. I can't seem to manually walk a circumstance where you would get the log entries you got and not at least one more line, so I'll need to look into it some more.
find quote
Martijn Offline
Team-XBMC
Posts: 10,299
Joined: Jul 2011
Reputation: 154
Location: Dawn of time
Post: #41
(2012-03-27 20:16)pkscuot Wrote:  
(2012-03-27 18:32)Martijn Wrote:  Using T!

Is T! a skin? I'll download it and try. All I can say for now is that I agree, the script is definitely stopping. I can't seem to manually walk a circumstance where you would get the log entries you got and not at least one more line, so I'll need to look into it some more.

hehe ronie is not gonna like you any more Wink

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #42
(2012-03-27 20:48)Martijn Wrote:  
(2012-03-27 20:16)pkscuot Wrote:  
(2012-03-27 18:32)Martijn Wrote:  Using T!

Is T! a skin? I'll download it and try. All I can say for now is that I agree, the script is definitely stopping. I can't seem to manually walk a circumstance where you would get the log entries you got and not at least one more line, so I'll need to look into it some more.

hehe ronie is not gonna like you any more Wink

I see why now. He's going to hate me even more when I tell you I can't figure out how to get Artist Slideshow to even start using Transparency! If I rip out the condition of the onload in MusicVisualization.xml, Artist Slideshow runs when I go full screen while listening to music, and I see in the debug log that it is working, but it never displays any images.

EDIT: I found where to enable Artist Slideshow. And with it enabled it's running as expected on both my OSX development machine and Windows production machine.

Could someone else check with Transparency! to see if it works for them. At least then we'll know whether it's me or Martijn who is going crazy. Wink
(This post was last modified: 2012-03-27 22:17 by pkscuot.)
find quote
Martijn Offline
Team-XBMC
Posts: 10,299
Joined: Jul 2011
Reputation: 154
Location: Dawn of time
Post: #43
(2012-03-27 21:59)pkscuot Wrote:  Could someone else check with Transparency! to see if it works for them. At least then we'll know whether it's me or Martijn who is going crazy. Wink

Crazy already, I am Rofl

Seems my test setup is some what messed up.
Works fine on my normal HTPC. Still weird though

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #44
(2012-03-27 22:55)Martijn Wrote:  Seems my test setup is some what messed up.
Works fine on my normal HTPC. Still weird though

Very strange to be sure. It's starting the script for sure. After that it's almost like the object gets destroyed before it gets to the first conditional statement when it figures out if there's music playing and then finishes the script. It's the only way I can figure you would get that set of log entries without something like "no music playing" or "first song started" in the log as well.

Or you're not holding your tongue the right way when you start the music visualization. Either is equally plausible. Big Grin
find quote
NisseDILLIGAF Offline
Junior Member
Posts: 17
Joined: Jan 2009
Reputation: 0
Post: #45
@pkscuot

have a look at my last commit...
https://github.com/NisseDILLIGAF/script....4cf2587e6d

sometimes last.fm has no album image, then it just shows http://cdn.last.fm/flatness/catalogue/no...medium.png
find quote
Post Reply