[RELEASE] Artist Slideshow 1.3.0 addon (with skin and addon integration)

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #931
It would definitely help to see a debug log.
find quote
fabio2007 Offline
Junior Member
Posts: 1
Joined: Mar 2014
Reputation: 0
Post: #932
I listen a lot of music, this is by far my favorite xbmc plugin, and I wish to thank you very much for your effort in mantaining it

but it's driving me crazy
it works for a while, suddendly it stops

has happened form some versions, putting the new one usually solve..
1.6.2 has worked for a while, now has stopped

my tipical setting:

XBMCBuntu , Frodo 12.3 with ArtistSlideshow 1.6.2, Aeon Nox 4.0.9

fresh install
had worked for a few hours,


sometimes, to have it work, I have to click "start" on the program itself, while music is playing

of course each time I try with a different artist to be sure that the program does not keep info from a previous session

some examples:

http://xbmclogs.com/show.php?id=145682
in this one I played Al Jarreau , but nothing happened

http://xbmclogs.com/show.php?id=145695
in this one James Taylor

as can you see, logs are very differents, in terms of plugin activity, the result (on screen ) it's the same "no sign of activity of ArtistSlideshow"

thank you very much

edit:
removed 1.6.2
removed userdata/addon_data/script.artistslideshow
addons/script.artistslideshow was already removed

installed 1.5.9, now it's working fine.
(This post was last modified: 2014-03-09 05:07 by fabio2007.)
find quote
back Offline
Junior Member
Posts: 18
Joined: Dec 2004
Reputation: 0
Post: #933
Hi pkscuot

I'm having a similar issue as fabi2007. AS sometimes works, and sometimes not. Mostly it doesn't work. Right now it's not working, nothing shows up in the background when playing music from Spotlight. This is my debug log: http://tny.cz/d4c3c141

Care to take a look?
find quote
LEDFan Online
Senior Member
Posts: 297
Joined: Nov 2012
Reputation: 1
Location: Québec, Canada
Post: #934
I use version 1.6.2 of the addon.

1- Each time I press "i" on an artist which has accents in their name gives me a script error as you can see in the picture for Beyoncé.

[Image: A3SVucV.jpg]

Here is a part of my log: http://www.xbmclogs.com/show.php?id=146553

Why?

2- Why do I get this for many artists? My nfo file are correct and my MP3 files are correctly tagged with MusicBrainz Picard app.

For Adele, it's OK:
[Image: hiillxn.jpg]

But for many artists I just get this, like here for Alicia Keys:
[Image: PpdJ5b6.jpg]
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #935
NEW BETA AVAILABLE

v.1.6.2.2
- fixed crash when viewing artists with extended characters in their name
- fixed bad searches with artists with extended characters in their name

https://github.com/pkscout/script.artist...master.zip

I think this will fix the issue LEDFan was having, and it should make AS get artwork more consistently. As for any issues related to Last.FM data, at this point it looks like Last.FM is giving back less and less and less and less data. I am no longer able to troubleshoot any Last.FM issues, and I will likely remove all Last.FM support in an upcoming release. The only thing left it is really used for is similar artists.
find quote
LEDFan Online
Senior Member
Posts: 297
Joined: Nov 2012
Reputation: 1
Location: Québec, Canada
Post: #936
I tried 1.6.2.2 by replacing all files instead of installing from zip and I get a script error each time. Where can I get previous version 1.6.2 (since I replaced all my files)?
find quote
Lockos Offline
Senior Member
Posts: 192
Joined: May 2011
Reputation: 1
Post: #937
Hi Pkscuot !

Glad you put another cool update ! However, I have a request : please don't remove last.fm support which is the only provider in foreign language (when it works).

I say "when it works" because as usual, I'm having several bugs with the addon, if you could take a quick look at it.
I'm running Aeon Nox 4.1.9 Gotham version with Gotham beta1 (anyway those bugs are remaining under frodo 12.3) with spotimc 1.0-beta5 (latest github commit).
Download of images is activated for all services (HTBackdrops, Lastfm, etc...) and additional info is also activated and set up in french.

1) I don't have text info for a lot of artists (while I have better results in english).

What is weird is that this info actually exists on Last.fm french site. Look :

[Image: n--IDd3ka2HWRwEZEF0uWK667OI8jzkEVgQ15wNi...25-h745-no]

and on last.fm site :

[Image: Sans+titre4.jpg]


2) Is it possible to use artists fanart here, where we still got this awful picture for every artists ?

[Image: Sans+titre.jpg]

I have fanarts for my local artists because the addon is set up to local images first, but nothing for spotimc artists.

3) Do you know how to get text info for the additionnal info field ? (or is this has nothing to do with your addon ?)
Look at the picture below, I don't have anything populating this field :

[Image: Sans+titre2.jpg]

Big thanks in advance for your reply ! Wink

@LedFan : delete your addondata artistslideshow folder first (except the settings file) and it should be okay ! Wink
(This post was last modified: 2014-03-10 20:08 by Lockos.)
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #938
(2014-03-10 19:55)LEDFan Wrote:  I tried 1.6.2.2 by replacing all files instead of installing from zip and I get a script error each time. Where can I get previous version 1.6.2 (since I replaced all my files)?

Delete the AS add-on and reinstall from the main XBMC repo. It would be really helpful to see a debug log.

(2014-03-10 20:06)Lockos Wrote:  Glad you put another cool update ! However, I have a request : please don't remove last.fm support which is the only provider in foreign language (when it works).

I say "when it works" because as usual, I'm having several bugs with the addon, if you could take a quick look at it.
I'm running Aeon Nox 4.1.9 Gotham version with Gotham beta1 (anyway those bugs are remaining under frodo 12.3) with spotimc 1.0-beta5 (latest github commit).
Download of images is activated for all services (HTBackdrops, Lastfm, etc...) and additional info is also activated and set up in french.

1) I don't have text info for a lot of artists (while I have better results in english).

What is weird is that this info actually exists on Last.fm french site. Look :

Based on that I guess I'll have to leave it in, but it seems like Last.FM is providing less and less information, or at least I can't figure out why sometimes I get data back and sometimes I don't.

Quote:2) Is it possible to use artists fanart here, where we still got this awful picture for every artists ?

3) Do you know how to get text info for the additionnal info field ? (or is this has nothing to do with your addon ?)
Look at the picture below, I don't have anything populating this field :

I think both those things are related to your skin and not AS.
(This post was last modified: 2014-03-10 20:31 by pkscuot.)
find quote
Lockos Offline
Senior Member
Posts: 192
Joined: May 2011
Reputation: 1
Post: #939
Thanks for your answers Wink If you have to leave last.fm and if it is your decision, so be it !

Can I just be curious and ask you what would be the biography and album info provider you would use instead ?
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #940
(2014-03-10 20:44)Lockos Wrote:  Thanks for your answers Wink If you have to leave last.fm and if it is your decision, so be it !

Can I just be curious and ask you what would be the biography and album info provider you would use instead ?

theaudiodb.com is the "default" provider for AS now. Last.FM is used only in the case where album or bio information can't be found there. I think I might have found some of the problem though. I'm getting ready to post a new beta.

NEW BETA

v.1.6.2.3
- additional changes to get more consistent results from external sites

https://github.com/pkscout/script.artist...master.zip

I'm continuing to track down issues with results from the various external sites. Both Last.FM and htbackdrops should provide better results now, and I think even MusicBrainz should be better too. Apparently the requests module handles url encoding differently than the older libraries I was using, so AS has been generating a fair number of "bad" URLs.
(This post was last modified: 2014-03-10 21:23 by pkscuot.)
find quote
Lockos Offline
Senior Member
Posts: 192
Joined: May 2011
Reputation: 1
Post: #941
That is an excellent news ! Thanks a lot pkscuot for having such a devoted development spirit ! Wink

Gonna try it asap !
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #942
(2014-03-10 22:34)Lockos Wrote:  That is an excellent news ! Thanks a lot pkscuot for having such a devoted development spirit ! Wink

Gonna try it asap !

You're welcome. I mostly have serious OCD (obsessive compulsive disorder) when it comes to bugs. So fixing code is therapy for me. Wink
find quote
LEDFan Online
Senior Member
Posts: 297
Joined: Nov 2012
Reputation: 1
Location: Québec, Canada
Post: #943
1- Thanks guys, OK I installed it 1.6.2.3 correctly now! It seems that this version has corrected the bug I had on the picture. Great.

(2014-03-10 04:27)LEDFan Wrote:  For many artists I just get this, like here for Alicia Keys:
[Image: PpdJ5b6.jpg]

now works OK:
[Image: ImlRbrD.jpg]

2- But I still encounter a script error for artists with accents in their names, part of the log here (look aroung line 1343): http://www.xbmclogs.com/show.php?id=147093
Could that be on my side? I don't know anymore.

[Image: A3SVucV.jpg]

3- Finally, when the script fails for one artist, is this normal that it'sa not working anymore after for other artists? I have to close xbmc in order to make it work again.
(This post was last modified: 2014-03-11 00:15 by LEDFan.)
find quote
pkscuot Offline
Posting Freak
Posts: 903
Joined: Jan 2011
Reputation: 20
Location: Honolulu, HI
Post: #944
(2014-03-11 00:02)LEDFan Wrote:  Thanks guys, OK I installed it 1.6.2.3 correctly now! It seems that this version has corrected the bug I had on the picture. Great.

But I still encounter a script error for artists with accents in their names, part of the log here (look aroung line 1343): http://www.xbmclogs.com/show.php?id=147093
Could that be on my side? I don't know anymore.

Nope, that's mine. I think I've fixed it and will post a new beta right after this.

Quote:Finally, when the script fails for one artist, is this normal that it'sa not working anymore after for other artists? I have to close xbmc in order to make it work again.

Yes, that's normal after a crash of the script. If the script crashes two things happen. First, the script isn't running anymore, so it isn't checking for changes in the music. Second, because it crashed AS thinks it's still running and won't start again. The only way to reset that is to quit XBMC and restart it.

NEW BETA

v.1.6.2.4
- fixed another crash when viewing artists with extended characters in their name

https://github.com/pkscout/script.artist...master.zip
(This post was last modified: 2014-03-11 00:12 by pkscuot.)
find quote
LEDFan Online
Senior Member
Posts: 297
Joined: Nov 2012
Reputation: 1
Location: Québec, Canada
Post: #945
Wow you're too fast for me! lol

OK I'll try this one and let you know later on.

Last question:

The addon is configured to receive info in French but I get the biography in English. Why's that?

[Image: ytqVs0o.jpg]

[Image: jt8pPyL.jpg]

But the info at Lastfm is in French:

[Image: WFIU7vc.jpg]

Edit: Just tried 1.6.2.4. Great work! Now it works for artists with accents:

[Image: 61dy9jb.jpg]

The only remaining problem I have is the biography language as shown above.

Thanks a lot for your hard work.
(This post was last modified: 2014-03-11 00:25 by LEDFan.)
find quote
Post Reply