[RELEASE] Spotimc: Another Spotify music addon

  Thread Rating:
  • 30 Votes - 4.7 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dallasnights Offline
Fan
Posts: 490
Joined: Jan 2011
Reputation: 0
Post: #46
Sure here is my LOG file you requested, I hit playlist and let it sit for about 6 min nothing showed up and I exited to get you this LOG
Please advise the solution, thank you

http://pastebin.com/T6LFiGkE
find quote
mattg42 Offline
Junior Member
Posts: 19
Joined: Oct 2010
Reputation: 0
Post: #47
Hi,

I am using Crystalbuntu on a ATV1 / Linux on Eden RC2 with Cyrus skin. I've tried to use the plugin but am getting a script error when I go into it and the initial rotating icon apprears briefly. I never get a login screen on the first run. I've tried to reboot and restart XMBC but same result.

Here is a log file and it might relate to Python versions but I thought Eden was standardised on that now.

http://pastebin.com/download.php?i=9qnpdkpB

Thanks for any input you can provide and for developing this, its what many of us have been waiting for!
find quote
ferry Offline
Member
Posts: 62
Joined: Apr 2009
Reputation: 0
Post: #48
Can't thank you enough for this been waiting on a proper XBMC "app" for Spotify for ages and although I've just installed it, it looks great and works a treat so far. I have Spotify apps on my mobile and PC and at last XBMC.

I was wondering if you receive donations to encourage you in the development of this?

I'm running XBMCBuntu latest

Just having a problem getting it to remember my login details for Spotify, otherwise amazing. Edit--sorry my mistake, by complete coincidence the card they billed had expired a few weeks ago and they couldn't rebill on my monthly anniversary date which was yesterday, fixed now and logging in fine.
(This post was last modified: 2012-03-24 14:13 by ferry.)
find quote
mazkolain Offline
Senior Member
Posts: 114
Joined: Mar 2012
Reputation: 13
Post: #49
(2012-03-23 02:16)Ommand Wrote:  Is there any way we can get some screenshots added to the OP?
Sorry I can't understand the meaning of OP Blush, but it's true that there are no screenshots available. The github project page would be a good start.

(2012-03-23 03:14)dallasnights Wrote:  Sure here is my LOG file you requested, I hit playlist and let it sit for about 6 min nothing showed up and I exited to get you this LOG
Please advise the solution, thank you

http://pastebin.com/T6LFiGkE
Thanks! A brief look shows lots of timeout errors, but the key must be there. I'll continue investigating.

(2012-03-23 11:11)mattg42 Wrote:  Hi,

I am using Crystalbuntu on a ATV1 / Linux on Eden RC2 with Cyrus skin. I've tried to use the plugin but am getting a script error when I go into it and the initial rotating icon apprears briefly. I never get a login screen on the first run. I've tried to reboot and restart XMBC but same result.

Here is a log file and it might relate to Python versions but I thought Eden was standardised on that now.

http://pastebin.com/download.php?i=9qnpdkpB

Thanks for any input you can provide and for developing this, its what many of us have been waiting for!
Probably related to some XML comments on the skin code that the plugin is unable to parse. Almost sure that is the same bug that happens with the refocus skin. I'm already preparing a fix for it, so it may work also for Cyrus.

(2012-03-23 16:43)ferry Wrote:  I was wondering if you receive donations to encourage you in the development of this?
Don't worry about that, as long as I can find spare time for it development will go on. Has been like that since I started a year and a half ago Wink Anyway, thank you!
find quote
adytum Offline
Senior Member
Posts: 100
Joined: Oct 2010
Reputation: 0
Post: #50
This is an extremely well made addon! Thanks so much!

Do you have plans to implement the radio too?
find quote
Ommand Offline
Junior Member
Posts: 22
Joined: Jun 2010
Reputation: 0
Post: #51
(2012-03-24 15:09)mazkolain Wrote:  
(2012-03-23 02:16)Ommand Wrote:  Is there any way we can get some screenshots added to the OP?
Sorry I can't understand the meaning of OP Blush, but it's true that there are no screenshots available. The github project page would be a good start.

OP = Original Post.

I don't see any screenshots on the github page either.
find quote
monkeybite Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #52
Every song I play stops after 7-10 seconds and changes to the next song in list. Does not matter if it's in a playlist or random song.
I now have Eden installed, Windows 7 64-bit, and of course have a proper Spotify premium account.

Anyone with the same problem? I LOVE the interface, but it's kind of annoying when I can only listen to 10 seconds of the song... hehe.
(This post was last modified: 2012-03-25 12:56 by monkeybite.)
find quote
Blueblack Offline
Junior Member
Posts: 14
Joined: Jul 2011
Reputation: 0
Location: Uppsala, Sweden
Post: #53
(2012-03-25 12:56)monkeybite Wrote:  Every song I play stops after 7-10 seconds and changes to the next song in list. Does not matter if it's in a playlist or random song.
I now have Eden installed, Windows 7 64-bit, and of course have a proper Spotify premium account.

Anyone with the same problem? I LOVE the interface, but it's kind of annoying when I can only listen to 10 seconds of the song... hehe.

Read the thread!

Eeebox 1501p htpc, Win7 Ultimate
aTV2 Seas0nPass NitoTV
find quote
oBey Offline
Junior Member
Posts: 12
Joined: Oct 2009
Reputation: 0
Post: #54
Really nice addon, works like a charm. Cant wait for the new features. To bad you cant go to the home screen without the stream closing down.
find quote
mattg42 Offline
Junior Member
Posts: 19
Joined: Oct 2010
Reputation: 0
Post: #55
(2012-03-23 11:11)mattg42 Wrote:  Hi,

I am using Crystalbuntu on a ATV1 / Linux on Eden RC2 with Cyrus skin. I've tried to use the plugin but am getting a script error when I go into it and the initial rotating icon apprears briefly. I never get a login screen on the first run. I've tried to reboot and restart XMBC but same result.

Here is a log file and it might relate to Python versions but I thought Eden was standardised on that now.

http://pastebin.com/download.php?i=9qnpdkpB

Thanks for any input you can provide and for developing this, its what many of us have been waiting for!
Probably related to some XML comments on the skin code that the plugin is unable to parse. Almost sure that is the same bug that happens with the refocus skin. I'm already preparing a fix for it, so it may work also for Cyrus.


Hi again,
I can confirm the Cyrus skin is causing the infinite spinning icon upon initialisation as described above with Eden final, switching to Confluence 2.1 it works fine.


I can perhaps assist with one other problems I've seen which are referred to.

Playlists not loading or icon spinning forever:-
This seems to be related to not the number of playlists but the content of the playlists. I had some old iTunes playlists that were created for my Sonos which got imported long ago and the Spotify import seems to not like them. So by deleting the iTunes playlists caused the Spotify ones to load immediately. I recommend that people check if their Spotify playlists have content that might not be playable in their region or relate to imports playlists.

So in summary the Cyrus skin is causing problems here and playlists can be fixed by removing the imported iTunes ones - at least on my system.
Problems with Username / Password and Second Run

I'm not sure if these are related but by switching to Eden final, Confluence 2.1 on the Crystalbuntu version on a ATV1, the addon works well - no it works brilliantly and it is simply awesome, so thank you!

After fixing the playlist not loading issue, I notice that irrespective of whether I click 'Remember Me' or not click it, the addon never remembers either my username or password and I have to always have to enter it in. Naturally that's not fun with a remote so is their a file or directory that can hard code it into? Also is it a permissions problem that I can fix? The Crystalbuntu distro is quirky on where it stores things so perhaps the default settings aren't being picked up.


Secondly, if I log in, use the addon, have a great time, then exit out back to XBMC main menu, then return in (after manually logging in again), the spinning login circle appears and I have to reboot the box to get it back, it won't respond to the Menu button etc. Upon reboot, the initial login works but the send always hangs. Not sure what the issue is there but if we fix the first issue with remembering logins, then perhaps the second will fix itself.

Thanks again, you made my month!
(This post was last modified: 2012-03-26 14:48 by mattg42.)
find quote
Cthugha Offline
Member
Posts: 77
Joined: Sep 2010
Reputation: 0
Location: Sweden
Thumbs Up  RE: [RELEASE] Spotimc: Another Spotify music addon
Post: #56
Finally a working Spotify addon Rofl

Works great so far, no problems encountered. XBMC Eden Final with skin Xperience1080 running on Win7 x64.

A few screenshots...

[Image: spotimc01.png]
Start screen

[Image: spotimc02.png]
Album view

[Image: spotimc03.png]
Now playing

Feel free to use these shots in your OP.
Nice work!! Have a bear hug! Wink

HTPC Zotac ZBOX HD-ID33BR (Intel Atom D525, NVIDIA NG-ION, 4xBD, etc), 2GB DDR2 RAM, 40GB OCZ Agility2 SSD, Win 8.1, XBMC 13.
SERVER AMD Phenom II X4 910e, Asus M4A785TD-V EVO/U3S6, 8GB DDR3 RAM, 6xHDDs, Win Srv 2012 R2.
A/V BenQ W1400 DLP FHD/3D projector w 104" motor screen, Samsung 40" LCD FHD TV, Onkyo 7.1 receiver, Infinity Alpha speakers, Supra cables.
(This post was last modified: 2012-03-26 19:52 by Cthugha.)
find quote
Sambuccashake Offline
Junior Member
Posts: 5
Joined: Jul 2011
Reputation: 0
Location: Sweden
Post: #57
I can't seem to get it too launch. (Windows 7)

"Script failed" and then the spinning thing.

Reinstalled twice but no change.

http://pastebin.com/7yp7UZyB
(This post was last modified: 2012-03-26 22:02 by Sambuccashake.)
find quote
Cthugha Offline
Member
Posts: 77
Joined: Sep 2010
Reputation: 0
Location: Sweden
Post: #58
(2012-03-26 21:50)Sambuccashake Wrote:  I can't seem to get it too launch. (Windows 7)

"Script failed" and then the spinning thing.

Reinstalled twice but no change.

Running XBMC v11 Eden Final?

I installed the repo and then the addon from there, not a single problem so far.

HTPC Zotac ZBOX HD-ID33BR (Intel Atom D525, NVIDIA NG-ION, 4xBD, etc), 2GB DDR2 RAM, 40GB OCZ Agility2 SSD, Win 8.1, XBMC 13.
SERVER AMD Phenom II X4 910e, Asus M4A785TD-V EVO/U3S6, 8GB DDR3 RAM, 6xHDDs, Win Srv 2012 R2.
A/V BenQ W1400 DLP FHD/3D projector w 104" motor screen, Samsung 40" LCD FHD TV, Onkyo 7.1 receiver, Infinity Alpha speakers, Supra cables.
find quote
baldsasquatch Offline
Junior Member
Posts: 6
Joined: Mar 2012
Reputation: 0
Post: #59
I get Script failed. script.audio.spotify. Then exits.
find quote
Sambuccashake Offline
Junior Member
Posts: 5
Joined: Jul 2011
Reputation: 0
Location: Sweden
Post: #60
(2012-03-26 21:57)Cthugha Wrote:  
(2012-03-26 21:50)Sambuccashake Wrote:  I can't seem to get it too launch. (Windows 7)

"Script failed" and then the spinning thing.

Reinstalled twice but no change.

Running XBMC v11 Eden Final?

I installed the repo and then the addon from there, not a single problem so far.
Yep, Eden final.

Got the zip file from the OP though (github).
Shouldn't be any difference right?

I get "addon enabled" and I can read about it properly in the addon section
Just like all other addons.
find quote
Post Reply