[WIP] PVR Client Addon for XBMC for EPG and full control of Dreambox and DBox2

  Thread Rating:
  • 17 Votes - 4.47 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #451
(2012-05-28 18:44)jdembski Wrote:  
(2012-05-28 17:51)soussef24 Wrote:  Sincerely I'm also a bit lost in naming of Enigma stuff... My DM500HD is using a "build" called newnigma2, but as I understood, there are several "builds" based on Enigma, and I don't think naming your addon after any of them makes more sense than naming it after VU+...

What about Tuxbox PVR? My only concern is to get your very nice addon the attention is deserves Smile

I think tuxbox is actually enigma1 - and the addon does not work with enigma1 devices. Or do I misunderstand the tuxbox/enigma stuff right now?
Tuxbox has nothing to do with Enigma/Enigma2.
Tuxbox = Linux distribution in the box
Enigma/Enigma2 = PVR application in the box.
New boxes uses OpenEmbedded instead as linux distribution and there is a few boxes with Enigma1 like DM600PVR that use OE.
The most logic name would be Enigma2 PVR Client.
(This post was last modified: 2012-07-13 08:59 by Leatherface.)
find quote
cmatte Offline
Junior Member
Posts: 13
Joined: Jul 2012
Reputation: 0
Post: #452
Can I say I really LOVE this plugin?
Is the main reason I'm using XBMC for: sat tv in a room that in no way could get tv/sat signal..here it comes the dm8000 with a newnigma2 image that helps Smile
I really appreciated the option to only fetch data of a single bouquet because using a motorized system I have a really big list on the box of all the satellites and I don't really need it all on the xbmc. Also it goes to download all the epg data and it's mainly empty in many occasions.
I have a question, I'd really like to make it download more than one bouquet only, is this possible with some punctuation? If not, is there a chance there will be this possibility in the future?

Thanks again, lovable work!!!
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #453
(2012-07-13 08:26)Leatherface Wrote:  Another thing is that plugin is broken with newest git, recordings etc works but not streaming channels.
It works perfectly in XBMC Eden and XBMC xvba branch so something has changed in git.

Yes, the API changed, I hope that I will find the time to fix that sometime next week...

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
Solo0815 Offline
Fan
Posts: 337
Joined: Sep 2004
Reputation: 0
Post: #454
@ jdembski:
Can you please have a look at this thread, someone has a problem with your plugin in a PVR-Build for the ATV2
(2012-07-17 10:12)Memphiz Wrote:  Maybe the addon dev itself could jump in here?

I'm loving your plugin with the VU+ Duo! Thx

there are only 10 sorts of people: those who understand binary and those who don't

PC: Kubuntu 14.04 and Win7 --- Raspberry Pi: OpenELEC --- VU+ Duo: VTi 7.0.x --- NAS: OMV 1.0.x with XBMC-Server
find quote
ibramadhan Offline
Member
Posts: 92
Joined: Feb 2012
Reputation: 0
Post: #455
fav, plugin by far!
find quote
MikeRD03 Offline
Junior Member
Posts: 42
Joined: Apr 2005
Reputation: 3
Location: NRW, Germany
Post: #456
I' ve started trying the vuplus plugin with my Dream HD 800se and connection seam fine so far. EPG load and I can stream most of my channels, but not all of them and I have no idea whats going wrong. Roughly ten channel of 50 are affected, some of them are free to air?

Mike
find quote
tnisterworth Offline
Junior Member
Posts: 3
Joined: Mar 2012
Reputation: 0
Post: #457
hello,

first i have to thank jdemski for a wondeful plugin! I tested addon on several os(Windows, IOS, Ubuntu..) and everytime it will go very well!

Now i have to test it on cubox von solid-run.com wih the distro XilkaX with PVR XBMC.

The addon von Jdemski is installed and could be configured, but when i started, i´l get a error message that the plugin could not be started it was a not known error!

This is the xbmc log:
Code:
08:07:31 T:3021193216   DEBUG: ------ Window Init (DialogExtendedProgressBar.xml) ------
08:07:31 T:3021193216   DEBUG: Alloc resources: 0.88ms (0.04 ms skin load)
08:07:31 T:3021193216   DEBUG: ------ Window Deinit (DialogExtendedProgressBar.xml) ------
08:07:31 T:2773988352   DEBUG: Thread EPG updater 2773988352 terminating
08:07:31 T:2695836672  NOTICE: Thread PVR add-on updater start, auto delete: false
08:07:31 T:2695836672   DEBUG: PVR - ResetProperties - creating PVR add-on instance 'VU+ Client'
08:07:31 T:2695836672   DEBUG: InitialiseClient - initialising add-on 'VU+ Client'
08:07:31 T:2695836672   DEBUG: ADDON: Dll Initializing - VU+ Client
08:07:31 T:2695836672   DEBUG: SECTION:LoadDLL(/opt/xbmc/share/xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr)
08:07:31 T:2695836672   DEBUG: Loading: /opt/xbmc/share/xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr
08:07:31 T:2756408320   DEBUG: RunQuery took 3 ms for 0 items query: select * from movieview  ORDER BY dateAdded desc, idMovie desc LIMIT 10
08:07:31 T:2695836672   ERROR: ADDON: Dll VU+ Client - Client returned bad status (4) from Create and is not usable
08:07:31 T:2695836672   DEBUG: PVR - ResetProperties - creating PVR add-on instance 'VU+ Client'
08:07:31 T:2695836672    INFO: Called Add-on status handler for '4' of clientName:VU+ Client, clientID:pvr.vuplus (same Thread=no)
08:07:31 T:2778137600  NOTICE: Thread CAddonStatusHandler:pvr.vuplus start, auto delete: true
08:07:31 T:2695836672   ERROR: PVR - InitialiseClient - can't initialise add-on 'VU+ Client'
08:07:31 T:2756408320   DEBUG: RunQuery took 24 ms for 0 items query: select * from episodeview  ORDER BY dateAdded desc, idEpisode desc LIMIT 10
08:07:31 T:2756408320   DEBUG: RunQuery took 13 ms for 0 items query: select * from musicvideoview  ORDER BY dateAdded desc, idMVideo desc LIMIT 10
08:07:31 T:3021193216   DEBUG: ------ Window Deinit (Pointer.xml) ------
08:07:31 T:2778137600    INFO: Loading skin file: DialogOK.xml
08:07:31 T:2756408320   DEBUG: CRecentlyAddedJob::UpdateTotal() - Running RecentlyAdded home screen update

What can i do?
find quote
haifischjunge Offline
Member
Posts: 85
Joined: Oct 2008
Reputation: 0
Post: #458
if i change the bouquets (add, reorder..) on my box. the plug in finds the new bouquets but doenst change the channel names, just keeps the old ones.

reseting the pvr database doesnt help (seems that only dumps all the epg data)

edit: i already tried deleting the tv21 and epg7 database, but also to no avail, same data stays in.
(This post was last modified: 2012-07-29 23:11 by haifischjunge.)
find quote
tnisterworth Offline
Junior Member
Posts: 3
Joined: Mar 2012
Reputation: 0
Post: #459
The vuplus addon is not Running on XilkaX!!! damn it was a dream not come true!
(This post was last modified: 2012-07-30 19:54 by tnisterworth.)
find quote
haifischjunge Offline
Member
Posts: 85
Joined: Oct 2008
Reputation: 0
Post: #460
Even if I delete all whole XBMC Directory in AppData the old Names still haunt me Sad
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #461
(2012-07-30 08:53)haifischjunge Wrote:  Even if I delete all whole XBMC Directory in AppData the old Names still haunt me Sad

Please try to delete the channeldata.xml file

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
haifischjunge Offline
Member
Posts: 85
Joined: Oct 2008
Reputation: 0
Post: #462
thx. Ill give it a spin when I am at home in the evening.
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #463
How is it going with support for latest git? Tried the socket branch but XBMC crashes with that version.
find quote
haifischjunge Offline
Member
Posts: 85
Joined: Oct 2008
Reputation: 0
Post: #464
(2012-07-30 09:17)jdembski Wrote:  
(2012-07-30 08:53)haifischjunge Wrote:  Even if I delete all whole XBMC Directory in AppData the old Names still haunt me Sad

Please try to delete the channeldata.xml file

thx. that did the trick, I wasnt thinking to check to application directory for config f
find quote
devmc Offline
Junior Member
Posts: 6
Joined: Jul 2012
Reputation: 0
Post: #465
(2012-07-30 19:19)Leatherface Wrote:  How is it going with support for latest git? Tried the socket branch but XBMC crashes with that version.


the same problem overhere with the latest build from xbmc freak

http://www.xbmcfreak.nl/xbmcbuntu-12-04-...y-release/


I love your addon very much mate !

greets
Devmc
find quote
Post Reply