[WIP] PVR Client Addon for XBMC for EPG and full control of Dreambox and DBox2

  Thread Rating:
  • 17 Votes - 4.47 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #526
I guess i have to recompile it then i have compiled with debugs off.
But i think something is broken here because your normal 0.2.8 addon with Eden crashes for me too.
This problem i have since the last days with any version hmms.
And manuelly removing /usr/lib64/xbmc /usr/share/xbmc and .xbmc dir in homedir doesn't help either.
(This post was last modified: 2012-10-03 21:37 by Leatherface.)
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #527
Only thing i can see is this

22:06:14 T:140233820088064 NOTICE: PVRManager - starting up
22:06:14 T:140233811695360 NOTICE: Thread PVR manager start, auto delete: false
22:06:14 T:140233803302656 NOTICE: Thread PVR add-on updater start, auto delete: false
22:06:14 T:140233803302656 DEBUG: RegisterClient - registering add-on 'VU+ / Enigma2 Client'
22:06:14 T:140233803302656 DEBUG: PVR - Create - creating PVR add-on instance 'VU+ / Enigma2 Client'
22:06:14 T:140233803302656 DEBUG: ADDON: Dll Initializing - VU+ / Enigma2 Client
22:06:14 T:140233803302656 DEBUG: SECTION:LoadDLL(/usr/lib64/xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr)
22:06:14 T:140233803302656 DEBUG: Loading: /usr/lib64/xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr

############### END LOG FILE ################

############ END XBMC CRASH LOG #############

And after recompiling with debug option i have same behaviour again. XBMC crashed when starting the PVR addon.
(This post was last modified: 2012-10-03 22:17 by Leatherface.)
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #528
I can confirm this problem now - I'll push a fix ASAP...

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #529
(2012-09-30 17:50)Leatherface Wrote:  Are you looking at teletext subtitle support yet without need to start teletext and manuellt go to subtitle page?

Btw, I'm running frodo right now and I can activate / deactive subtitles in Live-TV via the OSD Audio Settings dialog - just like in any other movies.

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #530
The crashes should be fixed now - but storing the channel data in a xml file is currently broken. I will have a closer look tomorrow - the plugin should be usable again without this...

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
(This post was last modified: 2012-10-05 00:50 by jdembski.)
find quote
sfuchs Offline
Member
Posts: 54
Joined: Sep 2012
Reputation: 0
Location: Moenchengladbach, Germany
Post: #531
Hi jdembski,

thanks for the fix. I did setup my first Windows Build enviroment yesterday and I was suprised that the compiled plugin was not working.

At the moment I am testing with Frodo Nightlies and I use Eden for my stable enviroment. My question is: How can I build a version of your plugin especially for Frodo or Eden? Are there special build options?
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #532
(2012-10-04 23:13)jdembski Wrote:  
(2012-09-30 17:50)Leatherface Wrote:  Are you looking at teletext subtitle support yet without need to start teletext and manuellt go to subtitle page?

Btw, I'm running frodo right now and I can activate / deactive subtitles in Live-TV via the OSD Audio Settings dialog - just like in any other movies.
Yes i can activate it and could do that even in Eden but it only works in TVHeadend but strange thing is that it seems not to work with Frodo anymore but worked in Eden hmms. Maybe it's because i upgraded to latest tvheadend.



(2012-10-05 00:49)jdembski Wrote:  The crashes should be fixed now - but storing the channel data in a xml file is currently broken. I will have a closer look tomorrow - the plugin should be usable again without this...
Hmm strange same problem still here and xot-uzg also crashes for me.
Same problem with latest git from XBMC, XBMC XVBA master and XBMC XVBA october branch.
But now it seems to connect and get some info from the box before it crashes.
I will try compile newest XBMC master again now and see.
Storing data in xml file is not a problem right now because i have already a xml file for my channels.
(This post was last modified: 2012-10-05 08:10 by Leatherface.)
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #533
(2012-10-05 07:47)sfuchs Wrote:  Hi jdembski,

thanks for the fix. I did setup my first Windows Build enviroment yesterday and I was suprised that the compiled plugin was not working.

At the moment I am testing with Frodo Nightlies and I use Eden for my stable enviroment. My question is: How can I build a version of your plugin especially for Frodo or Eden? Are there special build options?
This version works for Eden only:

https://github.com/jdembski/xbmc-addon-vuplus


The other repository is for frodo

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
sfuchs Offline
Member
Posts: 54
Joined: Sep 2012
Reputation: 0
Location: Moenchengladbach, Germany
Post: #534
(2012-10-05 09:56)jdembski Wrote:  
(2012-10-05 07:47)sfuchs Wrote:  Hi jdembski,

thanks for the fix. I did setup my first Windows Build enviroment yesterday and I was suprised that the compiled plugin was not working.

At the moment I am testing with Frodo Nightlies and I use Eden for my stable enviroment. My question is: How can I build a version of your plugin especially for Frodo or Eden? Are there special build options?
This version works for Eden only:

https://github.com/jdembski/xbmc-addon-vuplus


The other repository is for frodo

Thanks for the clarification!
(This post was last modified: 2012-10-05 10:00 by sfuchs.)
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #535
Compiled again today still no luck hmms.
i atleast got xot-uzg to work if i used margros XBMC repo that is a month old but still same crashes on vuplus plugin both with your frodo repo and his master/development repos (not them with timeshift) that worked fine earlier for a few days ago. I don't understand this hmms.
(This post was last modified: 2012-10-05 10:09 by Leatherface.)
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #536
(2012-10-05 10:07)Leatherface Wrote:  Compiled again today still no luck hmms.
i atleast got xot-uzg to work if i used margros XBMC repo that is a month old but still same crashes on vuplus plugin both with tour frodo repo and his master/development repos that worked fine earlier for a few days ago. I don't understand this hmms.

You shouldn't use margro's repository with this plugin as it contains changes (I.e. for timeshift) that are not compatible with the addon yet. Please try the official repository from opdenkamp

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #537
As i said i am using his repos WITHOUT timeshift.
I have tried opdenkamps repo and i have same problem there too.

https://github.com/margro/xbmc-pvr-addon...evelopment
https://github.com/margro/xbmc-pvr-addons/tree/vuplus
https://github.com/jdembski/xbmc-pvr-addons
https://github.com/opdenkamp/xbmc-pvr-addons

Crashes with all them.
And i have tried with all possible versions of frodo i can think of.
I don't understand what i have done this worked fine for a few days ago including margros branches.
My problems started after compiling his timeshifting branch but after that no branch works anymore including official ones.
And as i said earlier removing /usr/lib64/xbmc /usr/share/xbmc and .xbmc doesn't help either.
(This post was last modified: 2012-10-05 10:17 by Leatherface.)
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #538
Sorry, I misunderstood that. So you are using the official master branch from XBMC:

https://github.com/xbmc/xbmc

together with this repository (for the VU+ plugin):

https://github.com/jdembski/xbmc-pvr-addons

If so, can you upload a full debug log (please enable debug logging first)?

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #539
Yes that's the version i am trying right now but it's not working with any version of XBMC.
I will recompile with debug on again.
Something have atleast changed with your branch because i get some information from the box before it crashes atleast.
With margros 0.2.8 that worked fine for me earlier with both official XBMC PVR branch before it merged into XBMC official branch and XBMC XVBA it just crash now before getting any information.
(This post was last modified: 2012-10-05 10:27 by Leatherface.)
find quote
Leatherface Offline
Senior Member
Posts: 177
Joined: Jul 2012
Reputation: 0
Post: #540
I have sent debug in PM now.
That is with a total clean .xbmc with your plugin enabled.
(This post was last modified: 2012-10-05 11:05 by Leatherface.)
find quote
Post Reply