Video/Sound Interference

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nordberg Offline
Junior Member
Posts: 41
Joined: Feb 2012
Reputation: 0
Post: #1
Hi,

I have a problem with every version of XBMC I've run since Dharma.

I'm currently on RC2 and I'm having terrible - what I can best describe as - interference on certain videos. It's like a little bit of "snow" you'd get on your TV if it lost signal. It's worse on older SD videos or streaming content. On 1080p content it's hardly noticable with just little white dots appearing randomly in the picture. It's also evident on the menu screens with the same little white dots. Streaming content is particularly bad but what I've just discovered is that if I bring the main menu screen up with the video behind it, it's faultless. Very odd.

I'm running on a HP Microserver with an ATI 6450 vid card 1080p @ 25Hz.

What changes when I bring the main menu up? Does the video output change in some way?
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #2
It can change your refresh rate. Check and see that you have the latest ATI Drivers (Catalyst 12.1) and maybe try a different refresh rate (50/60hz) if that doesn't clear it up.

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
nordberg Offline
Junior Member
Posts: 41
Joined: Feb 2012
Reputation: 0
Post: #3
Hi,

Thanks for your reply.

Yes, I changed the refresh rate and updated the video drivers to no avail.

One thing I discovered last night is that if I Alt-Tab back to the desktop and then re-maximize XBMC, the problem goes away! Very odd....

Is there an optimal refresh rate? My TV will accept up to 60hz natively. I know if my vid card is set to 50hz them XBMC looks really poor and the speckledy interfernce is more apparent.
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #4
Hi Nordberg, 60hz is probably ideal for you then. Some user's swear by setting "Sync Refresh to Content" in the video settings to force the output frequency to match the video content, trying to avoid dropped frames, especially on 23.796hz material. If you're not noticing frame drops I would leave this option off and let your GPU & TV settle on the refesh rate (probably 60hz).

You can tweak settings by opening the Catalyst Control Center and going to the My Flat Panel TV tab to check on available rates.

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
mike909 Offline
Junior Member
Posts: 13
Joined: Jan 2010
Reputation: 0
Post: #5
Similiar issue here, on an ATI graphics card. I'm wondering if your running 'hot'? See if the following looks familiar:
http://www.youtube.com/watch?v=dV67j2IjTYI
article here:
http://blog.olitee.com/2010/04/overheating-apple-tv/

Here is the output of my "sensors" command (not sure how much it can be trusted):
$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +42.0°C (crit = +91.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +42.0°C (high = +90.0°C, crit = +90.0°C)
Core 1: +42.0°C (high = +90.0°C, crit = +90.0°C)

I'm on Eden xbmcbuntu. None of the afore mentioned refresh settings make any difference for me.
(This post was last modified: 2012-05-11 09:40 by mike909.)
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 3,010
Joined: Jul 2010
Reputation: 60
Location: Munich
Post: #6
nordberg:
Some ATI cards require to refresh the window after actual video mode switch. I have been working on this plus a couple of other changes. Some are included in the xvba experimental builds: http://forum.xbmc.org/showthread.php?tid=116996
find quote