Linux - XBMC crash on launch

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
tosmo Offline
Junior Member
Posts: 1
Joined: Aug 2011
Reputation: 0
Post: #1
I apologize in advance if this is another duplicate thread, but I've been searching for a long time and have not seen any answer to my problem, which follows :

I have weird crashes when I run xbmc on Ubuntu Oneiric. I can run the program right after boot or after a long idle time, and the interface shows up. I get a few seconds of interaction before xbmc segfaults and I get returned to desktop. Symptoms apear quickly, first with sound completely gone after a second, then it's the crash.

I then launch xbmc again, and it works properly. I get to play videos, with sound.

If the media center is left to idle, it will crash in a matter of hours.

I suspect it has to do with the movieDB scrapper, as when I try to force it to scan for movies, xbmc crashes in the same manner as described. However, I'm unable to disable it, so I can't confirm this hypothesis....

My setup is the following:

Intel DG45FC mini-ITX motherboard with 2GB ram
Intel Core 2 Duo E7200
nVidia GeForce 210 512MB ( ClubPC 1x PCI-E addon card )

Audio sent via NVIDIA HDMI

integrated intel graphics adapter disabled in bios and driver blacklisted in modprobe

XBMC EDEN Beta 3 from Teamxbmc/unstable ppas ( or so it says )

xbmc crashlog:
http://pastebin.com/MqZZrJyc

lspci:
Code:
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LF-2 Gigabit Network Connection
00:1a.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.3 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 4
00:1d.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
02:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 210] (rev a2)
02:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

uname -a
Code:
Linux sparkie 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


Hmm, in a fit of sanity, I tried :

Code:
xbmc --version
XBMC Media Center 11.0-BETA1 Git:Unknown
Copyright (C) 2005-2011 Team XBMC - http://www.xbmc.org

Any insight why I get stuck with Beta 1 when I clearly defined the latest ppas in apt/source.list.d ?
(This post was last modified: 2012-03-20 17:20 by tosmo.)
find quote