xbmc.gui bump to 3.0.1

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
pecinko Offline
Donor
Posts: 3,796
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #1
Ronie, JM

we would need GUI bump

<import addon="xbmc.gui" version="3.0.1"/>

My skins:

Amber
Quartz

find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,230
Joined: Oct 2003
Reputation: 177
Post: #2
Have requested the committer to bump the API.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
Montellese Offline
Team-XBMC Developer
Posts: 3,710
Joined: Jan 2009
Reputation: 34
Location: Switzerland
Post: #3
@pecinko: xbmc.gui bumped to 3.0.1 with backwards-compatibility to 3.00

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

[Image: badge.gif]
find quote
pecinko Offline
Donor
Posts: 3,796
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #4
(2012-03-26 01:04)Montellese Wrote:  @pecinko: xbmc.gui bumped to 3.0.1 with backwards-compatibility to 3.00

Cheers!

My skins:

Amber
Quartz

find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #5
OK so I'm confused ? anyone care to explain a little history to this statement
find quote
Jezz_X Offline
Team-XBMC Skinner
Posts: 5,289
Joined: Jun 2006
Reputation: 57
Location: Earth
Post: #6
right never mind its all about the pinned topic and changes for the next version rather than somthing broke with a new feature and needed a backwards compatibility check
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,230
Joined: Oct 2003
Reputation: 177
Post: #7
Yup - API was bumped so the skin that depends on the feature will be able to specify they want 3.0.1 and thus won't be installable on Eden.

(IMO this feature by itself isn't useful enough for a skinner to bother doing that - it won't cause issues if they use it and the infolabels aren't there).

We'll try and keep bumping the API in this way so that skinners should always have a version they can rely on.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
pecinko Offline
Donor
Posts: 3,796
Joined: Dec 2008
Reputation: 51
Location: Prague / Belgrade
Post: #8
(2012-03-26 06:01)jmarshall Wrote:  (IMO this feature by itself isn't useful enough for a skinner to bother doing that - it won't cause issues if they use it and the infolabels aren't there).

Although this is technically true, installing such skin in Eden would lead to user ending up with half of screen empty (e.g. season posters used instead of episode thumbs) causing avalanche of support questions and assumptions that either skin or xbmc is buggy.

My skins:

Amber
Quartz

(This post was last modified: 2012-03-26 11:41 by pecinko.)
find quote