Eden Crash on files with DD/DTS

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jomanscool2 Offline
Junior Member
Posts: 11
Joined: Mar 2012
Reputation: 0
Post: #1
http://pastebin.com/tcRuMaSk

Running 11.0 from the DMG on OSX 10.7.3 on an i7 Hackintosh with GA-X58A-UD3R and a RadeonHD 5850. XBMC crashes at start of playback on files with DTS or DD audio streams with both onboard and my PCI-E X-Fi Titanium HD.

Code:
<audiooutput>
        <ac3passthrough>true</ac3passthrough>
        <audiodevice>Line Out (Green Rear)</audiodevice>
        <channellayout>0</channellayout>
        <dontnormalizelevels>true</dontnormalizelevels>
        <dtspassthrough>true</dtspassthrough>
        <mode>0</mode>
        <passthroughaac>false</passthroughaac>
        <passthroughmp1>false</passthroughmp1>
        <passthroughmp2>false</passthroughmp2>
        <passthroughmp3>false</passthroughmp3>
    </audiooutput>

That is from the guisetting.xml - it is what I believe is the audio settings. I am trying to play it back over the analog 2 channel output from either my onboard or my X-Fi, and neither work.

Any idea what the problem is? Thank you.
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,221
Joined: Oct 2003
Reputation: 178
Post: #2
Turn off VDA decoding.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
jomanscool2 Offline
Junior Member
Posts: 11
Joined: Mar 2012
Reputation: 0
Post: #3
(2012-04-01 07:30)jmarshall Wrote:  Turn off VDA decoding.

Thank you!
find quote